Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel: Fomattazione Condizionale Data non Valida

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel: Fomattazione Condizionale Data non Valida

Postdi Dylan666 » 23/09/20 11:38

Avrei bisogno di usare la formattazione condizionale per validare i dati di alcuni CSV.
Per controllare se una cella contiene numeri (e in tal caso colorarla di verde) ho usato =VAL.NUMERO(A2)

Ma per le celle contenenti del testo con delle dato nel formato gg/mm/aaaa come faccio a verificare se la data è valida?
A che livelli posso arrivare con le sole formule senza complicarle troppo?

Altrimenti suppongo andrei meglio con le REGEX ma suppongo debba usare il VBS e in quel caso un esempio mi aiuterebbe

Grazie
Avatar utente
Dylan666
Moderatore
 
Post: 38501
Iscritto il: 18/11/03 16:46

Sponsor
 

Re: Excel: Fomattazione Condizionale Data non Valida

Postdi Anthony47 » 23/09/20 13:38

Nell'ipotesi che la cella contenga una stringa, prova se risolviamo con una formattazione condizionale con questa formula:
Codice: Seleziona tutto
=SE.ERRORE(DATA.VALORE(A2);FALSO)

Dovrebbe risultare "vero" se e' una data

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17155
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel: Fomattazione Condizionale Data non Valida

Postdi Dylan666 » 23/09/20 15:20

Perfetto grazie!
Avatar utente
Dylan666
Moderatore
 
Post: 38501
Iscritto il: 18/11/03 16:46


Torna a Applicazioni Office Windows


Topic correlati a "Excel: Fomattazione Condizionale Data non Valida":


Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti