Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Estrarre Numeri Da Una stringa

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Estrarre Numeri Da Una stringa

Postdi Francesco6918 » 14/05/20 19:28

Una Buonasera a tutti se gentilmente qualcuno può aiutarmi a modificare la mia formula o sostituirla , nella cella F9 o una stringa con 10 numeri, vorrei estrarre da questa stringa tutti i numeri se corrispondono con i numeri del intervallo H4:AA4 , il risultato riportarlo trascinando la formula nel intervallo H9 :Q9 (10 NUMERI), con la mia formula (NON SO SE SIA CORRETTA) o riscontrato un errore nella cella N9 (IL NUMERO 08 NON E PRESENTE NELLA STRINGA F9) non capisco dove posso modificarla,vi allego il file.

Formula : =SE.ERRORE(INDICE($H$4:$AA$4;AGGREGA(15;6;RIF.COLONNA($H$4:$AA$4)-RIF.COLONNA($H$4)+1/(($H$4:$AA$4<>"")*(RICERCA(DESTRA($H$4:$AA$4;2);$F$9;1)*RICERCA(SINISTRA($H$4:$AA$4;2);$F$9;1))>0);COLONNE($H$9:H9)));"")

DISTINTI SALUTI

http://www.filedropper.com/prova_5
Francesco6918
Utente Senior
 
Post: 200
Iscritto il: 04/03/11 11:20

Sponsor
 

Re: Estrarre Numeri Da Una stringa

Postdi D@nilo » 14/05/20 20:15

Ciao

in H9

Codice: Seleziona tutto
=SE.ERRORE(INDICE($H$4:$AA$4;AGGREGA(15;6;RIF.COLONNA($H$4:$AA$4)-7/(TROVA(TESTO($H$4:$AA$4;"00");$F$9)>0);RIF.COLONNA(A$1)));"")


trascina a destra

Edit:
Applicato Tag "[ Code ]"
Anthony


Avatar utente
D@nilo
Utente Junior
 
Post: 34
Iscritto il: 12/05/18 13:15
Località: ROMA

Re: Estrarre Numeri Da Una stringa

Postdi D@nilo » 14/05/20 20:23

Non capisco...l'editor del forum taglia la formula...la scrivo in due pezzi

=SE.ERRORE(INDICE($H$4:$AA$4;AGGREGA(15;6;RIF.COLONNA($H$4:$AA$4)-7/(TROVA(TESTO($H$4:$AA$4;"00");$F$9)>0)

;RIF.COLONNA(A$1)));"")
Avatar utente
D@nilo
Utente Junior
 
Post: 34
Iscritto il: 12/05/18 13:15
Località: ROMA

Re: Estrarre Numeri Da Una stringa

Postdi Francesco6918 » 15/05/20 09:06

Ciao D@nilo grazie della soluzione funziona

Saluti
Francesco6918
Utente Senior
 
Post: 200
Iscritto il: 04/03/11 11:20

Re: Estrarre Numeri Da Una stringa

Postdi Anthony47 » 15/05/20 09:21

Grazie D@nilo per i tuoi interventi

Non ho capito la storia del codice tagliato; comunque applicando il Tag "code" la visibilita' migliora

Ciao a tutti
Avatar utente
Anthony47
Moderatore
 
Post: 17003
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Estrarre Numeri Da Una stringa":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti