Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel: testare risultato cerca.vert

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel: testare risultato cerca.vert

Postdi karug64 » 13/05/20 10:26

Salve a tutti.

Avrei bisogno di concatenare due cerca.vert in uno all'operatore logico "E".

Ho scritto questa formula:

Codice: Seleziona tutto
=SE(E(CERCA.VERT(EU2;Query!$B$2:$B$14244;1;FALSO);(CERCA.VERT(AY2;Query!$A$2:$A$14244;1;FALSO)));"OK";"NOK")


che non funziona (ritorna #VALORE).

Verificando i due cerca.vert singolarmente, ritornato il risultato richiesto. Quindi,

=CERCA.VERT(EU2;Query!$B$2:$B$14244;1;FALSO) restituisce "CARLO" e
=CERCA.VERT(AY2;Query!$A$2:$A$14244;1;FALSO) restituisce "GIULIO"

il risultato sperato dovrebbe essere, quindi, "OK"

Come va modificata ?

Grazie
Office 2010
karug64
Utente Senior
 
Post: 741
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: Excel: testare risultato cerca.vert

Postdi Anthony47 » 13/05/20 21:35

Ripensaci: la sintassi della funzione Se e'
Se(Test; Valore se test Vero; Valore se test Falso)

Ora nella tua formula, in E(Cerca.Vert Uno; Cerca.Vert due) dov'e' il Test??

Forse volevi fare
Codice: Seleziona tutto
=SE(E(CERCA.VERT(EU2;Query!$B$2:$B$14244;1;FALSO)="Carlo";(CERCA.VERT(AY2;Query!$A$2:$A$14244;1;FALSO)="Giulio"));"OK";"NOK")


Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17003
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel: testare risultato cerca.vert

Postdi karug64 » 14/05/20 20:50

Grazie!!
Office 2010
karug64
Utente Senior
 
Post: 741
Iscritto il: 20/11/11 21:22


Torna a Applicazioni Office Windows


Topic correlati a "Excel: testare risultato cerca.vert":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti