Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

contare tutti i turni singolo tec

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

contare tutti i turni singolo tec

Postdi raimea » 04/05/20 17:46

ciao
dovrebbe essere l ultimo sforzo su questo file !

tramite una macro , vorrei riuscire a contare tutti i turni
di un singolo tecnico e riportarli in foglio >>> "tec_statis "

il tecnico da ricercare lo scrivo in cella D6
la data da cui partire a contare in D3

il file e composto da molti fogli
quindi il foglio dove cercare e' scritto in D4

in fgl "tec_statis " i turni da verificare e contare sono 10
piu il numero di settimane che compongono il calendario attuale

il risultato lo vorrei in col G da riga 7

1_il primo controllo da fare e' sapere di quante settimane
e composto il calendario
x fare questo basta contare la lettera L (i lunedi)
di riga 1 di ogni foglio.

poi:

2_ quanti turni B solo dal lun_ven
3_ quanti turni B solo di sabato
4_ quanti turni B solo di domenica

5_ quanti turni 1 solo dal lun_ven[url][/url]
6_ quanti turni 1 solo di sabato

7_ quanti turni 2 solo di lun_ven
8_ quanti turni 2 solo di sabato

9_ quanti turni LL solo dal lun_ven
10_ quanti turni X solo dal lun_ven
11_ quanti turni RI solo dal lun_ven

Immagine


vi allego un file x test

https://www.dropbox.com/s/0ytwfpnylsip6hu/singolo_tec_statist_2.rar?dl=0


grazie
http://www.lelugarine.eu
S.O. Seven7, Excell 2010
Avatar utente
raimea
Utente Senior
 
Post: 1244
Iscritto il: 11/02/10 07:33
Località: lago

Sponsor
 

Re: contare tutti i turni singolo tec

Postdi Anthony47 » 05/05/20 00:39

Il quesito si puo' risolvere anche tramite formule, "giocando" con Indice, Confronta e Indiretto.
Ad esempio, in G8
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(INDIRETTO("'"&$D$4&"'!I2:NZ2");2)<6);--(INDICE(INDIRETTO("'"&$D$4&"'!I1:NZ100");CONFRONTA($D$6;INDIRETTO("'"&$D$4&"'!D1:D100");0);0)=""&E8))

Poi la copi verso il basso
Viene usato INDIRETTO per far dipendere la formula dal nome foglio scritto in D4
CONFRONTA invece determina su quale riga si trova il nominativo prescelto, e viene usato per scegliere una riga nella matrice indicata in INDICE.

La parte "<6" indica Lu-Ve; quindi laddove vuoi invece solo Sab modificherai in "=6", e dove vuoi la Dom modificherai in "=7"

Fai sapere...
Avatar utente
Anthony47
Moderatore
 
Post: 17044
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: contare tutti i turni singolo tec

Postdi Anthony47 » 05/05/20 00:54

Noto che c'e' anche una data di partenza di cui tenere conto, pertanto bisogna introdurre un terzo campo in Matr.Somma.Prodotto:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(INDIRETTO("'"&$D$4&"'!I2:NZ2");2)<6);--(INDIRETTO("'"&$D$4&"'!I2:NZ2")>=$D$3);--(INDICE(INDIRETTO("'"&$D$4&"'!I1:NZ100");CONFRONTA($D$6;INDIRETTO("'"&$D$4&"'!D1:D100");0);0)=""&E8))

Valgono le stesse considerazioni fatte sopra su come modificare la formula per Sab e Dom

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17044
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: contare tutti i turni singolo tec

Postdi raimea » 05/05/20 06:10

ciao
ho riportato come descritto la formula nel fgl tec_statist
nella cornice rossa di SX ci sono i calcoli fatti a mano

il calcolo dei turni B L_V mi viene errato
da 27 dovrebbe esere 35

anche turni LL L_V mi da 1 dovrebbe essere 2

ho provato ad adattare la formula
per contare i lunedi (punto 1) ma mi da errore
questo come l ho scritta

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(INDIRETTO("'"&$D$4&"'!I1:NZ1");2)=1);--(INDIRETTO("'"&$D$4&"'!I1:NZ1")>=$D$3);--(INDICE(INDIRETTO("'"&$D$4&"'!I1:NZ100");CONFRONTA($D$6;INDIRETTO("'"&$D$4&"'!D1:D100");0);0)=""&E7))


so che potrei farlo con:
Codice: Seleziona tutto
=CONTA.SE('tec bassi'!I1:NZ1;"L")

ma non terrebbe conto di quale foglio analizzare,andrebbe modif manualmente ogni volta


Immagine


ciao
http://www.lelugarine.eu
S.O. Seven7, Excell 2010
Avatar utente
raimea
Utente Senior
 
Post: 1244
Iscritto il: 11/02/10 07:33
Località: lago

Re: contare tutti i turni singolo tec

Postdi Anthony47 » 05/05/20 08:17

Secondo me i calcoli che ritieni esatti partono dalla prima data presente nel foglio, cioe' ignorano la data di partenza impostata in D3. Se D3 e' da ignorare allora va bene la formula che ti avevo proposto nella prima risposta.
Quanto al calcolo in riga 7 (e probabilmente in riga 19) l'avevo proprio dimenticato; potresti usare:
in G7
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(INDIRETTO("'"&$D$4&"'!I2:NZ2");2)=1);--(INDIRETTO("'"&$D$4&"'!I2:NZ2")>=$D$3))

e in G19 (tramite il "noto" adattamento del Sabato=6)
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(INDIRETTO("'"&$D$4&"'!I2:NZ2");2)=6);--(INDIRETTO("'"&$D$4&"'!I2:NZ2")>=$D$3))

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17044
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: contare tutti i turni singolo tec

Postdi raimea » 05/05/20 17:12

ciao
e' tutto ok

sono correte gia' le formule del 1Mo Post !!

errore MIO
non avevo considerato che il tot 35 B L_V
l' ho ottenuto partendo dal gg 20-4
mentre nel file c'e la data 1-5 !!

Pardon

e Grazie
http://www.lelugarine.eu
S.O. Seven7, Excell 2010
Avatar utente
raimea
Utente Senior
 
Post: 1244
Iscritto il: 11/02/10 07:33
Località: lago

Re: contare tutti i turni singolo tec

Postdi raimea » 06/06/20 07:08

ciao

vorrei far contare anche le reperibilita' in G15
del dipendente selezionato.

vorrei contare quante volte c'e la scritta -reperibile-

ho riportato la stessa formula
che funziona correttamente per gli altri casi
ma no ho avuto successo.
per questa scritta non mi interessa il controllo del giorno LU_DO
vorrei solo contare le scritte.

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(INDIRETTO("'"&$D$4&"'!I2:NZ2");2)<6);--(INDIRETTO("'"&$D$4&"'!I2:NZ2")>=$D$3);--(INDICE(INDIRETTO("'"&$D$4&"'!I1:NZ300");CONFRONTA($D$6;INDIRETTO("'"&$D$4&"'!D1:D300");0);0)=""&E15))


provata io :

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(INDIRETTO("'"&$D$4&"'!I2:NZ2")>=$D$3);--(INDICE(INDIRETTO("'"&$D$4&"'!I1:NZ300");CONFRONTA($D$6;INDIRETTO("'"&$D$4&"'!D1:D300");0);0)=""&E15))


mi vengono dubbi perche' PURTROPPO
la scritta - reperibile - e' stata messa
in unione celle e la devo lasciare cosi

vi allego il file

https://www.dropbox.com/s/w3xjh59ses5v34u/conta_reperibile.rar?dl=0

grazie
http://www.lelugarine.eu
S.O. Seven7, Excell 2010
Avatar utente
raimea
Utente Senior
 
Post: 1244
Iscritto il: 11/02/10 07:33
Località: lago

Re: contare tutti i turni singolo tec

Postdi Anthony47 » 06/06/20 14:30

Potresti provare con:
Codice: Seleziona tutto
=SOMMA(--(SE((INDIRETTO("'"&D4&"'!I2:DB2")>=D3)*(INDIRETTO("'"&D4&"'!I2:DB2")<=tec_statist!G3);INDICE(INDIRETTO("'"&D4&"'!I1:DB130");1+CONFRONTA(D6;INDIRETTO("'"&D4&"'!D:D");0);0);"")="Reperibile"))

Matriciale, cioe' Contr-Maiusc-Enter

Come intervalli ho usato quelli compilati nel file allegato; eventualmente devi espandere per adattare

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17044
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: contare tutti i turni singolo tec

Postdi raimea » 06/06/20 14:33

ciao

ottima ... (come sempre )

tutto ok

grazie mille
http://www.lelugarine.eu
S.O. Seven7, Excell 2010
Avatar utente
raimea
Utente Senior
 
Post: 1244
Iscritto il: 11/02/10 07:33
Località: lago

Re: contare tutti i turni singolo tec

Postdi Anthony47 » 06/06/20 14:34

Si, ma prima provala :D :lol:
Avatar utente
Anthony47
Moderatore
 
Post: 17044
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: contare tutti i turni singolo tec

Postdi raimea » 06/06/20 14:56

provata ... provata...

ero al pc
come visto la tua risposta
(ero in trepida attesa... :D :D )

ripeto : tutto ok :)

ciao
http://www.lelugarine.eu
S.O. Seven7, Excell 2010
Avatar utente
raimea
Utente Senior
 
Post: 1244
Iscritto il: 11/02/10 07:33
Località: lago


Torna a Applicazioni Office Windows


Topic correlati a "contare tutti i turni singolo tec":


Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti