Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Media Ultimi 3 mesi + SE in base al risultato

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 08/04/20 14:29

Ciao a tutti,
è un pò che non scrivo ma non per questo non manco di avere bisogno di voi :D
vi chiedo se potete aiutarmi con questo questo foglio.
https://docs.google.com/spreadsheets/d/ ... sp=sharing


ho una tabella di dati con un elenco di nominativi (COL G)
ordinati per mese (COL A)
ad ogni mese viene indicato un importo incassato (COL I)


ogni nuovo mese viene aggiunto in COL A il mese di riferimento
e l'incasso relativo.


Nella COL M vorrei avere, attraverso una formula,
la media degli ultimi tre mesi di incasso (COL I),
riferiti al nominativo scritto in COL L

Fatto questo, nella COL N dovrebbe comparire un risultato che è frutto di uno schema (che ho segnato nel foglio condiviso).

Nella COL P e Q
ho inserito come dovrebbe essere il risultato finale.


Spero davvero possiate aiutarmi.
Grazie per l'attenzione.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 157
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi D@nilo » 08/04/20 16:16

Buonasera
in M4 da trascinare in basso
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((($G$2:$G$28=$L4)*(ANNO($A$2:$A$28)=ANNO(OGGI()))*(MESE($A$2:$A$28)>=MESE(OGGI())-3))*$I$2:$I$28)/3



in N4 da trascinare in basso

Codice: Seleziona tutto
=SE(M4<=9999;1000;SE(E(M4>=10000;M4<=16999);1400;1600))
Avatar utente
D@nilo
Utente Junior
 
Post: 34
Iscritto il: 12/05/18 13:15
Località: ROMA

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 09/04/20 11:24

wow.
Grazie davvero D@nilo

Per quanto riguarda questa
Codice: Seleziona tutto
=SE(M4<=9999;1000;SE(E(M4>=10000;M4<=16999);1400;1600))


volevo inserire un ulteriore variabile ma sto creando solo casini.

Le regole base sono quelle, ma SE in

T1 è indicato un valore compreso tra 1 e 3, il risultato di quella formula sarà sempre 1200.

Codice: Seleziona tutto
=SE((T1<=3);1200)--=SE(M4<=9999;1000;SE(E(M4>=10000;M4<=16999);1400;1600))

Ho provato così ma il risultato non è ovviamente corretto :undecided:

Grazie dell'aiuto.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 157
Iscritto il: 20/04/09 17:45

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi D@nilo » 09/04/20 13:09

ciao

=SE(T1<=3;1200;SE(M4<=9999;1000;SE(E(M4>=10000;M4<=16999);1400;1600)))
Avatar utente
D@nilo
Utente Junior
 
Post: 34
Iscritto il: 12/05/18 13:15
Località: ROMA

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 14/04/20 13:51

Gentilissimo grazie.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 157
Iscritto il: 20/04/09 17:45


Torna a Applicazioni Office Windows


Topic correlati a "Media Ultimi 3 mesi + SE in base al risultato":


Chi c’è in linea

Visitano il forum: Nessuno e 16 ospiti