Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Media Ultimi 3 mesi + SE in base al risultato

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 08/04/20 14:29

Ciao a tutti,
è un pò che non scrivo ma non per questo non manco di avere bisogno di voi :D
vi chiedo se potete aiutarmi con questo questo foglio.
https://docs.google.com/spreadsheets/d/ ... sp=sharing


ho una tabella di dati con un elenco di nominativi (COL G)
ordinati per mese (COL A)
ad ogni mese viene indicato un importo incassato (COL I)


ogni nuovo mese viene aggiunto in COL A il mese di riferimento
e l'incasso relativo.


Nella COL M vorrei avere, attraverso una formula,
la media degli ultimi tre mesi di incasso (COL I),
riferiti al nominativo scritto in COL L

Fatto questo, nella COL N dovrebbe comparire un risultato che è frutto di uno schema (che ho segnato nel foglio condiviso).

Nella COL P e Q
ho inserito come dovrebbe essere il risultato finale.


Spero davvero possiate aiutarmi.
Grazie per l'attenzione.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi D@nilo » 08/04/20 16:16

Buonasera
in M4 da trascinare in basso
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((($G$2:$G$28=$L4)*(ANNO($A$2:$A$28)=ANNO(OGGI()))*(MESE($A$2:$A$28)>=MESE(OGGI())-3))*$I$2:$I$28)/3



in N4 da trascinare in basso

Codice: Seleziona tutto
=SE(M4<=9999;1000;SE(E(M4>=10000;M4<=16999);1400;1600))
Avatar utente
D@nilo
Utente Junior
 
Post: 36
Iscritto il: 12/05/18 13:15
Località: ROMA

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 09/04/20 11:24

wow.
Grazie davvero D@nilo

Per quanto riguarda questa
Codice: Seleziona tutto
=SE(M4<=9999;1000;SE(E(M4>=10000;M4<=16999);1400;1600))


volevo inserire un ulteriore variabile ma sto creando solo casini.

Le regole base sono quelle, ma SE in

T1 è indicato un valore compreso tra 1 e 3, il risultato di quella formula sarà sempre 1200.

Codice: Seleziona tutto
=SE((T1<=3);1200)--=SE(M4<=9999;1000;SE(E(M4>=10000;M4<=16999);1400;1600))

Ho provato così ma il risultato non è ovviamente corretto :undecided:

Grazie dell'aiuto.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi D@nilo » 09/04/20 13:09

ciao

=SE(T1<=3;1200;SE(M4<=9999;1000;SE(E(M4>=10000;M4<=16999);1400;1600)))
Avatar utente
D@nilo
Utente Junior
 
Post: 36
Iscritto il: 12/05/18 13:15
Località: ROMA

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 14/04/20 13:51

Gentilissimo grazie.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 01/01/21 12:08

Ciao,
in merito a questa formula,
oggi che è il 1 gennaio 2021
mi sono trovato di fronte a tutti risultati pari a 0.

La formula, facendo la media delle ultime 3 celle con la data,
non tiene conto delle date dei mesi del 2020
ma ora che siamo nel 2021, accetta solo annualità 2021

=MATR.SOMMA.PRODOTTO((($G$2:$G$28=$L4)*(ANNO($A$2:$A$28)=ANNO(OGGI()))*(MESE($A$2:$A$28)>=MESE(OGGI())-3))*$I$2:$I$28)/3

è possibile fare in modo che tenga conto anche dell'accavallamento di anno?

Grazie e buon anno a tutti
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi Anthony47 » 01/01/21 12:53

Non capisco se e' la continuazione del quesito precedente (nel qual caso dovresti riallegare il file coi dati che non e' piu' disponibile) o se e' un quesito nuovo, nel qual caso dovresti almeno descrivere la struttura dei dati su cui lavora (ma ovviamente e' meglio se pubblichi un file esemplificativo sui cui lavorare) e che che cosa vorresti calcolare.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17658
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 02/01/21 18:50

Ciao,
perdonate. In effetti non ho inserito il documento di test.

La formula che mi è stata data nei precedenti post,
ha funzionato correttamente fino al 31.12.2020

Dal 01.01.2021 ha smesso di funzionare. :-?

La formula dovrebbe prendere gli ultimi 3 mesi del sig. "pippo" o "salsiccia"
e fare la media. (vedi allegato)

Quindi se oggi siamo nel mese di gennaio,
andrà a visionare

OTT 20
NOV 20
DIC 20

Ho inserito la formula in G4 e G5

https://docs.google.com/spreadsheets/d/ ... sp=sharing

Grazie ancora del supporto.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi Anthony47 » 02/01/21 20:11

Prova in G4
Codice: Seleziona tutto
=SOMMA.PIÙ.SE($D$1:$D$1000;$B$1:$B$1000;">"&DATA.MESE(OGGI()-GIORNO(OGGI());-3);$C$1:$C$1000;F4)

Poi copia in G5

Questa in Gen 2021 somma dal 1° di Ott in avanti (quindi anche eventuali righe datate xx gen 2021); e' giusto così??

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17658
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 03/01/21 12:12

Ciao,
grazie. La formula fa la somma, mentre a me servirebbe la "media" degli ultimi 3 mesi indicati,
anche se questi si accavallano tra il 2020 ed il 2021.

Ad esempio, quando sarò a marzo 2021
ed indicherò dati fino a febbraio 2021
mi servirà la media di

dicembre 2020
gennaio 2021
febbraio 2021

Grazie mille ancora
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi Anthony47 » 03/01/21 12:48

Ho notato solo adesso quel "/3" finale nella formula con MATR.SOMMA.PRODOTTO

Quindi o aggiungi /3 in fondo alla formula che ti ho dato, oppure (mia preferenza) passi alla funzione Media.Più.Se; cioe' in G4
Codice: Seleziona tutto
=MEDIA.PIÙ.SE($D$1:$D$1000;$B$1:$B$1000;">"&DATA.MESE(OGGI()-GIORNO(OGGI());-3);$C$1:$C$1000;F4)


Fai sapere...
Avatar utente
Anthony47
Moderatore
 
Post: 17658
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Media Ultimi 3 mesi + SE in base al risultato

Postdi contiend » 03/01/21 17:27

Ciao,
ho utilizzato MEDIA.PIU.SE e funziona.

Grazie .
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 166
Iscritto il: 20/04/09 17:45


Torna a Applicazioni Office Windows


Topic correlati a "Media Ultimi 3 mesi + SE in base al risultato":


Chi c’è in linea

Visitano il forum: Nessuno e 57 ospiti