Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

indiretto indirizzo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

indiretto indirizzo

Postdi rombotuono » 27/01/20 10:42

Buongiorno
utilizzo la funzione indiretto indirizzo nel foglio archivio per inserire dei valori in una tabella sempre nello stesso foglio chiaramente tutto procede perfettamente.

chiedo se è possibile utilizzare la stessa formula per estrarre dei dati da un altro foglio che si chiama "dati" nel foglio archivio dove utilizzo la formula.
grazie


=SE.ERRORE(SE(VAL.ERRORE(CERCA.VERT($W55;(INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4;7)):INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4+$D$1;9)));3;0));CERCA.VERT($W55;(INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4;9)):INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4+$D$1;)));1;0);CERCA.VERT($W55;(INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4;7)):INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4+$D$1;9)));3;0));"")
rombotuono
Utente Junior
 
Post: 56
Iscritto il: 09/11/18 17:27

Sponsor
 

Re: indiretto indirizzo

Postdi wallace&gromit » 28/01/20 08:34

Nella funzione indiretto devi aggiungere il nome del foglio tra virgolette, come nell'esempio:
Codice: Seleziona tutto
=INDIRETTO(INDIRIZZO(1;1;;;"Foglio2"))

nota che ho aggiunto due volte ";" perché non mi interessa specificare il tipo di riferimento alla cella, excel lo capisce da sé.
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: indiretto indirizzo

Postdi rombotuono » 28/01/20 13:48

ciao
ho provato ma la formula non funziona da errore Valore
ho provato cosi
=CERCA.VERT($A45;(INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4;7;;;"Archivio!")):INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4+$D$1;9;;;"Archivio!")));3;0)
grazie
rombotuono
Utente Junior
 
Post: 56
Iscritto il: 09/11/18 17:27

Re: indiretto indirizzo

Postdi Anthony47 » 28/01/20 14:21

Senza sapere che cosa c'e' scritto nelle celle che usi possiamo solo far ricorso alle nostre scarse capacita' divinatorie; pero' devi concatenare correttamente le stringhe calcolate, quindi, guardando alla sola sintassi:
=CERCA.VERT($A45;(INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4;7;;;"Archivio!"))&":"&INDIRETTO(INDIRIZZO(($Y56-1)*$D$1+$Y56*4+$D$1;9;;;"Archivio!")));3;0)

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: indiretto indirizzo

Postdi wallace&gromit » 28/01/20 15:08

A me funziona solo se non metto il punto esclamativo dopo il nome del foglio, come da mio esempio
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: indiretto indirizzo

Postdi rombotuono » 28/01/20 16:19

ho provato ma nulla di fatto sempre tutto ok ma non funziona
vorrei ottenere il dato presente nel foglio archivio --- nel foglio pppppp
allego file
http://www.filedropper.com/stat
grazie
rombotuono
Utente Junior
 
Post: 56
Iscritto il: 09/11/18 17:27

Re: indiretto indirizzo

Postdi wallace&gromit » 28/01/20 16:40

La formula:
Codice: Seleziona tutto
=INDIRETTO(INDIRIZZO(($C3-1)*$D$1+$C3*4;7;;;"Archivio"))

messa in una cella del foglio pppp funziona (restituisce Luton Town), quindi il problema sta altrove, non so dove perché mi perdo nelle tue formule.

Propongo quindi che esponi bene le tue esigenze e magari invece di rattoppare qualcosa che ha una falla troviamo una formula alternativa.
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: indiretto indirizzo

Postdi rombotuono » 28/01/20 17:39

la formula deve dare come risultato Middlesbrough utilizzando la seguente formula
=CERCA.VERT($W4;(INDIRETTO(INDIRIZZO(($H18-1)*$D$1+$H18*4;7)):INDIRETTO(INDIRIZZO(($H18-1)*$D$1+$H18*4+$D$1;9)));3) nel foglio archivio funziona perfettamente ma non funziona quando lavoro nel foglio pppppp

nel file che ho postato bisogna sostituire "Archivio!" con "Archivio"))

tu utilizzi soltanto una porzione di formula cioè questa
=INDIRETTO(INDIRIZZO(($C3-1)*$D$1+$C3*4;7;;;"Archivio")) quindi non da il risultato voluto
grazie
rombotuono
Utente Junior
 
Post: 56
Iscritto il: 09/11/18 17:27

Re: indiretto indirizzo

Postdi wallace&gromit » 28/01/20 21:14

Sì, ero conscio di entrambe le cose, che non bisogna mettere il punto esclamativo e che la formula che ti ho dato era solo una parte, ma almeno chiarivo che quella parte funziona, il resto della formula è alquanto complesso.
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: indiretto indirizzo

Postdi Anthony47 » 28/01/20 23:30

La parte ((INDIRIZZO(($C3-1)*$D$1+$C3*4;7;;;"Archivio!"))&":"&@INDIRETTO(INDIRIZZO(($C3-1)*$D$1+$C3*4+$D$1;9;;;"Archivio!")) restituisce un indirizzo del tipo Archivio!$G$4:Archivio!$I$15, che ovviamente e' sbagliato; ci sono due o tre di queste anomalie.
La formula che non da errori:
Codice: Seleziona tutto
=SE.ERRORE(SE(VAL.ERRORE(CERCA.VERT(A2;(INDIRETTO(INDIRIZZO(($C3-1)*$D$1+$C3*4;7;;;"Archivio")&":"&(INDIRIZZO(($C3-1)*$D$1+$C3*4+$D$1;9))));3;0));CERCA.VERT(A2;(INDIRETTO(INDIRIZZO(($C3-1)*$D$1+$C3*4;9;;;"Archivio"))&":"&(INDIRIZZO(($C3-1)*$D$1+$C3*4+$D$1;10)));2;0);CERCA.VERT(A2;(INDIRETTO(INDIRIZZO(($C3-1)*$D$1+$C3*4;7;;;"Archivio")&":"&(INDIRIZZO(($C3-1)*$D$1+$C3*4+$D$1;9))));3;0));"")


Ma non so se e' quella che cerchi

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: indiretto indirizzo

Postdi rombotuono » 29/01/20 08:53

grazie Anthony
funziona parzialmente capisco la difficoltà della ricerca
in questo caso la ricerca viene effettuata leggendo il nome presente in A2 cercando in colonna G riga 4 ed estrae il dato presente in colonna I riga 4 "Middlesbrough"
se sostituisco il nome di ricerca presente in A2 in "Middlesbrough" cercando in colonna I riga 4 il nome da trovare è "Luton Town" colonna G riga 4
le sto provando tutte ma non riesco
grazie
rombotuono
Utente Junior
 
Post: 56
Iscritto il: 09/11/18 17:27

Re: indiretto indirizzo

Postdi wallace&gromit » 29/01/20 12:20

Prima di tutto una nota off topic: lo pronunciate giusto il nome di quella squadra? Memore della strana pronuncia di Edinburgo ho verificato ed effettivamente si pronuncia qualcosa di analogo anche per Middlesbrough: qualcosa come "Midlzbra". Oppure Boro per gli amici, che è più facile!

Tornando al quesito ripropongo la domanda, anche corroborata dal fatto che il file è già *.xlsm, quindi forse non scarti a priori macro o UserFunction, non sarebbe il caso che ci presenti bene quello che vuoi e costruiamo qualcosa in questo senso?
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: indiretto indirizzo

Postdi Anthony47 » 29/01/20 13:57

Mi sono limitato a correggere la sintassi, perche' la logica di quella formula non la conosco; anzi immagino che sia cosi' solo perche' vuoi fare pratica con le funzioni Indiretto e Indirizzo.
Con l'ultima indicazione, sposto una parentesi (dall'area blu all'area verde):
=SE.ERRORE(SE(VAL.ERRORE(CERCA.VERT(A2;(INDIRETTO(INDIRIZZO(($C3-1)*$D$1+$C3*4;7;;;"Archivio")&":"&(INDIRIZZO(($C3-1)*$D$1+$C3*4+$D$1;9))));3;0));CERCA.VERT(A2;(INDIRETTO(INDIRIZZO(($C3-1)*$D$1+$C3*4;9;;;"Archivio")&":"&(INDIRIZZO(($C3-1)*$D$1+$C3*4+$D$1;10))));2;0);CERCA.VERT(A2;(INDIRETTO(INDIRIZZO(($C3-1)*$D$1+$C3*4;7;;;"Archivio")&":"&(INDIRIZZO(($C3-1)*$D$1+$C3*4+$D$1;9))));3;0));"")


Ma seriamente, anche riprendendo la domanda di W&G (vedi suo messaggio, sopra) perche' non usi l'indirizzamento diretto?

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: indiretto indirizzo

Postdi rombotuono » 29/01/20 17:54

grazie Anthony sembra ok la studio e la provo
rombotuono
Utente Junior
 
Post: 56
Iscritto il: 09/11/18 17:27

Re: indiretto indirizzo

Postdi rombotuono » 29/01/20 18:28

Grazie Anthony
tutto ok non so come ringraziarti
grazie ancora
rombotuono
Utente Junior
 
Post: 56
Iscritto il: 09/11/18 17:27


Torna a Applicazioni Office Windows


Topic correlati a "indiretto indirizzo":


Chi c’è in linea

Visitano il forum: Nessuno e 45 ospiti