Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Visualizzare note dinamiche selezionando celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Visualizzare note dinamiche selezionando celle

Postdi BG66 » 03/11/19 21:58

Ciao a tutti,
titolo assurdo ma.....volevo lasciare lo spazio per RISOLTO :lol:
In pratica vorrei che posizionandomi su "P.TO FRANCO" (cella B4) nella cella (unita :oops: ) B13 venga visualizzato il testo corrispondente (cella N3). E cosi via...

https://www.dropbox.com/s/k5g7zefqk3kn1qu/note%20dinamiche%20in%20menu_forum.xlsx?dl=0

Non ho idea se si possa realizzare con formule o macro.

Grazie
Gene
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 209
Iscritto il: 20/08/16 07:44

Sponsor
 

Re: Visualizzare note dinamiche selezionando celle

Postdi Anthony47 » 04/11/19 01:14

Non ho idea se si possa realizzare con formule o macro
Una soluzione mista:
-nel modulo vba del foglio MENU inserisci:
Codice: Seleziona tutto
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Dim CkArea As String
'
CkArea = "B4:F10"
If Not Application.Intersect(Range(CkArea), Target.Cells(1, 1)) Is Nothing Then
    If Target.Cells(1, 1) <> "" Then Range("P1").Value = Target.Cells(1, 1)
End If
End Sub
(usa la cella P1 come appoggio)

Poi in B13 metti la fromula
Codice: Seleziona tutto
=SE.ERRORE(CERCA.ORIZZ(P1;N2:AD3;2;0);"Nessuna Nota")

Varia il parametro "MatriceTabella" del Cerca.Orizz in funzione di quante entry avra' la tua tabella

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16735
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Visualizzare note dinamiche selezionando celle

Postdi BG66 » 04/11/19 12:29

Ciao Anthony,
grazie ancora.

Di seguito link al file finale nel caso serva a qualcun altro:
https://www.dropbox.com/s/zqf4qh3zuihvgrt/note%20dinamiche%20in%20menu_by%20Anthony.xlsm?dl=0

Alla prossima
Gene
BG66
Excel2010
Avatar utente
BG66
Utente Senior
 
Post: 209
Iscritto il: 20/08/16 07:44


Torna a Applicazioni Office Windows


Topic correlati a "Visualizzare note dinamiche selezionando celle":


Chi c’è in linea

Visitano il forum: Nessuno e 24 ospiti