Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

MACRO VBA AL POSTO DELLA FUNZIONE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

MACRO VBA AL POSTO DELLA FUNZIONE

Postdi romant » 02/02/19 20:49

Salve, chiedo ancora un aiuto, volevo sapere se è possibile utilizzare una macro VBA al posto della funzione per contare numeri pari e dispari e alcune formule di combinazioni di numeri e darne il risultato di fianco alla colonna della combinazione stessa. Per poche righe ho utilizzato le funzioni
=MATR.SOMMA.PRODOTTO((RESTO(A2:E2;2)=0)+0) numeri pari
=MATR.SOMMA.PRODOTTO((RESTO(A2:E2;2)<>0)+0) numeri dispari


=MATR.SOMMA.PRODOTTO((A2:E2>=1)*(A2:E2<17)) numeri inferiori a 17
=MATR.SOMMA.PRODOTTO((A2:E2>=17)*(A2:E2<34)) numeri inferiori a 34
=MATR.SOMMA.PRODOTTO((A2:E2>=34)*(A2:E2<51)) numeri inferiori a 51


ma essendo le righe circa 1 milione che cambiano da settimana a settimana farlo con la funzione si perde molto tempo.
Ringrazio anticipatamente.
romant
Utente Junior
 
Post: 23
Iscritto il: 29/01/19 21:35

Sponsor
 

Re: MACRO VBA AL POSTO DELLA FUNZIONE

Postdi Anthony47 » 03/02/19 17:53

Una possible traduzione in vba:
Codice: Seleziona tutto
If Application.WorksheetFunction.IsEven(Variabile) Then
    'cosa fare se Pari
Else
    'cosa fare se dispari
End If

If Variabile < 17 Then
    'cosa fare se 1-16
ElseIf Variabile < 34 Then
    'cosa fare se 17-34
ElseIf varNum < 51 Then
    'cosa fare se 34-50
End If

COMUNQUE, ho immaginato che la tua richiesta fosse relativa al calcolo dei pari/dispari e calcolo per fascia di valore che e' presente nella tua precedente discussione (vedi viewtopic.php?f=26&t=110340)
Ho pertanto modificato il file che ti avevo allegato (che sviluppa la serie con mie macro, senza cioe' scervellarmi a capire l'organizzazione di quelle presenti nel tuo file) per aggiungere allo sviluppo anche le due colonne aggiuntive: calcolo per fascia di valori, calcolo pari /dispari

Il file e' reperibile al link gia' pubblicato nell'altra discussione; la modifica fatta riguarda Function cCOLSum(cR), ma ha comportato anche una leggera modifica alla sua chiamante (cioe' la Function Comb2)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 16531
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "MACRO VBA AL POSTO DELLA FUNZIONE":


Chi c’è in linea

Visitano il forum: Nessuno e 20 ospiti