Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cambio riferimenti formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cambio riferimenti formula

Postdi podge » 30/01/19 16:00

Buongiorno,
spero di poter avere il vs aiuto circa una macro che sto cercando di creare che possa cambiare il percorso all'interno di una formula.
Cerco di spiegarmi meglio...nel file ho inserito 3 mesi, gennaio/febbraio e marzo, ogni mese fa riferimento a valori del mese precedente, nel mio caso ore di straordinario.
Vorrei che, una volta creato il nuovo mese, attraverso una macro io possa cambiare i riferimenti delle formule di quel foglio prendendo i valori dalle celle "B32" e "B33" che in ordine sono il valore che va sostituito e quello che lo sostituisce.
Nel file nel mese di marzo voglio sostituire gennaio che trovo in "B32" con febbraio che è in "B33" in tutte le formule da "G2:BZ38".
Secondo voi è possibile?
ho provato con questa macro ma invano......
Codice: Seleziona tutto
Sub Sostituisci()
Dim ur As Long
Dim rng As Range
Dim cel As Range
ur = Cells(Rows.Count, 78).End(xlUp).Row
Set rng = Range("g2:bz" & ur)
For Each cel In rng
    Select Case cel.Value
        Case Is = Range("B32").Value
        cel.Value = Range("B33").Value
       
    End Select
Next cel
End Sub
podge
Newbie
 
Post: 8
Iscritto il: 30/01/19 15:46

Sponsor
 

Re: Cambio riferimenti formula

Postdi Anthony47 » 31/01/19 00:28

Perdona, mi sembra un lavoro inutile...
Excel gia' dispone del comando Trova e Sostituisci, con cui puoi cercare tutti i Gennaio! Nelle formule e sostituirli con Febbraio!
Il comando, come e' noto, si avvia con la combinazione di tasti Contr-Maiusc-t; l'impatto sull'operatore e' lo stesso che, tramite macro, scrivere Gennaio in B2 e Febbraio in B33

In alternativa puoi usare INDIRETTO per calcolare il riferimento delle tue formule

Es, se in A2 del foglio Febbraio la formula dice =Gennaio!A2 la puoi scrivere come
Codice: Seleziona tutto
=INDIRETTO($B$33&"!"&INDIRIZZO(RIF.RIGA(A2);RIF.COLONNA(A2)))

(B33 contiene la scritta Gennaio)

Oppure (cambia poco)
Codice: Seleziona tutto
=INDIRETTO(INDIRIZZO(RIF.RIGA(A2);RIF.COLONNA(A2);4;1;$B$33))


Quando poi duplichi il foglio Febbraio per farlo diventare Marzo, ti bastera' modificare la scritta in B33

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16946
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cambio riferimenti formula

Postdi podge » 31/01/19 15:13

Non l'avevo mai usata....ottima per le prove che ho fatto.
Con questo codice invece come dovrei comportarmi:
Codice: Seleziona tutto
=SE(gennaio!I4<=marzo!F4;gennaio!I4;F4)
podge
Newbie
 
Post: 8
Iscritto il: 30/01/19 15:46

Re: Cambio riferimenti formula

Postdi podge » 31/01/19 16:24

ho trovato come modificarlo.......
Codice: Seleziona tutto
=SE(INDIRETTO(INDIRIZZO(RIF.RIGA(I4);RIF.COLONNA(I4);4;1;$B$33))<=F4;INDIRETTO(INDIRIZZO(RIF.RIGA(I4);RIF.COLONNA(I4);4;1;$B$33));F4)


funziona alla grande
podge
Newbie
 
Post: 8
Iscritto il: 30/01/19 15:46


Torna a Applicazioni Office Windows


Topic correlati a "Cambio riferimenti formula":


Chi c’è in linea

Visitano il forum: Nessuno e 25 ospiti