Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel]: trovare valore in base a condizione SE e cerca.oriz

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel]: trovare valore in base a condizione SE e cerca.oriz

Postdi karug64 » 27/01/19 16:49

Salve a tutti.

Allegato invio un file di esempio per un foglio che vorrei sviluppare che meglio di ogni spiegazione rende chiara l'idea del problema da risolvere.

Dovrei fare un cerca.orizz e prelevare il valore corrispondente alla colonna che risulta dal cerca.orizz.

Potreste aiutarmi ?
Grazie.

http://www.mediafire.com/file/1a43cbmzsdxcdd6/Cartel2.xlsx/file
Office 2010
karug64
Utente Senior
 
Post: 701
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: [Excel]: trovare valore in base a condizione SE e cerca.

Postdi Marius44 » 27/01/19 17:42

Ciao
Non è un CERCA.ORIZ ma devi mettere insieme SE.ERRORE, SCARTO e CONFRONTA

Studiaci un po' e non riesci, lancia un fischio.

Ciao,
Mario
Marius44
Utente Senior
 
Post: 463
Iscritto il: 07/09/15 22:00

Re: [Excel]: trovare valore in base a condizione SE e cerca.

Postdi karug64 » 27/01/19 18:26

Ok.
Cominciamo:

CONFRONTA:
funziona solo se i valori da cercare sono ordinati ?
Infatti se ho (da C a L) questi valori

1,01 1,13 1,25 1,37 1,49 1,61 1,73 1,85 1,97 2,09

la formula =CONFRONTA(O1;C4:L4) con O1 = 2,09 restituisce 10 (ovvero la colonna L)

ma se la riga contiene questi valori:

1,01 3,13 1,25 1,37 4,00 1,61 1,73 2,00 1,97 3,99

la stessa formula restituisce = 1

Se è così, c'è un proplema perchè i valori nelle righe non saranno mai ordinati nè potrò farlo io ....

Grazie
Office 2010
karug64
Utente Senior
 
Post: 701
Iscritto il: 20/11/11 21:22

Re: [Excel]: trovare valore in base a condizione SE e cerca.

Postdi Marius44 » 27/01/19 19:31

Ciao
Oltre a quanto detto prima, per rendere la formula dinamica occorre anche RIF.RIGA()
Prova mettendo in O2 questa formula (da tirare giù)
=SE.ERRORE(SCARTO($A$1;RIF.RIGA();CONFRONTA($N2;$A$1:$L$1;0)-1);"")

Fai sapere. Ciao,
Mario
Marius44
Utente Senior
 
Post: 463
Iscritto il: 07/09/15 22:00

Re: [Excel]: trovare valore in base a condizione SE e cerca.

Postdi karug64 » 27/01/19 19:46

Ok. Grazie.
Il problema è che mi restituisce il valore della riga sottostante a quella dove c'è la formula.....
Office 2010
karug64
Utente Senior
 
Post: 701
Iscritto il: 20/11/11 21:22

Re: [Excel]: trovare valore in base a condizione SE e cerca.

Postdi Marius44 » 27/01/19 20:16

Ciao
Si, hai ragione. Nella formula m'è scappato un -1

=SE.ERRORE(SCARTO($A$1;RIF.RIGA()-1;CONFRONTA($N2;$A$1:$L$1;0)-1);"")

Prova ora.
Ciao,
Mario
Marius44
Utente Senior
 
Post: 463
Iscritto il: 07/09/15 22:00

Re: [Excel]: trovare valore in base a condizione SE e cerca.

Postdi karug64 » 27/01/19 20:30

Perfetto !!!

"Studiaci un po' e non riesci, lancia un fischio." ......

Altro che fischio, avrei potuto urlare una vita intera !!!!

Grazie
Office 2010
karug64
Utente Senior
 
Post: 701
Iscritto il: 20/11/11 21:22

Re: [Excel]: trovare valore in base a condizione SE e cerca.

Postdi Anthony47 » 27/01/19 23:02

Invece di SCARTO, che è "volatile" e quindi piu' esigente in termini di cpu, suggerisco l'uso di INDICE; quindi, in O2
Codice: Seleziona tutto
=INDICE($C2:$L2;CONFRONTA($N2;$C$1:$L$1;0))
Copiare poi verso il basso; se serve aggiungici "SE.ERRORE"

Ciao a tutti
Avatar utente
Anthony47
Moderatore
 
Post: 16618
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel]: trovare valore in base a condizione SE e cerca.

Postdi karug64 » 28/01/19 20:03

Ok. Grazie ad entrambi per le soluzioni proposte, perfettamente funzionanti.

E ora il prossimo quesito ......
Office 2010
karug64
Utente Senior
 
Post: 701
Iscritto il: 20/11/11 21:22


Torna a Applicazioni Office Windows


Topic correlati a "[Excel]: trovare valore in base a condizione SE e cerca.oriz":


Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti