Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula con data

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula con data

Postdi Zoro76 » 10/12/18 05:03

Salve ragazzi.
Avrei bisogno di una mano per una formula con l ora.
Quello di cui ho bisogno è questo
Se sono....dalle ore 05.01 alle ore 13.00 allora scrivi 1. Turno...se sono dalle ore 13.01 alle ore 21.00 allora scrivi 2. Turno, se sono dalle 21.01 alle 05.00 allora scrivi 3. Turno...
Ringrazio in anticipo per qualsiasi suggerimento
Zoro76
Utente Senior
 
Post: 107
Iscritto il: 10/03/10 10:55

Sponsor
 

Re: Formula con data

Postdi klingklang » 10/12/18 09:42

Ciao, prova questa formula, con orario in cella A1:
Codice: Seleziona tutto
=SE(E(A1-INT(A1)>5/24;A1-INT(A1)<=13/24);"1 turno";SE(E(A1-INT(A1)>13/24;A1-INT(A1)<=21/24);"2 turno";"3 turno"))
Enrico
Windows 7 + Office 2016 64bit / Windows 10 + Office 365 32/64bit
Avatar utente
klingklang
Utente Junior
 
Post: 93
Iscritto il: 23/11/18 15:01
Località: San Giovanni in Persiceto

Re: Formula con data

Postdi wallace&gromit » 10/12/18 09:53

Ciao Assumendo che in A2 vi sia la data da confrontare, espressa con una forma data e ora, la formula potrebbe essere questa:
Codice: Seleziona tutto
=SE(E(RESTO(A2;1)>5/24;RESTO(A2;1)<=13/24);"primo turno";SE(E(RESTO(A2;1)>13/24;RESTO(A2;1)<=21/24);"secondo turno";"terzo turno"))

Se invece hai già solo le ore (espresse in porzioni di 24° di giorno) allora togli sempre la funzione resto.

P.S. mi sono sovrapposto a klingklang con una soluzione simile
Office2016 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1923
Iscritto il: 16/01/12 14:21

Re: Formula con data

Postdi Anthony47 » 10/12/18 11:12

Cosi', tanto per confondere il buon Zoro, aggiungo anche la mia proposta, cosi' facciamo 3:
-in A2 l'Ora o la Data+Ora da confrontare; poi usa la formula
Codice: Seleziona tutto
=1/SE.ERRORE(1/RESTO(INT((1+A2-5,01/24)/(8/24))-2;3);1/3)&". Turno"

Ciao!
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 16454
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula con data

Postdi Zoro76 » 10/12/18 12:42

Grazie mille ragazzi siete stati gentilissimi.... Ora provo
Zoro76
Utente Senior
 
Post: 107
Iscritto il: 10/03/10 10:55

Re: Formula con data

Postdi Zoro76 » 11/12/18 21:56

Ciao ragazzi. Ho provato le vostre formule ma sono incappato in un grosso problema. Il mio excel è in tedesco.... Non riesco a farlo andare in altra lingua... Gentilmente qlc ha la possibilita di tradurmi la formula?
Grazie mille
Zoro76
Utente Senior
 
Post: 107
Iscritto il: 10/03/10 10:55

Re: Formula con data

Postdi Anthony47 » 11/12/18 23:44

Nel file allegato trovi tutte le tre formule che ti sono state suggerite:
https://www.dropbox.com/s/55g691suyv5ct ... .xlsx?dl=0

Cosi' per curiosita', ci dici in tedesco come si traducono?

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 16454
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula con data

Postdi Zoro76 » 12/12/18 04:36

Si esatto. Purtroppo l excel al lavoro è in lingua tedesca e non accetta ne italiano ne inglese.

Ho trovato se che si dice wenn
Resto si dice rest
Int si dice ganzzahl

Mi manca la E che sinceramente non so neache cosa voglia dire in italiano
Zoro76
Utente Senior
 
Post: 107
Iscritto il: 10/03/10 10:55

Re: Formula con data

Postdi klingklang » 12/12/18 09:00

Ciao, per superare le barriere linguistiche, questo link ti sarà sicuramente utile: https://it.excel-translator.de/translator/
Enrico
Windows 7 + Office 2016 64bit / Windows 10 + Office 365 32/64bit
Avatar utente
klingklang
Utente Junior
 
Post: 93
Iscritto il: 23/11/18 15:01
Località: San Giovanni in Persiceto

Re: Formula con data

Postdi Zoro76 » 12/12/18 23:58

Grazie mille. Oggi provo
Zoro76
Utente Senior
 
Post: 107
Iscritto il: 10/03/10 10:55

Re: Formula con data

Postdi wallace&gromit » 13/12/18 10:20

mi sorprenderebbe se E non fosse UND, ma nella formula di Anthony non ti serve nemmeno.
Ti serve solo il WENNFEHLER
Office2016 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1923
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "Formula con data":


Chi c’è in linea

Visitano il forum: Nessuno e 20 ospiti