Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Modifica Formula Ordinamento Tabella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Modifica Formula Ordinamento Tabella

Postdi Francesco6918 » 28/07/18 16:58

Buna sera a tutti se gentilmente potreste aiutarmi , o questa formula : =INDICE($L$5:$L$6;CONFRONTA(GRANDE($M$5:$M$6+($N$5:$N$6)/100+RIF.RIGA($M$5:$M$6)/10000;RIF.RIGA(M5)-RIF.RIGA($M$4));$M$5:$M$6+($N$5:$N$6)/100+RIF.RIGA($M$5:$M$6)/10000;0))
inserendola nella cella P5 mi ordina i nomi con i punteggi più alti delle due colonne M5:M6 e N5:N6 fin qui funziona perfettamente,il problema nasce quando i punteggi delle due colonne M5:M6 e N5:N6 sono uguali in questo caso o inserito una colonna d'appoggio O5:O6 con i puneggi piu grandi in questo caso il punteggio più alto e O5 l ordine esatto dei nomi sarebbe come esempio del file in allegato nella colonna R5:R6 vorrei ottenere questo risultato modificando la mia formula .

Grazie


http://www.filedropper.com/prova_1
Francesco6918
Utente Senior
 
Post: 192
Iscritto il: 04/03/11 11:20

Sponsor
 

Re: Modifica Formula Ordinamento Tabella

Postdi D@nilo » 28/07/18 18:20

Buonasera
integrando la tua formula

=INDICE($L$5:$L$6;CONFRONTA(GRANDE($M$5:$M$6+($N$5:$N$6)+($O$5:$O$6)/100+RIF.RIGA($M$5:$M$6)/10000;RIF.RIGA(M5)-RIF.RIGA($M$4));$M$5:$M$6+($N$5:$N$6)+($O$5:$O$6)/100+RIF.RIGA($M$5:$M$6)/10000;0))
Avatar utente
D@nilo
Utente Junior
 
Post: 18
Iscritto il: 12/05/18 13:15
Località: ROMA

Re: Modifica Formula Ordinamento Tabella

Postdi Francesco6918 » 28/07/18 18:37

Ciao D@nilo grazie della risposta con la tua formula o notato un particolare inserendo nuovi valori coma da esempio riallego il file l ordine e sbagliato in quando il valore più grande è in M5 dunque viene prima Gianni e poi Nicola l ordine deve avvenire quando esclusivamente le due colonne M5:M6, e N5:N6 anno gli stessi valori uguali in quel caso il valore più grande da prendere in considerazione è quello della colonna O5:O6 come il file precedente .

Grazie

http://www.filedropper.com/prova1
Francesco6918
Utente Senior
 
Post: 192
Iscritto il: 04/03/11 11:20

Re: Modifica Formula Ordinamento Tabella

Postdi Anthony47 » 29/07/18 12:15

Mi sembra che vuoi condizionare il risultato non solo sulla base dei valori di colonna M ed N, ma anche di colonna O.
In questo caso la formula che propongo:
Codice: Seleziona tutto
=INDICE($L$5:$L$6;CONFRONTA(GRANDE($M$5:$M$6+($N$5:$N$6)/100+($O$5:$O$6)/10000-RIF.RIGA($M$5:$M$6)/1000000;RIF.RIGA(A1));$M$5:$M$6+($N$5:$N$6)/100+($O$5:$O$6)/10000-RIF.RIGA($M$5:$M$6)/1000000;0))

Da inserire in P5, confermando con Contr-Maiusc-Enter, e poi copiare in P6.

Ho modificato in "-" (invece che il "+") il coefficiente legato alla posizione nell'elenco; in questo modo, a parita' di contenuto in M-N-O risultera' prima chi figura prima nell'elenco (col "+" la priorita' e' per chi figura dopo).

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16625
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Modifica Formula Ordinamento Tabella

Postdi Francesco6918 » 29/07/18 12:35

Ciao Anthony47 perfetto grazie della soluzione, risolto.

Saluti
Francesco6918
Utente Senior
 
Post: 192
Iscritto il: 04/03/11 11:20


Torna a Applicazioni Office Windows


Topic correlati a "Modifica Formula Ordinamento Tabella":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti