Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Giorni per mese di un periodo di tempo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Giorni per mese di un periodo di tempo

Postdi xilofono » 24/06/18 10:17

Poniamo di avere due date:

A1 - 05/09/2012
A2 - 20/02/2017

Nel periodo intercorso tra le due date ci sono 1629 giorni

Io vorrei sapere, quanti di questi ricadono in ciascuno dei 12 mesi dell'anno (indifferentemente dall'anno) ho provato mille formule combinate ma non sono arrivato a una soluzione.

Certo il problema è calcolare gli anni non completi, in quanto per gli altri, salvo l'eventuale febbraio bisestile (ma non fa troppa differenza contarlo o meno ai fini del calcolo), il numero di giorni per mese è chiaro.

Per questi basta moltiplicare il numero di giorni fissi del mese per 2017-2012-1 e il gioco è fatto

ad esempio

Gennaio = [anno(A2)-anno(A1)-1]*31 + [X]

Febbraio = [anno(A2)-anno(A1)-1]*28 + [X]

Marzo = [anno(A2)-anno(A1)-1]*31 + [X]

Aprile = [anno(A2)-anno(A1)-1]*30 + [X]

E a seguire gli altri fino a dicembre
in realtà poi sarebbe =SE(ANNO(A2)-ANNO(A1)-1<0;0;ANNO(A2)-ANNO(A1)-1), per evitare che vada in negativo qualora il periodo non copra più di un anno

Poi va aggiunta la variabile [X] per gli anni incompleti, cioè quello iniziale e finale, ma come fare? :oops:
Windows 8 - Office 2013 Ita
Avatar utente
xilofono
Utente Junior
 
Post: 62
Iscritto il: 27/11/17 09:52

Sponsor
 

Re: Giorni per mese di un periodo di tempo

Postdi xilofono » 24/06/18 10:36

Soluzione trovata:

F2 data inizio
F3 data fine

esempio calcolo gennaio

=SE(ANNO(F3)-ANNO(F2)-1<0;0;ANNO(F2)-ANNO(F3)-1)*31+SE(MESE(F2)<1;31;SE(MESE(F2)=1;31-GIORNO(F2);0))+SE(MESE(F3)>1;31;SE(MESE(F3)=1;GIORNO(F3);0))

esempio calcolo febbraio

=SE(ANNO(F3)-ANNO(F2)-1<0;0;ANNO(F2)-ANNO(F3)-1)*28+SE(MESE(F2)<2;28;SE(MESE(F2)=2;28-GIORNO(F2);0))+SE(MESE(F3)>2;28;SE(MESE(F3)=2;GIORNO(F3);0))

e così via

non tiene conto dell'eventuale bisestile...
Windows 8 - Office 2013 Ita
Avatar utente
xilofono
Utente Junior
 
Post: 62
Iscritto il: 27/11/17 09:52

Re: Giorni per mese di un periodo di tempo

Postdi xilofono » 24/06/18 12:14

Non funzionava in realtà

ora con questa sì

Gennaio

=(SE(ANNO(F3)-ANNO(F2)-1<0;0;ANNO(F3)-ANNO(F2)-1)*31)+(SE(ANNO(F3)=ANNO(F2);(SE(E(MESE(F2)<1;MESE(F3)>1);31;SE(MESE(F2)=1;31-GIORNO(F2))));0))+(SE(ANNO(F3)<>ANNO(F2);(SE(MESE(F2)<1;31;SE(MESE(F2)=1;31-GIORNO(F2);0))+SE(MESE(F3)>1;31;SE(MESE(F3)=1;GIORNO(F3);0)));0))

Febbraio

=(SE(ANNO(F3)-ANNO(F2)-1<0;0;ANNO(F3)-ANNO(F2)-1)*28)+(SE(ANNO(F3)=ANNO(F2);(SE(E(MESE(F2)<2;MESE(F3)>2);28;SE(MESE(F2)=2;28-GIORNO(F2))));0))+(SE(ANNO(F3)<>ANNO(F2);(SE(MESE(F2)<2;28;SE(MESE(F2)=2;28-GIORNO(F2);0))+SE(MESE(F3)>2;28;SE(MESE(F3)=2;GIORNO(F3);0)));0))

Etc
Windows 8 - Office 2013 Ita
Avatar utente
xilofono
Utente Junior
 
Post: 62
Iscritto il: 27/11/17 09:52

Re: Giorni per mese di un periodo di tempo

Postdi xilofono » 24/06/18 13:21

:lol: non funzionava neanche quello

ho rinunciato a mettere tutto in un'unica cella x ogni mese...

soluzione trovata, allego file se interessasse

resta il problema dei bisestili, ma è davvero marginale

http://www.filedropper.com/calcologiornixmese
Windows 8 - Office 2013 Ita
Avatar utente
xilofono
Utente Junior
 
Post: 62
Iscritto il: 27/11/17 09:52

Re: Giorni per mese di un periodo di tempo

Postdi cromagno » 24/06/18 15:22

Ciao,
in base al tuo ultimo file allegato....
nella cella I7 (da copiare poi in basso):
=MATR.SOMMA.PRODOTTO(--(MESE(RIF.RIGA(INDIRETTO("A"&$C$2&":A"&$C$3)))=RIF.RIGA(A1)))

Ciao
Tore
Windows 10 + Office 2013 64bit(ita)
"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Avatar utente
cromagno
Utente Junior
 
Post: 65
Iscritto il: 08/10/16 16:33
Località: Sardegna


Torna a Applicazioni Office Windows


Topic correlati a "Giorni per mese di un periodo di tempo":


Chi c’è in linea

Visitano il forum: Nessuno e 21 ospiti