Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

filtro o macro excel su testi

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

filtro o macro excel su testi

Postdi Sunts » 21/02/18 15:47

Ciao a tutti,

apro il mio primo Topic sperando di essere nel posto giusto.

Ho un foglio excel 2010.

Colonna A: testo (più parole)
Colonna B: testo (una sola parola)

Vorrei evidenziare tutte le celle di A che contengono le parole contenute nella colonna B. Quindi se la cella di A contiene almeno una delle parole inserire in B, vorrei che mi fosse messa in qualche modo in evidenza (andrebbe bene anche un test con risposta si/no).

Qual è il modo più veloce per fare questa selezione?

grazie!
Sunts
Newbie
 
Post: 6
Iscritto il: 21/02/18 15:19

Sponsor
 

Re: filtro o macro excel su testi

Postdi Anthony47 » 22/02/18 00:48

Ad esempio, in C2
Codice: Seleziona tutto
=SE(VAL.ERR(TROVA(B2;A2));"No";"Si")


Ti funziona?
Avatar utente
Anthony47
Moderatore
 
Post: 17648
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: filtro o macro excel su testi

Postdi Sunts » 22/02/18 15:12

No.

In A ho delle descrizioni estese.

In B ho delle singole stringhe di testo.

Devo individuare tutte le descrizioni in A che contengono - almeno una - delle parole elencate in B.
Sunts
Newbie
 
Post: 6
Iscritto il: 21/02/18 15:19

Re: filtro o macro excel su testi

Postdi johnatan69 » 22/02/18 16:05

Ciao sunts. Ma le descrizioni in A sono separate da spazi oppure no?
johnatan69
Utente Junior
 
Post: 30
Iscritto il: 21/02/18 15:32

Re: filtro o macro excel su testi

Postdi johnatan69 » 22/02/18 16:07

Scusa in B dove hai la stringa...
johnatan69
Utente Junior
 
Post: 30
Iscritto il: 21/02/18 15:32

Re: filtro o macro excel su testi

Postdi Sunts » 22/02/18 16:18

in B ho una sola parola per ogni cella.

quindi la funzione dovrebbe confrontare ciascuna descrizione in A con tutte le parole presenti in B.
Sunts
Newbie
 
Post: 6
Iscritto il: 21/02/18 15:19

Re: filtro o macro excel su testi

Postdi johnatan69 » 22/02/18 17:47

Ti confermo,allora, che la soluzione proposta da anthony47 è quella giusta. Controlla la sintassi quando le inserisci nella cella C.
johnatan69
Utente Junior
 
Post: 30
Iscritto il: 21/02/18 15:32

Re: filtro o macro excel su testi

Postdi Sunts » 22/02/18 18:34

ma la formula sopra fa un confronto tra due celle... cioè verifica se il valore in B2 è presente in A2, Quindi se in B5 ho una parola contenuta in A2, il test non mi dà esito positivo.

faccio un esempio: in A ho 100 righe, in B ho 10 righe.

Il mio obiettivo è sapere se nella generica cella A-i è presente almeno una delle parole presenti nelle 10 celle della colonna B.
Sunts
Newbie
 
Post: 6
Iscritto il: 21/02/18 15:19

Re: filtro o macro excel su testi

Postdi Anthony47 » 22/02/18 23:33

In effetti rileggendo tutto si capisce...
Se i testi sono da A2 verso il basso, e le singole parole sono B2:B20, allora in C2:
Codice: Seleziona tutto
=SE(SOMMA(SE.ERRORE(TROVA($B$2:$B$20&SE($B$2:$B$20<>"";" ";"ZZZCC");A2&" ");0))>0;"Yes";"n")

Da confermare con Contr-Maiusc-Enter, non il solo Enter; poi copia verso il basso
L'intervallo B2:B20 puo' contenere anche celle vuote.

Riprova, vediamo se sei fortunato :D
Avatar utente
Anthony47
Moderatore
 
Post: 17648
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: filtro o macro excel su testi

Postdi Sunts » 23/02/18 11:40

No...non sono stata fortunata!

Poi pensavo che la funzione RICERCA fosse quella giusta in questo caso... farò qualche altro tentativo... non mi arrendo!
Sunts
Newbie
 
Post: 6
Iscritto il: 21/02/18 15:19

Re: filtro o macro excel su testi

Postdi Anthony47 » 23/02/18 15:34

Dubbio: sfortunata o disattenta?
Domanda: Hai confermato la formula con Contr-Maiusc-Enter (non il solo Enter)?

Comunque a questo punto e' utile allegare un file dimostrativo, cosi' vediamo l'effettiva organizzazione dei dati.
Per le istruzioni su come allegare un file:
viewtopic.php?f=26&t=103893&p=605487#p605487

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17648
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: filtro o macro excel su testi

Postdi Sunts » 27/02/18 13:37

ho sostituito Trova con Ricerca e mi avvicino di più al risultato atteso.

=SE(SOMMA(SE.ERRORE(RICERCA($B$2:$B$16&SE($B$2:$B$16<>"";" ";"NA");A2&" ");0))>0;"Yes";"No") matriciale

Ti evidenzio il caso in cui non funziona:

A10: VALVOLA DIAMETRO MM. 27, COMPLETA, PER I DISPOSITIVI DI CARICA INIZIALE ACCELERATA DEI DISTRIBUTORI U DEL FRENO. DIS. SAB TOPOLINO/15
B2: TOPOLINO

Risultato del test "No" perché vede TOPOLINO unito a /15. Io vorrei che il test mi dia risultato positivo perché il mio obiettivo è che A contenga la parola TOPOLINO a prescindere che sia una stringa singola o contenuta in un'altra più lunga.

Come si può bypassare l'errore?
Sunts
Newbie
 
Post: 6
Iscritto il: 21/02/18 15:19

Re: filtro o macro excel su testi

Postdi peppo55 » 27/02/18 16:24

Ciao Sunts,

prova con la Funzione: =TESTO(B2;" ")
peppo

Excel 2010
peppo55
Utente Senior
 
Post: 167
Iscritto il: 30/09/12 13:51

Re: filtro o macro excel su testi

Postdi Anthony47 » 27/02/18 18:38

Peppo ha scritto:prova con la Funzione: =TESTO(B2;" ")
Peppo, mi hai confuso :-?

Eh, tutto sta a capirsi su che cosa si intende per "parola"
Nel nostro caso e' la mancanza di spazio in TOPOLINO/15 che ne impedisce il confronto con TOPOLINO.

Il mio suggerimento e' che si fa una pulizia dei caratteri di contorno ("/", nell'esempio) prima di confrontare con l'elenco. Ad esempio:
Codice: Seleziona tutto
=SE(SOMMA(SE.ERRORE(RICERCA($B$2:$B$20&SE($B$2:$B$20<>"";" ";"ZZZCC");SOSTITUISCI(A2;"/";" ")&" ");0))>0;"Yes";"n")


Questa sostituisce la / con lo "spazio" tramite la funzione Sostituisci; piu' Sostituisci possono essere annidati per sostituire piu' caratteri. Ad esempio:
Codice: Seleziona tutto
SOSTITUISCI(SOSTITUISCI(A2;"/";" ");"-";" ")
Questa sostituisce prima "/" e poi "-" con lo "spazio"

La differenza tra Trova e Ricerca e' che la prima distingue tra maiusc e minusc, la seconda no.
Scegli l'una o l'altra in base alla sensibilita' al maiusc/minusc che vuoi adottare

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17648
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "filtro o macro excel su testi":


Chi c’è in linea

Visitano il forum: Bing [Bot] e 20 ospiti