Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

cerce vert in una cartella di rete

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: cerce vert in una cartella di rete

Postdi Anthony47 » 12/10/17 07:48

digito in A2 del file "Front sheet" la formula =CERCA.VERT($J$2;INDIRETTO(M4);10;0) ed ottengo in A2 #RIF!, con il file "1124-SMDL-00_IN PROGRESS" rigorosamente aperto
Sono in giro quindi non posso fare molte prove su cartelle di rete, pero' quanto scritto mi sembra smentire cose scritte nei giorni scorsi.
Inoltre le prove dovresti farle anche cambiando il contenuto di J2
apro file "1124-SMDL-00_IN PROGRESS" che si trova all'indirizzo '\\XenFs01\commesse\_ARCHIVIO WO 01100 - 01199\01124 - AKER BP ASA Kameleon & Storklakken Aker Solutions\05 Docs per il Cliente\IN PROCESS\PM_SMDR
Chiarisci (senza risparmiare la tasiera) se lo apri usando il Drive Windows (es K:\path\nomefile) oppure l'UNC (\\\\XenFs01\etc etc)

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Sponsor
 

Re: cerce vert in una cartella di rete

Postdi giostacchio » 12/10/17 13:29

ciao Anthony in che senso "quanto scritto mi sembra smentire cose scritte nei giorni scorsi" è sempre stato così. Ho provato, certo, anche a cambiare il contenuto.

Mentre quando apro il file lo apre con il drive windows "K" e non con l'UNC. Comunque ho fatto anche questo caso ma non cambia.

grazie
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Re: cerce vert in una cartella di rete

Postdi Anthony47 » 12/10/17 23:20

Sono in giro quindi non posso fare molte prove su cartelle di rete, pero' quanto scritto mi sembra smentire cose scritte nei giorni scorsi.
Stamattina non ero al pc, ho lavorato "a mente" e sbagliavo a ricordare.

Ecco le prove fatte da me. In fondo concludo dicendo "per quello che vedo il comportamento della formula che usa Indiretto e' coerente con quanto ci si dovrebbe attendere: se il file e' aperto, il risultato della formula; se il file e' chiuso, l'errore #RIF"; vedi quindi se seguendole passo passo ti si accende qualche lucina.

A) Fase preparatoria
1) Lavorando sul pc "Ariel" (primo pc):
Ho condiviso una directory di questo Pc assegnandogli lo ShareName "cippa"
Il percorso completo reale e' (sul pc Ariel): D:\DaDocumenti\4Mercurio
L' IP: 192.168.0.8

2) In Ariel\cippa inserisco sia COPIA-di-Front sheet xx.xlsm (FILE_1) che 1124-SMDL-00_IN PROGRESS.xlsx (FILE_")

3) Lavorando sul Pc-2
Mappo il windows drive Z su questa condivisione; Z viene collegato al percorso
\\Ariel\cippa

4) Dal PC-2 apro COPIA-di-Front sheet xx.xlsm usando l'unc; con la formula =CELLA("nomefile") leggo il percorso e il nome file:
\\192.168.0.8\cippa\[COPIA-di-Front sheet xx.xlsm]Foglio1

5) Dal PC-2 apro COPIA-di-Front sheet xx.xlsm usando il drive Z; con la formula =CELLA("nomefile") leggo il percorso e il nome file:
Z:\[COPIA-di-Front sheet xx.xlsm]Foglio1

(si noti come nel caso 4 compaia lo sharename; nel 5 no)



B) Fase 1 di Test
1) Chiudo COPIA-di-Front sheet xx.xlsm (da adesso in avanti: FILE_1) e lo riapro tramite drive Z.
Ora =CELLA("nomefile") mi restituisce
Z:\[COPIA-di-Front sheet xx.xlsm]Foglio1

2) Sempre tramite Z: apro anche 1124-SMDL-00_IN PROGRESS.xlsx (da adesso in avanti: FILE_2)

3) In L15, usando la compilazione assistita (cioe' spostandomi su File_2 per selezionare l'area della tabella) inserisco la formula
=CERCA.VERT(J2;'[1124-SMDL-00_IN PROGRESS.xlsx]SMDL'!$A$4:$J$17;6;0)
Con J2=5 ottengo 1124-EPMS-00; cambiando il valore in J2 ottengo alri valori coerenti con la tabella della formula

4) Chiudo FILE_2
La formula in L15 diventa =CERCA.VERT(J2;'Z:\[1124-SMDL-00_IN PROGRESS.xlsx]SMDL'!$A$4:$J$17;6;0)
Cambiando il contenuto di J2 la formula restituisce ancora correttamente quanto presente in tabella.

5) Apro FILE_2 usando l'unc (\\192.168.0.8\cippa)
Tramite =CELLA("nomefile") inserita su File_2 leggo percorso e nome file:
\\192.168.0.8\cippa\[1124-SMDL-00_IN PROGRESS.xlsx]SMDL

La formula in L15 continua a darmi il corretto risultato della ricerca, man mano che cambio J2

6) Sempre usando la compilazione assistita, in L19 di File_1 metto la formula
=CERCA.VERT(J2;'[1124-SMDL-00_IN PROGRESS.xlsx]SMDL'!$A$4:$J$17;6;0)

Cambiando J2 il risultato in L15 ed L19 cambia all'unisono.

7) Compilo M1:M5 di File_1 in modo che in M10 venga assemblato il valore
'\\192.168.0.8\cippa\[1124-SMDL-00_IN PROGRESS.xlsx]SMDL'!$A$4:$T$136

In L17 di File1 metto la formula =CERCA.VERT($J$2;INDIRETTO(M7);6;0)
Ora cambiando J2 il risultato in L15, L17 ed L19 cambia all'unisono.


8) Vado a chiudere FILE_2:
La formula in L15 cambia in =CERCA.VERT(J2;'Z:\[1124-SMDL-00_IN PROGRESS.xlsx]SMDL'!$A$4:$J$17;6;0)
Quella in L17 rimane =CERCA.VERT($J$2;INDIRETTO(M7);6;0)
Quella in L19 cambia in =CERCA.VERT(J2;'\\192.168.0.8\cippa\[1124-SMDL-00_IN PROGRESS.xlsx]SMDL'!$A$4:$J$17;6;0)

Se modifico J2 allora L15 ed L19 restituiscono i valori corretti; L17 restituisce #RIF

9) Se apro FILE_2 tramite Z:
-la formula in L15 e' =CERCA.VERT(J2;'[1124-SMDL-00_IN PROGRESS.xlsx]SMDL'!$A$4:$J$17;6;0)
-quella in L17 rimane =CERCA.VERT($J$2;INDIRETTO(M7);6;0)
-quella in L19 rimane =CERCA.VERT(J2;'\\192.168.0.8\cippa\[1124-SMDL-00_IN PROGRESS.xlsx]SMDL'!$A$4:$J$17;6;0)

Se modifico J2, L15 ed L19 restituiscono i valori corretti; L17 continua a restituire #RIF


10) Chiudo File_1 (era aperto tramite Z) e lo riapro tramite l'unc (\\192.168.0.8\cippa)
Ricordo che l'unc e' lo stesso su tutti i client che si collegano al server, il nome del drive invece potrebbe cambiare tra pc e pc.
Ora =CELLA("nomefile") mi restituisce
\\192.168.0.8\cippa\[COPIA-di-Front sheet xx.xlsm]Foglio1

11) Apro FILE_2 sempre tramite l'unc
Tramite =CELLA("nomefile") inserita su File_2 leggo percorso e nome file:
\\192.168.0.8\cippa\[1124-SMDL-00_IN PROGRESS.xlsx]SMDL

Compilo M1:M5 in modo che in M7 venga assemblato
'\\192.168.0.8\cippa\[1124-SMDL-00_IN PROGRESS.xlsx]SMDL'!$A$4:$T$136

In L19 metto la formula =CERCA.VERT($J$2;INDIRETTO(M7);6;0)

Cambiando J2 il contenuto di M19 varia coerentemente con il contenuto della tabella in FILE_2


RISULTATO:

per quello che vedo il comportamento della formula che usa Indiretto e' coerente con quanto ci si dovrebbe attendere: se il file e' aperto, il risultato della formula; se il file e' chiuso, l'errore #RIF

Sul perche' a te dia un risultato diverso non so fare una prognosi; la mia migliore ipotesi e' che sbagli a comporre il reale indirizzo del file utilizzando l'unc; e' possibile che l'uso della formula =CELLA("nomefile") (da inserire all'interno di FILE_2) ti dia lo spunto per poter comporre in M7 il vero indirizzo da usare.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cerce vert in una cartella di rete

Postdi giostacchio » 17/10/17 10:42

caspita sarò mica costretto ad arrendermi, ho fatto come hai detto, soprattutto nell'ulitmo punto inserendo cella(nomefile)
in allegato il risultato di ciò che vede il mio PC
https://postimg.cc/image/3cdvevjtsb/

ma inserendo anche questo indirizzo nulla...ma è mai possibile!?!?!?
non so più che fare
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Re: cerce vert in una cartella di rete

Postdi Anthony47 » 17/10/17 15:19

Se io (che non ho problemi) scrivo due pagine e tu (che il problema ce l'hai) due righe credo che convenga rinunciare a tutti e due.

Oppure ripeti le prove che ho fatto io scrivendo esattamente quello che fai e che cosa succede.
Per il momento mi limito a dire che se apri il file come file sul drive Z potresti non vedere esattamente il percorso intero del file.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cerce vert in una cartella di rete

Postdi giostacchio » 17/10/17 15:39

Ok ma come faccio ad aprire il file diversamente?
ti allego immagine di dove si trovano in rete i due file
https://postimg.cc/image/4i81n9qbvf/

non capisco dove sbaglio, più che fare quello che mi stai dicendo di fare , non saprei...
grazie cmq per la pazienza.
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Re: cerce vert in una cartella di rete

Postdi Anthony47 » 18/10/17 00:34

Se sai solo aprire il file dal drive Z invece che dal percorso di rete allora lavora con Z.
Quindi:
-scrivi la formula giusta per ottenere il tuo risultato, avendo il secondo file "aperto" (partendo dal drive Z)
-chiudi il secondo file e' prendi nota di come cambia la parte "Percorso-NomeFile-NomeFoglio-Intervallo" nella formula
-usando altre formule calcola in M7 esattamente la stessa stringa "Percorso-NomeFile-NomeFoglio-Intervallo"
-nella formula originale sostituisci la stringa "Percorso-NomeFile-NomeFoglio-Intervallo" con Indiretto(M7)
-la formula adesso ti restituira' l'errore #Rif, ma se apri il secondo file dovresti vederla funzionare regolarmente
In M7 (o la cella che decidi di usare) devi vedere esattamente la stessa stringa che vedi nella formula, compreso il primo "apice" (visto nella cella, non nella barra della formula).

Se la formula ti da' #Rif significa che quella stringa non e' la stringa giusta.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cerce vert in una cartella di rete

Postdi giostacchio » 18/10/17 11:06

non ci credo!
L'apiceeeeeeeeeeeeeeeeeee....quel maledetto apice...l'apice ...Azz!!!

grazieeeeeeeeee Anthony
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Re: cerce vert in una cartella di rete

Postdi Anthony47 » 18/10/17 22:30

Guarda anche se quanto stiamo dicendo in quest'altra discussione ti puo' tornare utile.
Avendo l'utente mau52 tanti file target (difficile da tenerli tutti aperti), l'approccio e' stato
-creare una stringa che abbia la sintassi di una formula
-una macro si occupa poi di mettere le stringhe come formule

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "cerce vert in una cartella di rete":


Chi c’è in linea

Visitano il forum: Nessuno e 47 ospiti