Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel: riferimenti esterni dopo copiatura

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel: riferimenti esterni dopo copiatura

Postdi karug64 » 28/09/17 08:48

Salve a tutti.
Per esigenze di lavoro spesso mi trovo a dover "ricomporre" in un unico file (che ha la stessa composizione degli altri, con stessi fogli denominati alla stessa maniera) il contenuto di vari fogli identici.
Quindi provvedo a copiare le celle dei vari fogli incolonnandole in un unico foglio complessivo.

Il problema è che nelle formule mi viene riportato il riferimento esterno al file di provenienza. Es.

Codice: Seleziona tutto
=SE(H2552>=81;"T";SE(E(H2552>=61;H2552<=80);"C";SE(E(H2552>=41;H2552<=60);"P";SE(E(H2552>=21;H2552<=40);"N";SE(E(H2552>=1;H2552<=20);"F";SE(E(H2552=0;(CONTA.SE(D2545:D2551;'C:\TEST\[Giorgio_schede.xlsm]Base_dati'!$H$1)+CONTA.SE(D2545:D2551;'C:\TEST\[Giorgio_schede.xlsm]Base_dati'!$H$2)+CONTA.SE(D2545:D2551; 'C:\TEST\[Giorgio_schede.xlsm]Base_dati'!$H$3)+CONTA.SE(D2545:D2551; 'C:\TEST\[Giorgio_schede.xlsm]Base_dati'!$H$4)+CONTA.SE(D2545:D2551; 'C:\TEST\[Giorgio_schede.xlsm]Base_dati'!$H$5)=0));"Nullo";"OK"))))))


invece di:

Codice: Seleziona tutto
=SE(H2552>=81;"T";SE(E(H2552>=61;H2552<=80);"C";SE(E(H2552>=41;H2552<=60);"P";SE(E(H2552>=21;H2552<=40);"N";SE(E(H2552>=1;H2552<=20);"F";SE(E(H2552=0;(CONTA.SE(D2545:D2551;Base_dati'!$H$1)+CONTA.SE(D2545:D2551;Base_dati'!$H$2)+CONTA.SE(D2545:D2551; Base_dati'!$H$3)+CONTA.SE(D2545:D2551; Base_dati'!$H$4)+CONTA.SE(D2545:D2551; Base_dati'!$H$5)=0));"Nullo";"OK"))))))




Spostando il file finale su un altro computer all'apertura non vengono rinvenuti i riferimenti ai files originari e non funziona.

C'e' un modo per fare in modo che quando si incollano celle provenienti da altri file non vengano riportati i riferimenti esterni ma si calcolino quelle degli intervalli attuali ?

Grazie
Office 2010
karug64
Utente Senior
 
Post: 641
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: excel: riferimenti esterni dopo copiatura

Postdi Marius44 » 28/09/17 11:55

Ciao
La butto lì ma non ho fatto alcuna prova.
Leggendo il codice forse si potrebbe mettere al posto di
Codice: Seleziona tutto
'C:\TEST\[Giorgio_schede.xlsm]

questa riga
Codice: Seleziona tutto
ActiveWorkbook.


Scusa se ho detto baggianate.
Ciao,
Mario
Marius44
Utente Senior
 
Post: 269
Iscritto il: 07/09/15 22:00

Re: excel: riferimenti esterni dopo copiatura

Postdi Anthony47 » 29/09/17 14:14

In aggiunta al suggerimento di Mario, vedi sopra.
Si potrebbe cercare all'interno delle formule la stringa
Codice: Seleziona tutto
C:\TEST\[Giorgio_schede.xlsm]

E sostituirla con una stringa vuota.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 14984
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "excel: riferimenti esterni dopo copiatura":


Chi c’è in linea

Visitano il forum: xilofono e 23 ospiti