Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cerca Vert che non mi funziona

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca Vert che non mi funziona

Postdi danibi60 » 18/09/17 14:25

Buongiorno a tutti,

sono ore che smanetto per cercare di inserire, attraverso il "cerca vert" la regione nel foglio di lavoro "Luglio2017" andando a prendere i dati dalla fonte posta nello stesso file nella sheet denominata cap_località_pr_regione...ma nulla da fare.

Ho provato a formattare tutti i campi in maniera univoca ma anche in questo caso nulla da fare.

Mi potete aiutare segnalandomi dove sbaglio?

Grazie

Danibi60

di seguito il link del file.

https://www.dropbox.com/s/j4oaslu85arij ... .xlsx?dl=0
"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Win 10 & Office365 Premium
danibi60
Utente Senior
 
Post: 383
Iscritto il: 11/07/13 09:21
Località: Bergamo

Sponsor
 

Re: Cerca Vert che non mi funziona

Postdi alfrimpa » 18/09/17 15:41

Hai la colonna E formattata a testo.

Assegna il formato Generale e vedrai che questa formula

Codice: Seleziona tutto
=CERCA.VERT(B2;CAP_Località_Pr_Regione!C2:D14481;2;FALSO)


funzionerà correttamente.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 1201
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Cerca Vert che non mi funziona

Postdi Anthony47 » 19/09/17 03:25

A me la descrizione "nulla da fare" non dice nulla:
-hai il problema che invece del risultato vedi la formula? In questo caso segui il consiglio di Alfredo.
-scrivi la formula ma essa produce un risultato diverso da quel che aspettavi? Quale? In alcuni casi funziona bene (fai un paio di casi) e in altri funziona male (fai un paio di casi)? Con quale formula?
-non riesci a capire come comporre la formula?
-cos'altro?

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17795
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cerca Vert che non mi funziona

Postdi danibi60 » 14/05/18 13:30

Ciao Anthony, siamo alle solite...
non riesco a far funzionare il cerca vert nel file allegato.

Vorrei inserire nella sheet BASE_CELERE e esattamente in colonna D (REGIONE)
La fonte da dove prendere tale è sempre nello stesso file nella sheet Cap_Regione
Ho provato in mille modi ma nulla da fare... sigh... non so dove sbaglio...

Posso contare sul tuo aiuto?
ecco il link del file

https://www.dropbox.com/s/fjbiwctv97xal ... .xlsx?dl=0

Grazie infinite
Daniby
"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Win 10 & Office365 Premium
danibi60
Utente Senior
 
Post: 383
Iscritto il: 11/07/13 09:21
Località: Bergamo

Re: Cerca Vert che non mi funziona

Postdi Anthony47 » 14/05/18 14:29

Devi leggere nell'help on line di Excel la descrizione della funzione Cerca.Vert e capire la differenza tra mettere il parametro "intervallo" su Vero o su Falso.
Sintetizzando, "Vero" ti restituisce un risultato approssimato, "Falso" ti restituisce il risultato esatto (se esiste) o l'errore #N/D.

Ora se cerchi il cap 98128 nel foglio CAP e pero' ti accontenti di un risultato approssimato (infatti 98128 non corrisponde al comune di CONTESSE), non meravigliarti che l'uso di una chiave approssimata sulla tabella di Foglio1 non produca un risultato.

Ma poi, perche' usi due tabelle contenenti cap diversi? Non basta quella di Foglio1 che comprende sia le citta' che provincie e regioni, oltre al cap?
Io userei in C2 e D2 rispettivamente
Codice: Seleziona tutto
=CERCA.VERT(TESTO(B2;"00000");Foglio1!A:B;2;FALSO)

Codice: Seleziona tutto
=CERCA.VERT(TESTO(B2;"00000");Foglio1!A:D;4;FALSO)

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17795
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Cerca Vert che non mi funziona":

Bluetooth non funziona.
Autore: hcb
Forum: Software Windows
Risposte: 2
Link che non funziona
Autore: danibi60
Forum: Software Windows
Risposte: 2

Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti