Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Differenza tra date in giorni,ore,minuti e secondi

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Differenza tra date in giorni,ore,minuti e secondi

Postdi Cedamido » 31/01/17 01:00

Cella A2 28/05/2017 cella A3 31/01/2017 0.48
Vorrei calcolare la differenza tra le date indicate in giorni, ore, minuti e secondi.
Grazie
excel 2003
Cedamido
Utente Senior
 
Post: 302
Iscritto il: 17/08/08 23:26

Sponsor
 

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi ricky53 » 31/01/17 01:25

Ciao,
in "A4" scrivi
Codice: Seleziona tutto
=A2-A3

e formatta la cella "A4" in
Codice: Seleziona tutto
gg hh:mm:ss
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4526
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi wallace&gromit » 31/01/17 08:59

Ciao,
Ricky, penso che Cedamido voglia qualcosa di più.
Tra l'altro non so se è un problema solo mio, ma la tua formula non mi restituisce il numero di giorni totali ma il numero di giorni al netto dei mesi.
Comunque questa formula, ammettendo che in A1 ci sia scritto 28.05.2017, restituisce il tempo che manca da ora allo scoccare della mezzanotte tra il 27 ed il 28 maggio. Istante in cui Cedamido festeggerà... la meritata pensione (?)

Codice: Seleziona tutto
=A1-INT(ADESSO())-1 & " " & INT((1-RESTO(ADESSO();1))*24) & ":" & DESTRA("00" & INT((1-RESTO(ADESSO()*24;1))*60);2) & ":" & DESTRA("00"& INT((1-RESTO(ADESSO()*24*60;1))*60);2)

È un po' lunghetta, forse Canapone la ridurrebbe in tre paroline, ma questo è quello che so fare io!

P.S. ancora 116 giorni, forza Cedamido
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi ricky53 » 31/01/17 11:51

Ciao,
W&G:
ad una certa ora si deve andare a dormire ... io avevo controllato con differenze inferiori ad un mese ed andavano bene ... !!!


Cedamido:
prova in quest'altro modo
Codice: Seleziona tutto
=TESTO(A2-A3-1; "0") & " - " & TESTO(RESTO(A2-A3; INT(A2-A3)); "hh:mm:ss")

con
"A2" che contiene la data finale, nel tuo esempio 28-05-2017 00:48:00
e
"A3" che contiene =ADESSO() oppure un'altra data e orario
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4526
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi wallace&gromit » 31/01/17 15:40

CIao Ricky,
ottima soluzione, più "pulita" della mia, però c'era un "-1" di troppo nella tua formula.
Così mi da il valore corretto:
Codice: Seleziona tutto
=TESTO(A2-A3; "0") & " - " & TESTO(RESTO(A2-A3; INT(A2-A3)); "hh:mm:ss")


Volendo integrare la funzione adesso:
Codice: Seleziona tutto
=TESTO(A2-ADESSO(); "0") & " - " & TESTO(RESTO(A2-ADESSO(); INT(A2-ADESSO())); "hh:mm:ss")
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi ricky53 » 31/01/17 15:59

Ciao,
si mi ero dimenticato di toglierlo ... lo avevo inserito nelle varie prove.
GRAZIE.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4526
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi ricky53 » 31/01/17 16:24

Ciao,
però se l'orario in "A2" è minore di quello in "A3" il calcolo fornisce un giorno di troppo e la formula va complicata, inoltre la funzione RESTO per differenza giorni "0" va in errore quindi ecco la formula più complicata ma che dovrebbe essere esente dalle due problematiche che ho esposto:

Codice: Seleziona tutto
=TESTO(A2-A3-SE(ORARIO(ORA(A2); MINUTO(A2); SECONDO(A2))<ORARIO(ORA(A3); MINUTO(A3); SECONDO(A3)); 1;0); "0") & "  e  " & TESTO((A2-A3)-INT(A2-A3); "hh:mm:ss")


Va fatto un test per i casi ordinari e limite (differenza di1 giorno, orario minore e maggiore), ... altri casi che vi vengono in mente.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4526
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi Cedamido » 31/01/17 17:27

Cella A2 31/01/2017
cella A3 05/02/2017 cella B3 -4  e  17:12:22

Vi ringrazio per le risposte, ho provato tutte le formule indicate da Entrambi, nessuna è esatta, l'ultima si avvicina ma secondo me manca un giorno in quanto dal 31/01/2017 al 05/02/2017 sono 5 giorni e non 4.

Questa è la formula che ho provato come ultima
=TESTO(A2-A3-SE(ORARIO(ORA(A2); MINUTO(A2); SECONDO(A2))<ORARIO(ORA(A3); MINUTO(A3); SECONDO(A3)); 1;0); "0") & " e " & TESTO((A2-A3)-INT(A2-A3); "hh:mm:ss")
excel 2003
Cedamido
Utente Senior
 
Post: 302
Iscritto il: 17/08/08 23:26

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi wallace&gromit » 31/01/17 22:23

A seconda dei rispettivi orari la differenza tra il 31.01 ed il 05.02 può variare da 4 a 6 giorni.
A me sembra che la formula di Ricky che hai usato sia esatta.
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi ricky53 » 01/02/17 01:10

Ciao Cedamido,
hai invertito le date!
... Cella A2 28/05/2017 cella A3 31/01/2017 0.48 ...

La data maggiore, seguendo il tuo esempio iniziale, va in "A2" e in "A3" avevi messo =ADESSO().
Io ho impostato la soluzione con queste condizioni.

A conferma di ciò la differenza che ottieni è NEGATIVA !

Attenzione agli orari contenuti nelle due celle ... tu avevi chiesto proprio di avere anche hh:mm:ss.
Questo vuol dire che nelle celle devi far vedere le due ore.
Imposta il formato in modo che sia visibile anche l'ora.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4526
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi Cedamido » 01/02/17 10:49

Ok, Vi ringrazio, funziona alla grande con giorni ore minuti e secondi.
excel 2003
Cedamido
Utente Senior
 
Post: 302
Iscritto il: 17/08/08 23:26

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi Cedamido » 04/02/17 12:37

cella D22 05/02/2017 cella E22 04/02/2017 12.24
=TESTO(D22-ADESSO(); "0") & " - " & TESTO(RESTO(D22-ADESSO(); INT(D22-ADESSO())); "hh:mm:ss")
da errore DIV/0

Scusate se insisto, da l'errore su indicato, si può correggere?
Grazie
excel 2003
Cedamido
Utente Senior
 
Post: 302
Iscritto il: 17/08/08 23:26

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi wallace&gromit » 04/02/17 15:00

Hai ripreso la formula vecchia in cui Ricky aveva già segnalato la presenza di un errore, ma tu stesso avevi già utilizzato quella nuova, se ti serve con la funzione adesso() trasformala così:
Codice: Seleziona tutto
=TESTO(D22-ADESSO()-SE(ORARIO(ORA(D22); MINUTO(D22); SECONDO(D22))<ORARIO(ORA(ADESSO()); MINUTO(ADESSO()); SECONDO(ADESSO())); 1;0); "0") & " e " & TESTO((D22-ADESSO())-INT(D22-ADESSO()); "hh:mm:ss")
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi ricky53 » 04/02/17 16:26

Ciao,
leggi quanto ti hai scritto W&G.

Però dovresti stare un po' più attento a quello che ti scriviamo!

Domanda: in "E22" hai inserito la funzione ADESSO().
se "SI" allora perché non hai utilizzato la formula che ti ho proposto il 31/01/17 alle ore 16:24 ?

La riporto
=TESTO(A2-A3-SE(ORARIO(ORA(A2); MINUTO(A2); SECONDO(A2))<ORARIO(ORA(A3); MINUTO(A3); SECONDO(A3)); 1;0); "0") & " e " & TESTO((A2-A3)-INT(A2-A3); "hh:mm:ss")


Tu devi solo cambiare le celle:
da A2 =====>> a D22
da A3 =====>> a E22
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4526
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Differenza tra date in giorni,ore,minuti e secondi

Postdi Cedamido » 06/02/17 10:14

OK grazie.
excel 2003
Cedamido
Utente Senior
 
Post: 302
Iscritto il: 17/08/08 23:26


Torna a Applicazioni Office Windows


Topic correlati a "Differenza tra date in giorni,ore,minuti e secondi":


Chi c’è in linea

Visitano il forum: Nessuno e 42 ospiti