Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Confrontare dati

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Confrontare dati

Postdi contiend » 06/08/16 22:10

Ciao a tutti,
vi espongono subito il mio "problema" .

Ho una tabella con

COL A
1 | CAIO
2 | GIGIO
3 | SEMPRONIO
4 | SANDRO
5 | TRIMIO

COL B
In questa colonna, a fianco ai nomi sopra elencati, possono avvenire due casi:
- numero postivo, zero o negativo
- cella vuota

COL E
1 | Sempronio (nome che può cambiare di volta in volta)

COL F
1 | qui dovrebbe esserci la formula:
dovrebbe verificare che il nome in cella E1 sia presente in COLONNA A
se questo è vero, dovrebbe verificare che nell'adiacente COLONNA B, ci sia un numero (o lo zero).
A questo punto dovrebbe dare come risultato un " +1 "
Se nella colonna B ci sarà una cella vuota , allora in F1 non risulterà nulla.


Come sempre spero di essermi fatto capire,
vi ringrazio dell'attenzione e spero possiate aiutarmi.

Grazie ancora.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: Confrontare dati

Postdi karug64 » 07/08/16 12:27

Se ho ben capito, questa potrebbe essere una soluzione:

Codice: Seleziona tutto
=SE(CERCA.VERT(E1;A1:B5;2;FALSO);"+1";"")


Ciao
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Re: Confrontare dati

Postdi contiend » 07/08/16 12:35

Direi che funziona :D
Grazie mille
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Re: Confrontare dati

Postdi contiend » 09/08/16 09:52

Gentilmente posso chiedere un aggiunta.

In quanto quando il nome non è presente nella lista mi riporta un errore #N/D . In quel caso dovrebbe riportarmi uno " 0 " invece che un " #N/D ", altrimenti altre celle con formule andrebbero in tilt :D

Stavo cercando d'inserire un "val errore" nella formula ma non riesco ad incastrarla. Un aiuto?

Grazie ancora.
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Re: Confrontare dati

Postdi alfrimpa » 09/08/16 10:00

Se hai una versione di Excel 2007 o successive puoi usare questa formula

Codice: Seleziona tutto
SE.ERRORE(SE(CERCA.VERT(E1;A1:B5;2;FALSO);"+1";"");0)
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 841
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Confrontare dati

Postdi contiend » 09/08/16 12:47

super grazie!
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45


Torna a Applicazioni Office Windows


Topic correlati a "Confrontare dati":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti