Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula excel UNICA

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula excel UNICA

Postdi MicheleMichele » 25/07/16 09:18

Buongiorno a tutti,
volevo chiedere supporto sul seguente problema.
Ho un file della consegna della posta, dove in una colonna (mettiamo per esempio colonna G) vengono riportati i seguenti stati: Consegnato; Spedito e Da ritirare.

Nella colonna I vorrei inserire una formula di controllo. Per adesso sono riuscito a creare 3 formule di controllo a seconda del valore nella colonna G. Vedi sotto

Per G1=Spedito
IF(OR(M11="";L11="";N11<>"n.a.";O11<>"n.a.");"ERRORE";"OK")
Per G1=Consegnato
=IF(OR(M2="";L2="";N2="";O2="");"ERRORE";"OK")
Per G1=Da ritirare
=IF(OR(A264="";H264="";M264<>"";L264<>"";N264<>"";O264<>"");"ERRORE";"OK")

E' possibile aggregare le 3 formule in modo da inserire tale controllo su una solo colonna (es colonna I) a seconda del valore trovato in G?
Grazie

Miky





Top



--------------------------------------------------------------------------------
MicheleMichele
Newbie
 
Post: 2
Iscritto il: 25/07/16 08:25

Sponsor
 

Re: Formula excel UNICA

Postdi Anthony47 » 26/07/16 01:21

Ciao Michele, benvenuto nel forum.

Nella colonna I vorrei inserire una formula di controllo.
[. . . .]

A spanne direi che la combinazione delle tre formule potrebbe portare a
Codice: Seleziona tutto
=SE(G1="Spedito";SE(O(M11="";L11="";N11<>"n.a.";O11<>"n.a.");"ERRORE";"OK");SE(G1="Consegnato";SE(O(M2="";L2="";N2="";O2="");"ERRORE";"OK");SE(G1="Da ritirare";IF(OR(A264="";H264="";M264<>"";L264<>"";N264<>"";O264<>"");"ERRORE";"OK");"Errore")))
(modifica il nome delle funzioni se hai Excel in versione Inglese)

Se questo non e' quello che cercavi allora dovresti spiegare quale e' il layout dei tuoi dati e che cosa vorresti ottenere con la formula di controllo; meglio se alleghi un file con dati verosimili.
Per le istruzioni su come allegare un file:
viewtopic.php?f=26&t=103893&p=605487#p605487

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Formula excel UNICA":


Chi c’è in linea

Visitano il forum: alfrimpa e 18 ospiti