Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

CONTA.VAL ma solo se cella successiva non vuota

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

CONTA.VAL ma solo se cella successiva non vuota

Postdi edino » 04/07/16 15:55

Ciao a tutti,
ho delle righe con n celle (esempio B2:AO2);
in queste celle posso inserire un valore "On" oppure lasciarle vuote;
avrei bisogno di contare le celle "On" che però hanno nella cella successiva adiacente un altra cella "On";
esempio pratico (ho messo meno colonne giusto per farmi capire):
On - On - On - Vuota - Vuota - On - Vuota - On - On - Vuota - Vuota - Vuota - Vuota - Vuota - Vuota - Vuota - Vuota - On - Vuota... (mi fermo qui spero sia chiaro...).
Se uso semplicemente la formula =CONTA.SE(B2:AO2;"On") mi restituisce il totale delle celle "On";
Esempio, vengono conteggiate queste: On - On - On - Vuota - Vuota - On - Vuota - On - On - Vuota - Vuota - Vuota - Vuota - Vuota - Vuota - Vuota - Vuota - On - Vuota
Quindi in totale avrò 7 celle On.
Invece io vorrei escludere quelle che hanno la cella adiacente successiva vuota, per esempio vorrei conteggiare le seguenti:
On - On - On - Vuota - Vuota - On - Vuota - On - On - Vuota - Vuota - Vuota - Vuota - Vuota - Vuota - Vuota - Vuota - On - Vuota
Qui avrò in totale 3 celle On.

Dovrò effettuare questa operazione per 24 righe...

Successivamente dovrò fare questa operazione per 40 colonne...

Mi piacerebbe poterlo fare senza macro, con cui non ho dimestichezza.

Grazie in anticipo
MS Office 2007-2010
Win7
edino
Utente Junior
 
Post: 17
Iscritto il: 15/09/14 14:49

Sponsor
 

Re: CONTA.VAL ma solo se cella successiva non vuota

Postdi scossa » 04/07/16 20:02

Una possibile soluzione:

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((B2:$AO$2="On")*(C2:$AP$2="On"))
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: CONTA.VAL ma solo se cella successiva non vuota

Postdi edino » 05/07/16 08:00

Ciao scossa! Grazie per l'aiuto! Intanto funziona! Ma volevo capirci qualcosa:
intanto perché hai fissato le celle $AO$2 e $AP$2?

Quindi io adatto la formula per le n righe e poi la "rigiro" per le n colonne...
Poi faccio una somma dei risultati... Corretto?

Grazie
MS Office 2007-2010
Win7
edino
Utente Junior
 
Post: 17
Iscritto il: 15/09/14 14:49

Re: CONTA.VAL ma solo se cella successiva non vuota

Postdi edino » 05/07/16 16:16

Scusate... Un altra domanda:
se invece di avere solo il valore "On" avessi anche il valore "Off" che va ugualmente conteggiato, come diventerebbe la formula?
Io ho provato a inserire una funzione "o" ma non funziona...
MS Office 2007-2010
Win7
edino
Utente Junior
 
Post: 17
Iscritto il: 15/09/14 14:49

Re: CONTA.VAL ma solo se cella successiva non vuota

Postdi edino » 05/07/16 16:31

Avrei risolto con questa formula:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((--($B2:$AO2="On")--($B2:$AO2="Off"))*(--($C2:$AP2="On")--($C2:$AP2="Off")))


Sembra che funzioni correttamente... Potete solo confermarmi che sia effettivamente OK?

Grazie
MS Office 2007-2010
Win7
edino
Utente Junior
 
Post: 17
Iscritto il: 15/09/14 14:49

Re: CONTA.VAL ma solo se cella successiva non vuota

Postdi scossa » 05/07/16 17:58

edino ha scritto:Scusate... Un altra domanda:
se invece di avere solo il valore "On" avessi anche il valore "Off" che va ugualmente conteggiato, come diventerebbe la formula?
Io ho provato a inserire una funzione "o" ma non funziona...


Cambia semplicemente
$B2:$AO2="On"
in
$B2:$AO2<>""
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona


Torna a Applicazioni Office Windows


Topic correlati a "CONTA.VAL ma solo se cella successiva non vuota":


Chi c’è in linea

Visitano il forum: enrico43 e 13 ospiti