Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cerca in un matrice

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca in un matrice

Postdi Ubuntus » 22/06/16 15:38

ciao

Dovrei cercare dentro una specie di matrice/DB, sulle colonne ho le date, sulle righe i nomi con le matricole


w1 w1 w1 w2
venerdì sabato domenica lunedì
TURNO 01/01/2016 02/01/2016 03/01/2016 04/01/2016
Nome Matricola
carlo 4053 1
Marco 4212 3 1 1 1 1

Vorrei che nel mio file nella posizione, 1 agosto matricola 4212 incrociasse i dati che pesca dal dB, come potrei fare
utilizzando un indice ed un confronta?

LU MA ME GI VE SA
01-ago 02-ago 03-ago 04-ago 05-ago 06-ago
Matricola

4212
436
9486
4280
4288
4328
4186
4202

grazie
Ubuntus
Utente Junior
 
Post: 73
Iscritto il: 24/07/15 15:56

Sponsor
 

Re: Cerca in un matrice

Postdi Anthony47 » 23/06/16 00:26

Il layout dei tuoi dati e' illegibile; la migliore idea che mi sono fatto e' che il database Matricola /Data abbia questo aspetto:
Immagine
url immagine
Supponiamo che si trovi su Foglio2.

A questo punto, su un'altro foglio, hai questa matrice, con le instazioni in giallo (matricola /data)
Immagine
free image upload
Allora puoi ottenere in B3 il turno segnato nel DB con la formula
Codice: Seleziona tutto
=INDICE(Foglio2!$B$1:$I$10;CONFRONTA($A3;Foglio2!$B$1:$B$20;0);CONFRONTA(B$2;Foglio2!$B$1:$I$1;0))
Copia la formula verso destra e verso il basso.
Il risultato dell'immagine e' ottenuto formattando le celle del risultato in "Stile separatore" (e' l'icona normalmente rappresentata con "000") con nessun decimale.

Se hai una situazione simile, vedi di adattare la formula al tuo layout; se invece e' tutta un'altra cosa allora cerca di allegare almeno uno screenshot dei dati; per come allegare un file o uno screenshot guarda qui: viewtopic.php?f=26&t=103893#p605486

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Cerca in un matrice":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti

cron