Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Lista controllo con doppioni

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Lista controllo con doppioni

Postdi iki » 14/06/16 11:10

Buongiorno,
ho provato a cercare se ci fossero topic che potessero rispondere al mio quesito.

ho una lista di CAP a cui non posso spedire ad un prezzo agevolato;
questa lista contiene doppioni;
in base agli indirizzi che mi vengono forniti devo avere la conferma se la spedizione viene fatta a prezzo ageolato o meno.

nella colonna Z inserisco i CAP di controllo, devo eliminare i doppioni (non è necessario se non creano problemi al passaggio successivo)
ovvero se nella colonna S, inserisco i CAP a cui devo spedire e se tali CAP coincidono con quelli della colonna Z vorrei si colorassero di Rosso (o si evidenziasse di rosso la cella, come è più smplice)

non so se son riuscito a spiegarmi.
qualcuno può suggerirmi una soluzione?
grazie
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Sponsor
 

Re: Lista controllo con doppioni

Postdi alfrimpa » 14/06/16 14:57

Ciao Iki

Da quel che dici sembrerebbe che potresti risolvere con la formattazione condizionale ma se alleghi un file di esempio (con la descrizione di quello che vuoi ottenere) sarà più facile aiutarti.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 841
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Lista controllo con doppioni

Postdi iki » 14/06/16 17:27

ci provo,
mi servirebbe che i CAP di spedizione vengano controllati con la lista nera ed in caso di congruenza si evidenzi di rosso

ma non so come allegare un file 8)
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56


Re: Lista controllo con doppioni

Postdi Anthony47 » 15/06/16 02:31

Nel file mi par di capire che i CAP "proibiti" sono in colonna I, e quelli a cui devi inviare sono in colonna M.
Sviluppando il suggerimento di Alfredo:
-seleziona l'area di colonna M in cui potresti inserire un CAP di Invio; io ho usato M1:M1000
-avvia la formattazione condizionale; scegli "Utilizza una formula per determinare le celle da formattare";
-come formula inserisci
Codice: Seleziona tutto
=CONTA.SE($I$1:$I$10000;M1)>0

-premi Formato, tab Riempimento, scegli il colore Rosso
-Ok, Ok

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Lista controllo con doppioni

Postdi iki » 21/06/16 12:30

Intanto grazie per l'aiuto...
Pero', scusate, sono piuttosto imbranato.

ho provato ad applicare la formula, correggendola in quanto il foglio è leggermente diverso, ma non sono riuscito a farlo in modo corretto.

mi succede che se inserisco un CAP che è all'interno della lista mi si colora una cella diversa, esattemnte 5 posizioni sotto.
oopure, a volte non si colora nemmeno.
considerando che all'interno della lista nera ci sono dei doppioni, questi potrebbero interferire?

ecco il file come si presenta, ovviamente ho cancellato i dati sensibili, ma le posizioni sono esatte

https://docs.google.com/spreadsheets/d/ ... =961537933
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: Lista controllo con doppioni

Postdi Anthony47 » 22/06/16 00:30

Il file che hai linkato e' disponibile solo al proprietario; se non riesci a condividere tramite Google Drive usa uno dei server descritti qui: viewtopic.php?f=26&t=103893&p=605487#p605487

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Lista controllo con doppioni

Postdi iki » 22/06/16 08:47

Grazie Anthony47,
scusate la goffaggine

ecco il file

http://www.filedropper.com/ordinemaglietecnicheverxlsx
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56

Re: Lista controllo con doppioni

Postdi Anthony47 » 23/06/16 00:30

Se la "lista nera" e' in AA1:AA10000 e i cap che vuoi controllare sono in T7 e sottostanti, allora la formula di formattazione condizionale deve essere
Codice: Seleziona tutto
=CONTA.SE($AA$7:$AA$10000;T7)>0

Modifica la tua formula usando i comandi di Formattazione condizionale /Gestisci regole

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Lista controllo con doppioni

Postdi iki » 29/06/16 10:59

GRAZIE, GRAZIE, GRAZIE MILLE :)
:)
iki
Utente Junior
 
Post: 27
Iscritto il: 04/12/10 17:56


Torna a Applicazioni Office Windows


Topic correlati a "Lista controllo con doppioni":


Chi c’è in linea

Visitano il forum: Nessuno e 47 ospiti