Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cerca dati incrociati in tabella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca dati incrociati in tabella

Postdi riccardo34 » 12/06/16 09:55

Ciao a tutti,
sono nuovo del forum e avrei bisogno del vostro aiuto poichè ho un problema che non riesco a risolvere con le funzioni standard e mi piacerebbe capire come potere fare con VBA.
Vorrei riempire il campo del foglio 1 (cella gialla con ???) prendendo le info dalla tebella del foglio 2.
Purtroppo con un cerca vert non è possibile, poichè è necessario prima filtrare solo la colonna di interesse (auto, moto bici ecc)

Vi allego il file per farvi capire.
http://www.filedropper.com/esempiocerca

GRazie mille per il vostro prezioso aiuto

Riccardo
riccardo34
Newbie
 
Post: 5
Iscritto il: 23/03/07 14:42

Sponsor
 

Re: Cerca dati incrociati in tabella

Postdi alfrimpa » 12/06/16 18:51

Scusa Riccardo ma non capisco bene quali sono i valori che ti aspetti di vedere nelle celle gialle del primo foglio in base ai dati contenuti nel secondo.

Azzardo un'ipotesi: 6 e 1?
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 842
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Cerca dati incrociati in tabella

Postdi riccardo34 » 12/06/16 20:45

Ciao, scusa ma non misono spiegato bene.
Il risultato che vorrei ottenere è: cella c2=a cella c3=a
Cioè capire che: l'auto2 monta ruote con codice a e l'auto monta clacson con codice a.
In poche parole è un cerca vert che prima di fare la ricerca presuppone il filtro della colonna.
riccardo34
Newbie
 
Post: 5
Iscritto il: 23/03/07 14:42

Re: Cerca dati incrociati in tabella

Postdi Anthony47 » 12/06/16 22:08

Allora prova in C2 di Foglio1 la formula
Codice: Seleziona tutto
=INDICE(Foglio2!$B$1:$B$100;CONFRONTA(B2;SE(INDICE(Foglio2!$A$1:$H$100;;CONFRONTA(A2;Foglio2!$A$1:$H$1;0))<>"";Foglio2!$A$1:$A$100;"");0))

Da confermare con Contr-Maiusc-Enter, non il solo Enter. Poi copia verso il basso.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cerca dati incrociati in tabella

Postdi riccardo34 » 13/06/16 17:42

Ciao, intanto non saprei come ringraziarti perchè funziona ed io non ci sarei mai arrivato.
Pero' vorrei capire come funziona :(

[code]=INDICE(Foglio2!$B$1:$B$100;CONFRONTA(B2;SE(INDICE(Foglio2!$A$1:$H$100;;CONFRONTA(A2;Foglio2!$A$1:$H$1;0))<>"";Foglio2!$A$1:$A$100;"");0))[/code]


Nella funzione SE gli dici: se nella matrice il valore della colonna A2 è diverso da "", se vero Foglio2!$A$1:$A$100, se falso "".
Cosa significa la sintassi: se vero Foglio2!$A$1:$A$100?? Questo non mi è chiaro. In realtà non capisco perchè viene utilizzato il SE.

Grazie

Riccardo
riccardo34
Newbie
 
Post: 5
Iscritto il: 23/03/07 14:42

Re: Cerca dati incrociati in tabella

Postdi Anthony47 » 14/06/16 01:33

Con SE(INDICE(Foglio2!$A$1:$H$100;;CONFRONTA(A2;Foglio2!$A$1:$H$1;0))<>"";Foglio2!$A$1:$A$100;"") creo una matrice che contiene solo i componenti che nella colonna relativa al "Modello" hanno un valore; CONFRONTA restituisce la posizione in questa matrice del componente cercato; INDICE infine restituisce il valore di colonna B cercato.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Cerca dati incrociati in tabella":


Chi c’è in linea

Visitano il forum: patel e 8 ospiti