Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] contare solo le ultime N righe

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] contare solo le ultime N righe

Postdi mmrrcc » 04/06/16 14:54

Ciao a tutti!
spero sia la sezione giusta.. vi espongo il mio problema:
- ho circa 3000 righe con 8 numeri per ogni riga
- i numeri sono tutti dall'1 al 99
- periodicamente si aggiunge una riga con altri 8 numeri.

Vorrei sapere se c'è una formula che mi restituisce il numero di righe nelle quali, partendo dall'ultima in assoluto e andando verso l'alto, il numero non è presente.

Faccio un esempio. Ho 5 righe con i seguenti numeri:

1, 10, 15, 60, 70, 80, 85, 95
1, 8, 13, 40, 50, 55, 65, 99
3, 5, 10, 20, 30, 35, 38, 90
2, 7, 9, 11, 18, 22, 23, 60
1, 2, 6, 12, 14, 15, 86, 91

Vorrei che inserendo in una cella il numero 1 per sapere per quante volte (dall'ultima volta che si è verificato) il numero 1 non si è verificato mi restituisse 0 nella cella a fianco (perché l'1 sta nell'ultima riga), inserendo il numero 60 vorrei che restituisse 1 perché la riga nella quale è presente il numero 60 è la seconda a partire dal basso, inserendo il numero 85 vorrei che restituisse 4 perché nelle ultime 4 righe il numero 85 non è presente, e così via.

Ciao
mmrrcc
Newbie
 
Post: 7
Iscritto il: 11/04/15 18:22

Sponsor
 

Re: [Excel] contare solo le ultime N righe

Postdi CANAPONE » 04/06/16 16:33

Ciao,

supponiamo che i numeri siano nelle colonne A:I a partire dalla seconda riga: in A2:H3000 il tuo database.

In J1 scrivo il numero che devo controllare.

Mi servo di una colonna di formule di servizio per semplificare il tutto, in I2 da copiare accanto al database di numeri:
Codice: Seleziona tutto
=CONTA.SE(A2:H2;[b]J$1[/b])*RIGHE($1:1)

In K1 la formula che sfrutta la colonna di servizio di conta.se (la colonna I)
Codice: Seleziona tutto
=SE(SOMMA(I:I);CONTA.NUMERI(A:A)-MAX(I:I);"")


La formula restituisce il ritardo di uscita del numero.

Spero sia d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [Excel] contare solo le ultime N righe

Postdi mmrrcc » 04/06/16 20:31

Graaaandee!!! Funziona, perfetto, grazie mille!
mmrrcc
Newbie
 
Post: 7
Iscritto il: 11/04/15 18:22


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] contare solo le ultime N righe":


Chi c’è in linea

Visitano il forum: tex willer e 11 ospiti