Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

somma se e giorno.settimana

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

somma se e giorno.settimana

Postdi riskismoney » 16/04/16 13:23

E' possibile sommare dei risultati in base la giorno della settimana utilizzando la funziona somma.se?

es. somma.se(giorno.settimana(data);risultato) dove data è la colonna delle date e risultato è il numero associato a quella data.

Vorrei evitare la funzione MATR.SOMMA.PRODOTTO perchè rallenta molto il file.
riskismoney
Utente Senior
 
Post: 177
Iscritto il: 25/03/12 16:04

Sponsor
 

Re: somma se e giorno.settimana

Postdi CANAPONE » 16/04/16 15:22

Ciao,

credo tu debba usare matr.somma.prodotto specificando gli intervalli che vuoi elaborare

=MATR.SOMMA.PRODOTTO((GIORNO.SETTIMANA(A2:A100)=7)*(A2:A100<>"")*B2:B100)

Lasciando la formula così - esempio- rallenti parecchio la velocità di calcolo

=MATR.SOMMA.PRODOTTO((GIORNO.SETTIMANA(A:A)=7)*(A:A<>"")*B:B)

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: somma se e giorno.settimana

Postdi riskismoney » 16/04/16 15:25

Rallenta comunque i calcoli... quindi mi pare di capire che le funzione SOMMA.SE e GIORNO.SETTIMANA non siano utilizzabili insieme, è corretto?
riskismoney
Utente Senior
 
Post: 177
Iscritto il: 25/03/12 16:04

Re: somma se e giorno.settimana

Postdi CANAPONE » 16/04/16 15:26

Ciao,

se vuoi usare giorno.settimana non lo puoi fare con il somma.se.Il somma.se non accetta matrici di risultati da elaborare.

matr.somma prodotto sì.


Forse non ho capito bene.
Ultima modifica di CANAPONE su 16/04/16 15:31, modificato 1 volte in totale.
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: somma se e giorno.settimana

Postdi riskismoney » 16/04/16 15:30

CANAPONE ha scritto:Ciao,

se vuoi usare giorno.settimana non lo puoi fare con il somma.se.

Forse non ho capito bene.

Hai capito bene e dalla tua risposta si evince che le due funzioni non sono utilizzabili insieme. Grazie.
riskismoney
Utente Senior
 
Post: 177
Iscritto il: 25/03/12 16:04

Re: somma se e giorno.settimana

Postdi CANAPONE » 16/04/16 15:36

Ciao,

stavo cercando un articolo che confrontava la velocità di somma.se (o somma.più.se) e matr.somma.prodotto

L'argomento è diventato interessante quando matr.somma.prodotto ha accettato di elaborare anche intere colonne

=matr.somma.prodotto(--(a:a="pippo");(b:b))

Matr.somma.prodotto non restituisce più errore usando Excel 2007 ( o 2010 non ricordo ) , però elabora tutte le 2^20 righe, anche se i dati da elaborare sono solo nelle prime 50 righe.


Se ritrovo il link dove vengono paragonate le velocità di elaborazione lo metto in condivisione: credo di averlo nel pc in ufficio.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: somma se e giorno.settimana

Postdi riskismoney » 16/04/16 15:40

Ok grazie, ciao.
riskismoney
Utente Senior
 
Post: 177
Iscritto il: 25/03/12 16:04

Re: somma se e giorno.settimana

Postdi Anthony47 » 16/04/16 20:54

Ho testato formule del tipo
Codice: Seleziona tutto
1:  =SOMMA(SE(GIORNO.SETTIMANA(A2:A100;2)=1;B2:B100;""))
2: =MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(A2:A100;2)=1);B2:B100)
3: =MATR.SOMMA.PRODOTTO(--(GIORNO.SETTIMANA(A1:A100;2)=1);B1:B100)
4: =SOMMA((GIORNO.SETTIMANA(A2:A100;2)=1)*(B2:B100))

Le formule hanno tempi di esecuzione confrontabile (+/-1%)
Ho allungato l'intervallo fino a 1000; il tempo unitario aumenta di circa 10%, tempi di esecuzione confrontabile (+/-1%)
Ho allungato fino a 10mila: tempo unitario raddoppia, leggera prevalenza della formula 3 (-5%).
Ho allungato fino a 100mila: tempo unitario quintuplica, leggera prevalenza delle formule 2 e 3 (-5%)
Ho allungato fino a inserire l'intera colonna: tempo unitario decuplica, leggera prevalenza della formula 3 (-10%)
Insomma, in tutte le situazioni un riferimento all'intera colonna e' penalizzante, e i tempi di esecuzione sono dipendenti dall'intervallo specificato.

La 1 e la 4 sono "a matrice" (Contr-Maiusc-Enter)

I tempi unitari sono confrontati con la condizione precedente (non quella iniziale).

Per finire dico che la formula che ha performato meglio (con righe da 10mila in su) e' quella che non ho ancora scritto:
Codice: Seleziona tutto
=SOMMA.SE(C2:C100;1;B2:B100)

Questa considera che in colonna C ci sia il calcolo GIORNO.SETTIMANA.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: somma se e giorno.settimana

Postdi CANAPONE » 17/04/16 05:13

Ciao,

saluto subito Anthony47.

Mi riferivo a questo articolo:

https://fastexcel.wordpress.com/2015/12 ... -bad-idea/

Se non lo conosci, segnalo anche:

http://www.decisionmodels.com/index.htm

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: somma se e giorno.settimana

Postdi riskismoney » 17/04/16 10:16

Anthony47 ha scritto:Per finire dico che la formula che ha performato meglio (con righe da 10mila in su) e' quella che non ho ancora scritto:
Codice: Seleziona tutto
=SOMMA.SE(C2:C100;1;B2:B100)

Questa considera che in colonna C ci sia il calcolo GIORNO.SETTIMANA.

Ciao a tutti.

Grazie Anthony, preciso ed infallibile come sempre. E' esattamente quello che ho fatto.
riskismoney
Utente Senior
 
Post: 177
Iscritto il: 25/03/12 16:04


Torna a Applicazioni Office Windows


Topic correlati a "somma se e giorno.settimana":


Chi c’è in linea

Visitano il forum: Nessuno e 25 ospiti