Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel 2007: conta.più.se

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel 2007: conta.più.se

Postdi karug64 » 14/04/16 18:53

Salve a tutti.
Utilizzando excel 2007 avrei bisogno di contare quante occorrenze "codice" trovo sulla colonna "C" che abbiano in corrispondenza, in colonna "E" un valore (ovvero una cella non vuota)

Ho provato con questa formula

=conta.più.se(c1:c5000;"=codice";e1:e5000;"<>""")

ma mi conteggia anche le celle in cui in corrispondenza di c(x) = "codice" non abbiano in "E" alcun valore.

Nella fattispecie ho in colonna "C" 20 valori "codice" ed in colonna "E" solo 16 celle con valori.
Il risultato della formula è 20

Inoltre, sarebbe interessante sapere se nella formula si può mettere un riferimento ad un altro foglio (formula su foglio1, cella A1 e calcolo su intervalli di foglio2)


Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: excel 2007: conta.più.se

Postdi Anthony47 » 14/04/16 21:59

Non stare a scervellarti su funzioni che non si capisce al volo che vogliono, usa le vecchie MATR.SOMMA.PRODOTTO o anche solo SOMMA di una matrice; esempi:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(D1:D5000="codice");--(E1:E5000<>""))

Codice: Seleziona tutto
=SOMMA((Foglio1!D1:D5000="codice")*(Foglio1!E1:E5000<>""))

Questa seconda va introdotta come Contr-Maiusc-Enter

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2007: conta.più.se

Postdi karug64 » 14/04/16 23:44

Grazie come al solito, Anthony.
Avevo provato la conta.più.se perché mi era parso di capire che fosse un modo "più evoluto" di somma di matrice (che ad essere sincero non sono mai riuscito a capire bene ..... per esempio quei "--" ????).

Comunque, con le soluzioni proposte ho risolto. Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22


Torna a Applicazioni Office Windows


Topic correlati a "excel 2007: conta.più.se":


Chi c’è in linea

Visitano il forum: Nessuno e 20 ospiti