Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

inserire separatore in stringa data

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

inserire separatore in stringa data

Postdi mirmidone21 » 04/04/16 08:26

buongiorno a tutti
vengo subito al problema, ho queste stringhe che rappresentano una data, le quali purtroppo quando vengono importate attraverso un applicativo in csv non mi danno la possibilità di trasformarle in data con il separatore /
queste sono il tipo di stringa
A1
25112015
4012016
avevo usato questa funzione
Codice: Seleziona tutto
=SINISTRA(O2;2)&"/"&STRINGA.ESTRAI(O2;3;2)&"/"&DESTRA(O2;4)

che va bene per la prima stringa (25/01/2015), ma per la seconda no, perchè avendo un carattere in meno mi restituisce questo valore (40/12/2016).
cosa dovrei aggiustare nella formula? oppure c'è un metodo migliore?
grazie a tutti
Windows 7 sp1 -- Office 2013
Intel i5 4430 -- 3.00 ghz ---- 4gb RAM
mirmidone21
Utente Senior
 
Post: 124
Iscritto il: 26/10/15 16:48

Sponsor
 

Re: inserire separatore in stringa data

Postdi wallace&gromit » 04/04/16 10:29

Nella speranza che il mese sia sempre indicato con 2 cifre (altrimenti vi sarebbero date non univoche):
Codice: Seleziona tutto
=STRINGA.ESTRAI(O2;1;LUNGHEZZA(O2)-6)&"/"&STRINGA.ESTRAI(O2;LUNGHEZZA(O2)-5;2)&"/"&DESTRA(O2;4)
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: inserire separatore in stringa data

Postdi mirmidone21 » 04/04/16 11:08

GRAZIE wallace&gromit
il mese è sempre di due cifre, il giorno invece e a volte di una o due cifre.
la tua formula funziona benissimo, io avevo anche elaborato una simile cosa ne pensi?

Codice: Seleziona tutto
=SE(LUNGHEZZA(O2)=8;DATA(DESTRA(O2;4);STRINGA.ESTRAI(O2;3;2);SINISTRA(O2;2));DATA(DESTRA(O11;4);STRINGA.ESTRAI(O11;2;2);SINISTRA(O11;1)))
Windows 7 sp1 -- Office 2013
Intel i5 4430 -- 3.00 ghz ---- 4gb RAM
mirmidone21
Utente Senior
 
Post: 124
Iscritto il: 26/10/15 16:48

Re: inserire separatore in stringa data

Postdi wallace&gromit » 04/04/16 11:15

certo, anche quel principio funziona, vedo che hai aggiunto la trasformazione in data e non solo testo, che è senz'altro ragionevole, però verifica i riferimenti: un po' a O2 e un po' a O11.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: inserire separatore in stringa data

Postdi mirmidone21 » 04/04/16 11:23

hai ragione, avevo mischiato i riferimenti.
grazie
Windows 7 sp1 -- Office 2013
Intel i5 4430 -- 3.00 ghz ---- 4gb RAM
mirmidone21
Utente Senior
 
Post: 124
Iscritto il: 26/10/15 16:48


Torna a Applicazioni Office Windows


Topic correlati a "inserire separatore in stringa data":


Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti