Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Ultimo valore del cerca vert

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Ultimo valore del cerca vert

Postdi Ubuntus » 31/03/16 08:55

ciao

Come trovare ultimo valore di un del cerca vert

Colonna A Colonna B
A 1
A 2
A 3
A 2
B 4
B 8
C 1

Esempio se voglio cercare A mi restituisce 2; ( nel caso cerchero delle date, ma sara sempre la data piu recente)

penso sia qlc del genere
Codice: Seleziona tutto
 =INDICE(Foglio2.$B$1:$B$10;MAX(SE(Foglio2.$A$1:$A$10=A1;RIF.RIGA(Foglio2.$A$1:$A$10))))


grazie
Ubuntus
Utente Junior
 
Post: 73
Iscritto il: 24/07/15 15:56

Sponsor
 

Re: Ultimo valore del cerca vert

Postdi CANAPONE » 31/03/16 09:03

Ciao,

che versione di Excel hai a disposizione?
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Ultimo valore del cerca vert

Postdi CANAPONE » 31/03/16 09:06

Ciao di nuovo,

prova

=CERCA(7;1/(Foglio2.$A$1:$A$10=A1);Foglio2.$B$1:$B$10)

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Ultimo valore del cerca vert

Postdi CANAPONE » 31/03/16 09:43

Ciao,

visto ora che usi Open Office (credo)

la formual che hai condiviso andrebbe riconfermata come matriciale

=INDICE(Foglio2.$B$1:$B$10;MAX(SE(Foglio2.$A$1:$A$10=A1;RIF.RIGA(Foglio2.$A$1:$A$10))))

in un database tipo

a1 3
a1 7
a1 2

restituirebbe 2

Se ti interessa pescare il 7 ( o la data più recente ) credo tu possa semplificare la formula

=MAX(SE(Foglio2.$A$1:$A$10=A1;Foglio2.$b$1:$b$10))

Confermata come matrice
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Ultimo valore del cerca vert

Postdi Ubuntus » 31/03/16 15:40

Ho excel 7 aime
Ubuntus
Utente Junior
 
Post: 73
Iscritto il: 24/07/15 15:56

Re: Ultimo valore del cerca vert

Postdi CANAPONE » 01/04/16 05:53

Ciao,

hai riconfermato le formule con control+maiusc+invio? La formula che hai condiviso mi sembra declinata bene, ma richiede la forma matriciale.
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "Ultimo valore del cerca vert":


Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti