Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

problema funzione Confronta

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: problema funzione Confronta

Postdi Anthony47 » 07/04/16 10:52

Intanto non usare piu' 9,99999999999999E+307 nelle formule; ti basta scrivere 99 (in questo contesto) e fai respirare la tastiera...

Affinche' CONFRONTA possa restituire un valore conforme alle sue specifiche, se il parametro "corrisp" e' mancante o pari a 1 (come nella tua formula) allora la serie di dati deve essere disposta in ordine crescente. Nel tuo caso questo non avviene, quindi la formula e' usata in modo improprio e si applichera' la regola "Se CONFRONTA non riesce a trovare un valore corrispondente, restituirà il valore di errore #N/D", da cui derivano gli errori #N/D presenti in tutti i tuoi risultati.

C'e' una non dichiarata deviazione da questa specifica quando la serie e' di valori numerici; in questo caso CONFRONTA riesce a restituire la posizione dell'ultimo dato della serie che sia inferiore al valore cercato (o del primo dato che sia uguale al valore cercato). Ma i tuoi dati (in riga 9) sono testuali (perche' prodotti con la funzione CONCATENA e perche' includono anche ""), quindi questa deviazione non si applica e rimane il risultato di errore #N/D reso da Confronta e tutto il resto della formula.

A me pare che, tra le tante risposte date, questa formula dia il risultato corretto:
Codice: Seleziona tutto
=SCARTO(B9;0;MAX(SE(B9:AD9<>"";RIF.COLONNA(B9:AD9)-RIF.COLONNA(B9)-4;""));1;5)

A matrice da inserire contemporaneamente in tutte e 5 le celle dei risultati (vedi viewtopic.php?f=26&t=106663&p=624706#p624424)

Ciao a tutti
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Sponsor
 

Re: problema funzione Confronta

Postdi ricky53 » 07/04/16 11:57

Ciao,
prima leggi quanto ti ha scritto Anthony sull'utilizzo della funzione CONFRONTA. E' molto importante.
Adesso verifica la sua proposta.


Infine prova questa variante della mia precedente proposta.
Passi da fare:
A) copia la seguente formula in "B9"
Codice: Seleziona tutto
=SE(B5=""; "";CONCATENA(SE(STRINGA.ESTRAI(B5;1;1)="F";(SE(STRINGA.ESTRAI(B5;2;1)>STRINGA.ESTRAI(B5;4;1);3;SE(STRINGA.ESTRAI(B5;2;1)=STRINGA.ESTRAI(B5;4;1);1;0))); 0)))

B) trascina "B9" fino alla cella "AD9"
C) copia la seguente formula in "B16"
Codice: Seleziona tutto
=INDICE($B$9:$AD$9; CONTA.SE($B$9:$AD$9; ">""") - COLONNE(B9:$F9)  + 1)

D) trascina "B16" fino alla cella "F16"

Fai le prove ed aggiornaci
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: problema funzione Confronta

Postdi ricky53 » 07/04/16 12:22

Ciao,
ecco anche un file di esempio: sono partito dal tuo file ed ho fatto i passi che ti ho descritto nel mio precedente intervento.

Link al file di ESEMPIO
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: problema funzione Confronta

Postdi davide2574 » 08/04/16 08:35

Ciao a voi (Anthony e Rick53)

Allora per Anthony

ho provato ad inserire la formula ma mi sembra che non funziona perché restituisce tutti i risultati 3 oppure vuota. Forse avrò sbagliato. Se non ti spiace mettere un file magari capirò dove ho sbagliato ad inserire la formula.

Per Rick53

sembra funziona ma devo fare una prova in questo week end che avrò più libero.
Grazie a voi per la disponibilità.
Spero di riuscire a risolvere il problema con i vostri aiuti
davide2574
Utente Junior
 
Post: 46
Iscritto il: 15/11/15 16:42

Re: problema funzione Confronta

Postdi Anthony47 » 08/04/16 11:13

Secondo me tu metti la formula nella prima celle e poi la copi nelle celle adiacenti...
Invece la formula va messa una sola volta in tutte le celle:
-selezioni tutte e 5 le celle dove vuoi calcolare i risultati
-scrivi nella barra della formula la formula
Codice: Seleziona tutto
=SCARTO(B9;0;MAX(SE(B9:AD9<>"";RIF.COLONNA(B9:AD9)-RIF.COLONNA(B9)-4;""));1;5)
-premi Contr-Maiusc-Enter

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "problema funzione Confronta":

Problema Windows 10
Autore: asso1998
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 23 ospiti