Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Somma cerca vert con moltiplicazione

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Somma cerca vert con moltiplicazione

Postdi statam » 09/03/16 20:46

Ciao ragazzi,
mi sto aggrovellando con questa formula che non riesco a far riuscire:
In pratica vorrei che nella casella D3"se ci sono errori allora appare cella vuota, altrimenti fa la somma di due percentuali che trova attaverso il cerca.vert e le moltiplica con un'altra percentuale".

Per capire meglio ho messo il file di prova http://www.filedropper.com/sommacercavert.

Questa è la formula che ho utilizzato nella cella D3:
Codice: Seleziona tutto
=SE(VAL.ERRORE(SOMMA(CERCA.VERT(B3;Foglio2!$A$1:$B$4;2;0));CERCA.VERT(1102;Foglio2!$A$1:$B$4;2;0))*Foglio3!A2;"";SOMMA(CERCA.VERT(B3;Foglio2!$A$1:$B$4;2;0));CERCA.VERT(1102;Foglio2!$A$1:$B$4;2;0)*Foglio3!A2)


Vorrei che mi riportasse come risultato appunto la somma delle due percentuali desiderate con la moltiplicazione desiderata: ovvero (3%+5%)*40%=3.2%
L'errore che mi riporta è che "Sono stati immessi troppi argomenti per questa funzione... "
statam
Utente Junior
 
Post: 47
Iscritto il: 30/12/15 19:30

Sponsor
 

Re: Somma cerca vert con moltiplicazione

Postdi Anthony47 » 09/03/16 21:34

La sintassi generale della formula e':
Codice: Seleziona tutto
=Se(Val.Errore(LaFormula);"";LaFormula)

Se hai XL2007 o superiore la formula puo' essere semplificata.

Prima fai funzionare "LaFormula", solo quando il risultato e' Ok allora la inserisci nello schema "SE(val.Errore"

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Somma cerca vert con moltiplicazione":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti