Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Macro di Excel per cercare e assegnare un valore di un range

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Macro di Excel per cercare e assegnare un valore di un range

Postdi martem21 » 07/03/16 17:14

Buongiorno a tutti! :)

Devo assegnare ad una cella un valore preso da un range di possibili in base al valore di un'altra cella.

Es. Ho una lista di aziende e le loro sigle. In una cella, da una lista, scelgo il nome dell'azienda e in un'altra cella vorrei che, con una macro, comparisse la sigla dell'azienda corrispondente.

Essendo il range grande, evito di usare IF() e, non essendo serrato in Visual Basic, chiedo aiuto a voi :)

P.S. il top sarebbe se fosse possibile che l'elenco delle aziende e delle sigle si trovasse in un'altro sheet, sempre all'interno dello stesso workbook.

Grazie
martem21
Newbie
 
Post: 1
Iscritto il: 07/03/16 16:55

Sponsor
 

Re: Macro di Excel per cercare e assegnare un valore di un r

Postdi alfrimpa » 07/03/16 17:33

Ciao Martem21

Allega un file di esempio (con Filedropper o simili) e mostra il risultato che vuoi ottenere.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 841
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Macro di Excel per cercare e assegnare un valore di un r

Postdi wallace&gromit » 07/03/16 18:05

mmh, non capisco che influsso abbia la grandezza di un range per l'uso di una formula.
Inoltre da quello che scrivi sembrerebbe più adatta una formula cerca.vert() che una IF().
Quindi concordo con Alfredo: meglio se presenti un esempio.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Macro di Excel per cercare e assegnare un valore di un r

Postdi ricky53 » 08/03/16 11:45

Ciao,
come già scritto da W&G anch'io penso che l'utilizzo della funzione "CERCA.VERT" risolverebbe il tuo quesito.

COMMENTO: nell'esporre il tuo quesito avresti dovuto indicare in quale cella fai la scelta della aziende e in quale intervallo di dati hai la tabella di corrispondenza "Nome Azienda - Sigla Azienda"


Ci provo:
ipotizziamo che tu abbia
A) in "A2" la scelta del "Nome Azienda" (in questa cella avrai sicuramente una convalida i cui dati (sempre ipotizzando) sono in "AA2:AA100"
B) in AA2:AB100 la tabella "Nome Azienda - Sigla Azienda"

In "B2" scrivi la seguente formula
Codice: Seleziona tutto
=CERCA.VERT(A2; AA$2:AB$100; 2; 0)



Prova ... sono qUI
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "Macro di Excel per cercare e assegnare un valore di un range":


Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti