Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

estrarre testo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

estrarre testo

Postdi dome10 » 19/02/16 14:09

Sale ragazzi, ho un problema dovrei estrare testo da una cella, senza quello che ho tra le parentesi.
Faccio un esempio:
"Misr El Makasa (3) - Al Masry (4) ",
per quanto riguarda la prima parte uso questa formula" =SE(B3="";"";STRINGA.ESTRAI(C3;1;RICERCA("-";C3)-5)) "(cella B3 uso per controllo, C3 contiene il testo da estrarre)ed esce "Misr El Makasa"(quello che voglio).
la seconda parte(quella dopo il trattino) uso " =SE(B3="";"";DESTRA(C3;(LUNGHEZZA(C3)-(RICERCA("-";C3)+0)))) ",
ed esce " Al Masry (4)"non va, vorrei solo " Al Masry ".
Grazie
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04

Sponsor
 

Re: estrarre testo

Postdi wallace&gromit » 19/02/16 14:38

usando la stessa logica della prima soluzione puoi modificare la formula così:
Codice: Seleziona tutto
=SE(B3="";"";STRINGA.ESTRAI(C3;RICERCA("-";C3)+2;LUNGHEZZA(C3)-RICERCA("-";C3)-5))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1419
Iscritto il: 16/01/12 14:21

Re: estrarre testo

Postdi dome10 » 19/02/16 14:48

Grazie wallace&gromit, mi stavo incartando.
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04


Torna a Applicazioni Office Windows


Topic correlati a "estrarre testo":


Chi c’è in linea

Visitano il forum: Marius44, patel e 10 ospiti