Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Estrarre testo da una cella fino al carattere "."

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Estrarre testo da una cella fino al carattere "."

Postdi alexagosto62 » 31/01/16 08:43

Ciao. Ho l necessità di estrarre da una cella excel la prima parte del contenuto
fino al primo carattere "." escluso.
In pratica il testo è qualcosa di simile a "ABCD123456.italia.it".
Io devo estrarre "ABCD123456", tenendo conto che non conosco a priori la lunghezza nè della prima parte nè della seconda. L'unica cosa che conosco è che nella cella ci può essere uno o più di un carattere "."
Ringrazio chiunque mi riesca a dare un piccolo aiuto. Excel è in italiano ... Grazie
Alessandro
alexagosto62
Newbie
 
Post: 5
Iscritto il: 31/01/16 08:29

Sponsor
 

Re: Estrarre testo da una cella fino al carattere "."

Postdi alfrimpa » 31/01/16 12:46

Ciao Alessandro

Se il dato è in A1 credo che basti la formula che vedi sotto.

Codice: Seleziona tutto
=SINISTRA(A1;TROVA(".";A1)-1)
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Estrarre testo da una cella fino al carattere "."

Postdi alexagosto62 » 01/02/16 09:41

Ciao
Grazie, la formula funziona ma vi è un'eccezione ... Se per una qualsiasi ragione la cella contiene una stringa SENZA il carattere ricercato (il punto), il risultato è "#VALORE!".
Bisognerebbe trovare il modo di effettuare un controllo ...
Non so se è fattibile ...
Fammi sapere quando riesci .. Per il momento grazie davvero ..
Alessandro
alexagosto62
Newbie
 
Post: 5
Iscritto il: 31/01/16 08:29

Re: Estrarre testo da una cella fino al carattere "."

Postdi alfrimpa » 01/02/16 11:03

Allora Alessandro usa questa formula che, se nella cella non c'è il punto, non restituirà nulla.

Non so se è questo che vuoi.

Codice: Seleziona tutto
=SE.ERRORE(SINISTRA(A1;TROVA(".";A1)-1);"")


Se invece di nulla vuoi che restituisca un messaggio modificala così:

Codice: Seleziona tutto
=SE.ERRORE(SINISTRA(A1;TROVA(".";A1)-1);"messaggio")


dove al posto di messaggio puoi mettere quello che vuoi.

Spero di essere stato chiaro.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Estrarre testo da una cella fino al carattere "."

Postdi alexagosto62 » 01/02/16 12:01

Grazie ... non conoscevo l'uso della funzione se.errore ...
Funziona.
Ho modificato la ricerca con la seguente:

Codice: Seleziona tutto
=SE.ERRORE(SINISTRA(C2;TROVA(".";C2)-1);C2)

In tal modo e non c'è il punto mi restituisce quanto c'è nella cella ... Che è quello che mi serve.
Perfetto.
Il potere di Excel.
Grazie ancora e a presto

Alessandro
alexagosto62
Newbie
 
Post: 5
Iscritto il: 31/01/16 08:29


Torna a Applicazioni Office Windows


Topic correlati a "Estrarre testo da una cella fino al carattere "."":


Chi c’è in linea

Visitano il forum: Nessuno e 27 ospiti