Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - Somma SE cella contiene un'altra cella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel - Somma SE cella contiene un'altra cella

Postdi Luigi1984 » 17/09/15 15:58

Salve a tutti. Ho un quesito da porre.
Ho una prima tabella excel in cui ad ogni stringa di testo corrisponde un numero (le stringhe di testo sono date da un insieme di identificativi; es: TM001-TM002- ecc.). In una seconda tabella ho una prima colonna in cui sono riportati separatamente questi identificativi. Ho necessità che per, ciascuno di questi identificativi, excel calcoli la somma dei numeri contenuti nella prima tabella cercando ciascun identificativo nelle stringhe di testo della prima tabella. Credo che la funzione da utilizzare sia SOMMA.SE ma non so come impostare il campo "criterio".
Vi ringrazio in anticipo per le risposte
Luigi1984
Newbie
 
Post: 1
Iscritto il: 17/09/15 15:28

Sponsor
 

Re: Excel - Somma SE cella contiene un'altra cella

Postdi wallace&gromit » 17/09/15 16:38

Ciao Luigi e benvenuto nel forum,
per capire cosa ti serve penso sia necessario avere un esempio realistico di dati.
Office2016 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2045
Iscritto il: 16/01/12 14:21

Re: Excel - Somma SE cella contiene un'altra cella

Postdi Anthony47 » 18/09/15 00:14

Senza conoscere il layout dei dati posso solo farti un esempio:
Codice: Seleziona tutto
=SOMMA.SE(Foglio2!$A$1:$A$100;"*"&A2&"*";Foglio2!$B$1:$B$100)
Foglio2!$A$1:$A$100 sono le stringhe della prima tabella; Foglio2!$B$1:$B$100 sono i suoi numeri; A2 e' uno degli identificativi.

Se non risolvi con questo spunto allora pubblica un esempio realistico di dati; per allegare un file o una immagine guarda qui: viewtopic.php?f=26&t=103893

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17446
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel - Somma SE cella contiene un'altra cella":


Chi c’è in linea

Visitano il forum: Nessuno e 37 ospiti