Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL Calcolo valore netto

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

EXCEL Calcolo valore netto

Postdi Bella89 » 16/09/15 13:57

Ciao ho un quesito da risolvere, spero di riuscire a spiegarmi.
Ho 3 colonne dove andrò ad inserire degli importi per fatturare,voglio utilizzare la formula SE perché ogni colonna ha un importo diverso, partono tutti da 0,00 (M9=0, O9=0, Q9=0), io inserisco l'importo in una di queste celle che se è M9 ,sulla colonna del totale (H9) deve dividere M9/1.06; SE è O9 ,sempre sulla colonna del totale(H9) deve dividere O9/1.1; e se è Q9 ,sempre sulla colonna del totale (H9) deve dividere Q9/1.22.
La formula che ho inserito io è la seguente:
=SE(M9=0;O9/1,1;M9/1,06)+SE(M9=0;SE(O9=0;Q9/1,22))ovvero:
se M9 uguale 0, O9 diviso 1.1 altrimenti M9 diviso 1.06 -- e se M9 uguale a 0, e O9 uguale a 0, Q9 diviso 1.22.
Così facendo ottengo quello che mi serve, ora però a me servirebbe integrare una cosa all'interno della formula ma non riesco a farlo,cioè solo se uno dei tre valori e diverso da zero e tutti gli altri sono uguali a zero deve effettuare la divisione, ma se due valori sono diversi da zero anziché uno soltanto, vorrei che uscisse la scritta "errore" perché così facendo io azzero quello sbagliato e automaticamente in base a quale dei tre e diverso da zero mi effettua la divisione. :oops: :oops: :oops: :undecided:
Bella89
Newbie
 
Post: 3
Iscritto il: 16/09/15 13:41

Sponsor
 

Re: EXCEL Calcolo valore netto

Postdi wallace&gromit » 16/09/15 14:19

ciao Bella,
benvenuta nel forum,

Allora, come prima cosa ti serve sapere se c'è un solo valore diverso da 0, questo lo puoi fare con questa formula:
Codice: Seleziona tutto
=SE(SOMMA(--(M9=0);--(O9=0);--(Q9=0))=2;...resto della formula...;"errore")

nel resto della formula puoi ora semplificare rispetto a prima, perché sai già che l'unico valore non nullo è quello che ti interessa, quindi fai M9/1.06+O9/1.1+Q9/1.22, la formula finale diventa:
Codice: Seleziona tutto
=SE(SOMMA(--(M9=0);--(O9=0);--(Q9=0))=2;M9/1.06+O9/1.1+Q9/1.22;"errore")
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: EXCEL Calcolo valore netto

Postdi scossa » 16/09/15 18:04

wallace&gromit ha scritto:la formula finale diventa:
Codice: Seleziona tutto
=SE(SOMMA(--(M9=0);--(O9=0);--(Q9=0))=2;M9/1.06+O9/1.1+Q9/1.22;"errore")


Una variante semplificata:
Codice: Seleziona tutto
=SE((M9=0)+(O9=0)+(Q9=0)=2;M9/1,06+O9/1,1+Q9/1,22;"errore")
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: EXCEL Calcolo valore netto

Postdi Bella89 » 18/09/15 09:43

grazie infinite sei un genio .... avevo bisogno di questa mano. Una curiosità nella formula che serve a sapere se il valore è diverso da zero hai riportato questa dicitura =SE(SOMMA(--(M9=0);--(O9=0);--(Q9=0))=2 il valore =2 cosa significa?
grazie ancora
Bella89
Newbie
 
Post: 3
Iscritto il: 16/09/15 13:41

Re: EXCEL Calcolo valore netto

Postdi wallace&gromit » 18/09/15 09:46

hai visto la versione semplificata di scossa?
si può tralasciare la funzione somma().
ogni volta che scrivi per esempio (M9=0) excel converte in 1 se è vero e in 0 se è falso, 2 significa che ha trovato 2 volte dei valori nulli.

P.S. mi ci è voluto un po' di tempo di frequentazione del forum prima di imparare a usare questa potenzialità di excel e come vedi scossa me l'ha ancora migliorata!
Ultima modifica di wallace&gromit su 18/09/15 09:50, modificato 1 volte in totale.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: EXCEL Calcolo valore netto

Postdi Bella89 » 18/09/15 09:48

ok ok grazie è perfettamente chiaro!!
Bella89
Newbie
 
Post: 3
Iscritto il: 16/09/15 13:41


Torna a Applicazioni Office Windows


Topic correlati a "EXCEL Calcolo valore netto":


Chi c’è in linea

Visitano il forum: Nessuno e 22 ospiti