Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL: Funzione SE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

EXCEL: Funzione SE

Postdi damage » 09/09/15 17:20

Ciao ragazzi,
avrei bisogno di un piccolo aiuto

Devo applicare la funzione SE a delle celle in questo modo:

Se nel testo della cella A1 c'è la parola PIPPO sulla cella A2 scrivi ABC
Se nel testo della cella A1 c'è la parola PLUTO sulla cella A2 scrivi DEF
Se nel testo della cella A1 c'è la parola PAPERINO sulla cella A2 scrivi GHI
Se nel testo della cella A1 non è contenuta nessuna delle precedenti parole nella cella A2 non scrivere nulla

Specifico che nella cella A1 ci può essere anche dell'altro testo (tipo una frase), ma non ci saranno mai contemporaneamente le parole PIPPO, PLUTO e PAPERINO, solamente una di queste alla volta (o nessuna)

Grazie in anticipo
damage
Utente Junior
 
Post: 14
Iscritto il: 05/02/15 12:02

Sponsor
 

Re: EXCEL: Funzione SE

Postdi alfrimpa » 09/09/15 18:24

Ciao damage

Prova con questa formula

Codice: Seleziona tutto
=SE(A1="PIPPO";"ABC";SE(A1="PLUTO";"DEF";SE(A1="PAPERINO";"GHI";SE(A1="";""))))


Se in A1 c'è dell'altro la formula restituisce "FALSO"
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 842
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: EXCEL: Funzione SE

Postdi wallace&gromit » 09/09/15 21:05

Ciao a tutti
@Alfredo: non penso che la tua soluzione soddisfi damage, perché considera solo celle che contengono esclusivamente il testo cercato.
Proverei piuttosto con questa:
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA("PIPPO";A1));"";"ABC")&SE(VAL.ERRORE(TROVA("PLUTO";A1));"";"DEF")&SE(VAL.ERRORE(TROVA("PAPERINO";A1));"";"GHI")

Nota 1: la funzione distingue le maiuscole dalle minuscole, quindi "pippo" non sarebbe riconosciuto
Nota 2: se il testo dovesse essere "SUPERPIPPO OSSERVA PLUTONE A PAPERINOPOLI" uscirebbe come risultato "ABCDEFGHI"


(lo so che la città si chiama Paperopoli, ma era per fare un esempio!)
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: EXCEL: Funzione SE

Postdi damage » 10/09/15 08:18

Ciao alfrimpa e wallace&gromit,
confermo, la formula di alfrimpa funziona se la cella contiene solo la parola cercata, quella di wallace&gromit funziona anche se la cella contiene altro testo.

Per il mio caso penso che la più adatta sia quella di wallace&gromit

Vi ringrazio entrambi per il supporto ;)
damage
Utente Junior
 
Post: 14
Iscritto il: 05/02/15 12:02


Torna a Applicazioni Office Windows


Topic correlati a "EXCEL: Funzione SE":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti