Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Invio E-Mail da Excel a destinatari in "Scadenza"

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Invio E-Mail da Excel a destinatari in "Scadenza"

Postdi Valerio93 » 07/09/15 09:31

Salve a tutti, sono nuovo del Forum e spero di non infrangere qualche parte del regolamento, non sono molto pratico di VBA, pertanto avrei bisogno del vostro aiuto nella creazione di una Macro che invii da un Foglio Excel attivo delle E-mail , soltanto ai destinatari (nell'intervallo di celle da B5 a B100) che hanno sulla stessa riga, nell'intervallo di celle da I5 a I100, la voce "Scaduto", generata in automatico da tale funzione:
Codice: Seleziona tutto
=SE(O(G5<$K$5;H5<$K$5);"Scaduto";"Valido")


Il foglio è così composto:
Colonna A: Nomi dei Fornitori
Colonna B: Indirizzi
Colonna C: Testo (non rilevante)
Colonna E ed F: Date di emissione
Colonna G e H: Date di scadenza (quelle di nostro interesse)
Colonna I: Variabile di testo "Scaduto" o "Valido" (di nostro interesse)
La cella H5 contiene la data di "Oggi" per il calcolo delle scadenze.
La cella K14 contiene il Testo che vorrei inserire nella E-mail, uguale per tutti.

L'invio non deve essere automatico, mi va benissimo anche integrare un pulsante che esegua la Macro, l'importante è che le E-mail vengano inviate solo agli indirizzi che sono effettivamente in scadenza.

Grazie in anticipo a tutti ragazzi!
Valerio93
Newbie
 
Post: 6
Iscritto il: 07/09/15 09:16

Sponsor
 

Re: Invio E-Mail da Excel a destinatari in "Scadenza"

Postdi alfrimpa » 07/09/15 09:45

Ciao Valerio

Potresti allegare un file di esempio con Filedropper o Dropbox (senza dati sensibili) con pochi record?

Ho già una macro per l'invio di mail e penso di poterla adattare al tuo caso.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Invio E-Mail da Excel a destinatari in "Scadenza"

Postdi Valerio93 » 07/09/15 10:43

Ciao Alfredo,

Intanto grazie per la risposta,
Purtroppo da pc aziendale non posso accedere a quelle piattaforme, però, se mi da il suo indirizzo, le giro il file excel per email.
Valerio93
Newbie
 
Post: 6
Iscritto il: 07/09/15 09:16

Re: Invio E-Mail da Excel a destinatari in "Scadenza"

Postdi alfrimpa » 07/09/15 10:56

Ti ho risposto in mp
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Invio E-Mail da Excel a destinatari in "Scadenza"

Postdi alfrimpa » 07/09/15 13:07

Ciao Valerio

Ti allego il tuo file con la sottostante macro che invia mail agli scaduti;

Ho modificato la tua formula così:

Codice: Seleziona tutto
=SE(A5="";"";SE(O(G5<$K$5;H5<$K$5);"Scaduto";"Valido"))


In modo che se la cella A5 (nome ditta) anche I5 sia vuota (mi serviva ai fini della macro).

Nella cella K14 puoi inserire un testo che verrà incluso nel corpo della mail

Attualmente la macro non invia le mail ma le visualizza soltanto; per inviarle devi sostituire nel codice .Display con .Send (sai farlo?)

http://www.filedropper.com/valerio93_1

Codice: Seleziona tutto
Sub SendEmail()
  Dim OutlookApp As Object
  Dim MItem As Object
  Dim EmailAddr As String
  Dim Msg As String
  Set OutlookApp = CreateObject("Outlook.Application")
  Dim miorange As Range
  Dim cella As Range
  Set miorange = Range("I5:I100")
For Each cella In miorange
    If cella.Value = "Scaduto" Then
      EmailAddr = cella.Offset(0, -7).Value
        Msg = Range("K14").Value
      Set MItem = OutlookApp.CreateItem(0) 'olMailItem
      With MItem
        .To = EmailAddr
        .Body = Msg
        .Display   '<=== Per inviare la mail sostituire .Display con .Send
      End With
    End If
Next cella
  Set OutlookApp = Nothing
End Sub
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Invio E-Mail da Excel a destinatari in "Scadenza"

Postdi Valerio93 » 07/09/15 13:25

E' perfetta!

Ho inserito soltato il destinatario fisso in CC e l'oggetto dell'e-mail.
Va alla grande!

Grazie Alfredo.
Valerio93
Newbie
 
Post: 6
Iscritto il: 07/09/15 09:16


Torna a Applicazioni Office Windows


Topic correlati a "Invio E-Mail da Excel a destinatari in "Scadenza"":


Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti