Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Aiuto excel per somma con spunta

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Aiuto excel per somma con spunta

Postdi simon01 » 05/08/15 10:17

Buongiorno a tutti, è il mio primo topic.

Sto creando una semplice tabella formata da colonne; codici, fornitori e costi;
Vorrei poter inserire in ogni riga "un simbolo spunta" in modo che se disattivato faccia diventare la riga grigia ed escluda la colonna dei costi ai fini della somma totale.
Premetto che non sono pratico di macro
Ringrazio in anticipo per l'aiuto
simon01
Newbie
 
Post: 3
Iscritto il: 05/08/15 10:06

Sponsor
 

Re: Aiuto excel per somma con spunta

Postdi simon01 » 05/08/15 11:03

Se fosse più semplice, mi andrebbe bene in alternativa inserire una colonna dove mettere una "x" al posto del simbolo spunta per escludere la cella della riga dalla somma. Grazie
simon01
Newbie
 
Post: 3
Iscritto il: 05/08/15 10:06

Re: Aiuto excel per somma con spunta

Postdi alfrimpa » 05/08/15 11:16

Ciao Simon

Prova a guardare il file allegato

http://www.filedropper.com/simon

Ovviamente è solo una bozza assolutamente da migliorare; giusto per incominciare a ragionare

Inserisci le X in colonna C
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Aiuto excel per somma con spunta

Postdi simon01 » 05/08/15 12:39

Intanto ti ringrazio la soluzione è circa quello che stavo cercando. Però una vota tolta la X però avrei bisogno che la somma si riattivasse
simon01
Newbie
 
Post: 3
Iscritto il: 05/08/15 10:06

Re: Aiuto excel per somma con spunta

Postdi wallace&gromit » 05/08/15 13:10

propongo un approccio diverso:
il colore delle celle lo farei con un formato condizionale, ogni riga si colora se in colonna C ha una x.
Il calcolo lo farei con questa formula:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(B:B;--(C:C<>""))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: Aiuto excel per somma con spunta

Postdi alfrimpa » 05/08/15 13:41

Ciao Simon

Ho modificato il codice che ti propongo

Codice: Seleziona tutto
Private Sub Worksheet_Change(ByVal Target As Range)
Application.EnableEvents = False
If Not Intersect(Target, Range("C1:c6")) Is Nothing Then     <---- Ovviamente modifica il range con il tuo
    If Target.Value = "" Then
        Range("A" & Target.Row & ":" & "B" & Target.Row).Interior.ColorIndex = xlNone
    Else
        Range("A" & Target.Row & ":" & "B" & Target.Row).Interior.ColorIndex = 6
    End If
    Worksheets(1).Calculate
End If
Application.EnableEvents = True
End Sub



In questo modo se cancelli la X in colonna C viene tolto il colore alle celle e ripristinato il totale.

Ti riallego il file

http://www.filedropper.com/simon1

Riesci ad implementare quanto suggerito sul tuo file reale?

Se no, allegane uno di esempio con dati fittizi e cercheremo di farlo.

@ Wallace

Poiché di f.c. non so quasi nulla potresti, gentilmente, spiegarmi come applicare la tua soluzione?

Grazie
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Aiuto excel per somma con spunta

Postdi alfrimpa » 05/08/15 13:51

Ciao Wallace

Ho provato ad usare la tua soluzione

1) Ho selezionato la zona A1:B6
2) Attivato la formattazione condizionale
3) Scelto Utilizza una formula per individuare le celle da formattare
4) nel riquadro ho incollato la tua formula
5) ho scelto lo sfondo ed ho dato Ok.

ma:

1) il file diventa lentissimo
2) si colora l'intera colonna A e non la singola riga
3) la formula del totale non si aggiorna.

Sicuramente sbaglio io: mi puoi dire dove?

Grazie
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Aiuto excel per somma con spunta

Postdi wallace&gromit » 05/08/15 14:07

prima di tutto correggo un refuso: la mia formula calcolava l'esatto contrario: cioè le celle con la x.
Quella giusta è:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(B:B;--(C:C=""))

Forse la combinazione con la tua macro rende le cose difficili, oppure il sistema di definire tutta la colonna rende la formula pesante, prova con:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(B2:B10000;--(C2:C10000=""))
con il formato condizionale ho ancora qualche problema, vedo di risolvere e aggiornarvi.

EDIT: attenzione: questa formula non va nel formato condizionale ma nella cella che calcola il totale
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: Aiuto excel per somma con spunta

Postdi alfrimpa » 05/08/15 14:16

Mah non riesco a capire.

A me non funziona per nulla e ci sono gli stessi problemi di prima ed ho anche provato su un file vuoto senza macro.

Puoi allegare anche tu un file di esempio così imparo qualcosa di nuovo? :)

Grazie
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Aiuto excel per somma con spunta

Postdi wallace&gromit » 05/08/15 14:29

eccomi qua, qui c'è un file d'esempio:
http://www.filedropper.com/simon2

in E2 ho la formula che ho dato prima e che mi calcola la somma dei valori in B che non hanno una x a fianco.
il formato condizionale delle celle A2:C2 ha questa formula:
Codice: Seleziona tutto
=$C2<>""
e come sfondo impostato grigio.
Le celle si colorano solo se in C2 c'è del testo.
Nelle righe successive ho fatto copia/incolla speciale formattazione, per avere lo stesso effetto.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: Aiuto excel per somma con spunta

Postdi alfrimpa » 05/08/15 14:45

Grazie Wallace.

Purtroppo tra me e le formule non corre buon sangue e spesso preferisco affidarmi al VBA.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Aiuto excel per somma con spunta

Postdi wallace&gromit » 05/08/15 14:55

eh, per me è l'opposto, ho ancora un certo timore reverenziale verso il VBA.
Comunque è un po' che non sentiamo Simon, per sapere a che punto è lui!
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: Aiuto excel per somma con spunta

Postdi alfrimpa » 05/08/15 15:00

E invece dovresti approfondire.

Con la tua esperienza sicuramente potrai avere grandi soddisfazioni.

Per quanto riguarda Simon credo che la tua proposta sia quella che preferirà perchè la mia è un po' ostica (ma niente di particolare) da capire.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Aiuto excel per somma con spunta

Postdi bismark » 05/08/15 15:23

ciao Alfredo

hai anticipato un ragionamento che volevo fare quello di mettere e togliere le X e conseguentemente evidenziare o no le righe di riferimento A e B

c'è però un piccolo problema.... se inserisci uno spazio in colonna C evidenzia ugualmente le righe forse bisogna vincolare il tutto l'inserimento della X....

non sono un'esperto di VBA sto cercando di capirci qualcosa scusami..........
bismark
Utente Junior
 
Post: 54
Iscritto il: 08/07/15 15:03

Re: Aiuto excel per somma con spunta

Postdi bismark » 05/08/15 15:27

non so se "informaticamente" corretto

Codice: Seleziona tutto
Option Explicit
Private Sub Worksheet_Change(ByVal Target As Range)
Application.EnableEvents = False
If Not Intersect(Target, Range("C1:c6")) Is Nothing Then
    If Target.Value = "x" Then
        Range("A" & Target.Row & ":" & "B" & Target.Row).Interior.ColorIndex = 6
    Else
        Range("A" & Target.Row & ":" & "B" & Target.Row).Interior.ColorIndex = xlNone
    End If
    Worksheets(1).Calculate
End If
Application.EnableEvents = True
End Sub



ho inserito value X e invertito il colorindex

dovrebbe funzionare .......

:oops: :oops:
bismark
Utente Junior
 
Post: 54
Iscritto il: 08/07/15 15:03

Re: Aiuto excel per somma con spunta

Postdi alfrimpa » 05/08/15 15:29

Osservazioni giustissime Bismark.

Il mio era solo un primo e grezzo tentativo per dimostrare la fattibilità della cosa (ed ho usato lo strumento a me più congeniale cioè il VBA)

Il tutto andrebbe testato e migliorato sul caso concreto e questo solo Simon ce lo può dire.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Aiuto excel per somma con spunta

Postdi alfrimpa » 05/08/15 15:32

Direi che ad occhio mi sembra corretto.

Oppure si potrebbe inserire una Convalida Dati in colonna C in modo da far accettare solo la "x".

Come vedi le strade (come sempre in Excel) possono essere diverse.

P.S. Non vedo di cosa dovresti scusarti: a questo mondo nessuno nasce imparato (tranne il sottoscritto visto che questo è il mio cognome :) )
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli


Torna a Applicazioni Office Windows


Topic correlati a "Aiuto excel per somma con spunta":


Chi c’è in linea

Visitano il forum: raimea, wallace&gromit e 10 ospiti