Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel 2007: condizione se su gruppi con funzione max

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel 2007: condizione se su gruppi con funzione max

Postdi karug64 » 04/08/15 22:06

Salve a tutti e buone ferie a tutto il forum.
Ho un problema che non riesco a risolvere:

K8:K12 = formattato a % vengono calcolati in automatico
M8:M12 = "descrizioni fisse" (M8="A";M9="B";M10="C";M11="D";M12="E")

In R7 devo ottenere questo risultato:

Se la somma delle prime tre celle di K (K8:K10) è maggiore della somma delle altre due (K11:K12) allora in R7 metto il valore della colonna M corrispondente al maggiore dei tre

altrimenti

se la somma delle prime tre celle di K (K8:K10) è minore delle altre due (K11:K12) allora in R7 metto il valore della colonna M corrispondente al maggiore dei due (M11:M12)


esempio:
K8:12%
K9:15%
K10:30%
K11:23%
K12:20%

in R7 metto "C" perchè 12+15+30(57) > 23+20(43) e 30 è il maggiore tra i tre (12/15/30)

Spero di essermi spiegato.
Grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: excel 2007: condizione se su gruppi con funzione max

Postdi Flash30005 » 05/08/15 01:07

Con questa formula dovresti risolvere
Codice: Seleziona tutto
=SE(SOMMA(K8:K10)>SOMMA(K11:K12);MAX(K8:K10);MAX(K11:K12))


ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel 2007: condizione se su gruppi con funzione max

Postdi Anthony47 » 05/08/15 01:52

In alternativa alla formula di Flash (vedi sopra):
Codice: Seleziona tutto
=SE(SOMMA(K8:K10)>SOMMA(K11:K12);CERCA.VERT(MAX(K8:K10);K8:M12;3;0);CERCA.VERT(MAX(K11:K12);K8:M12;3;0))

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel 2007: condizione se su gruppi con funzione max

Postdi karug64 » 05/08/15 07:55

La soluzione di flash mi riporta la percentuale maggiore e non il valore corrispondente ....
La soluzione di Anthony mi riporta VERO o FALSO e non il valore corrispondente di colonna M ....

Grazie ancora
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Re: excel 2007: condizione se su gruppi con funzione max

Postdi wallace&gromit » 05/08/15 09:10

ho provato la formula di Anthony e funziona, forse hai sbagliato qualcosa nella trascrizione, oppure c'è qualcosa d'altro nei tuoi dati che non hai esposto correttamente.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: excel 2007: condizione se su gruppi con funzione max

Postdi karug64 » 05/08/15 20:56

wallace&gromit ha scritto:ho provato la formula di Anthony e funziona, forse hai sbagliato qualcosa nella trascrizione, oppure c'è qualcosa d'altro nei tuoi dati che non hai esposto correttamente.


Strano.
Ho copiato ed incollato la formula di Anthony (col tasto copia) ed avevo il problema esposto.
Poi l'ho riscritta da zero nella cella e funziona ....
Mah.

Comunque grazie
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Re: excel 2007: condizione se su gruppi con funzione max

Postdi Flash30005 » 07/08/15 00:38

karug64 ha scritto:La soluzione di flash mi riporta la percentuale maggiore e non il valore corrispondente ....


Beh ho interpretato male quello che hai scritto nel post precedente?

karug64 ha scritto:Se la somma delle prime tre celle di K (K8:K10) è maggiore della somma delle altre due (K11:K12) allora in R7 metto il valore della colonna M corrispondente al maggiore dei tre

karug64 ha scritto:altrimenti
se la somma delle prime tre celle di K (K8:K10) è minore delle altre due (K11:K12) allora in R7 metto il valore della colonna M corrispondente al maggiore dei due (M11:M12)


Quindi non volevi la percentuale maggiore tra i tre valori o la maggiore tra i due (rispettando la condizione precedente)?
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel 2007: condizione se su gruppi con funzione max

Postdi Anthony47 » 07/08/15 01:26

Ciao Flash; i valori percentuali confrontati sono in colonna K, il dato richiesto e' quello di colonna M...
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "excel 2007: condizione se su gruppi con funzione max":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti