Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel 2013] Filtro date

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel 2013] Filtro date

Postdi damage » 04/08/15 14:13

Ciao ragazzi,
mi serve aiuto per filtrare dei dati
Ho 2 colonne: sulla prima ci sono le date, sulla seconda dei numeri (che rappresentano la quotazione di un indice di borsa in quel determinato giorno)
Ora praticamente vedo tutte le quotazioni giornaliere (a parte i giorni in cui la borsa è chiusa e manca proprio la riga)
Vorrei mettere un filtro sulla colonna con le date in modo da vedere solo le quotazioni del primo giorno di quotazione di ogni mese.
Per certi mesi il primo giorno di quotazione può essere l' 1, per altri mesi il 2, per altri ancora il 3 o forse anche il 4 perchè nei giorni in cui la borsa è chiusa non c'è la riga con la quotazione
Spero di essermi spiegato :D
Grazie in anticipo
damage
Utente Junior
 
Post: 14
Iscritto il: 05/02/15 12:02

Sponsor
 

Re: [Excel 2013] Filtro date

Postdi wallace&gromit » 04/08/15 15:00

se le date sono rigorosamente in ordine ascendente
e se non ci fossero le righe vuote
e infine se c'è la possibilità di creare una colonna d'appoggio
si potrebbe pensare ad una semplicissima formula nella colonna C:
Codice: Seleziona tutto
=SE(MESE(A3)=MESE(A2);"";"ok")
poi si filtra per i valori "ok"
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: [Excel 2013] Filtro date

Postdi wallace&gromit » 04/08/15 15:15

Questa formula matriciale dovrebbe togliere un po' di condizioni che avevo messo sopra:
Da inserire in C2, confermare con Ctrl+Shift+Enter (non solo enter) e trascinare in basso
Codice: Seleziona tutto
=SE(A2<>"";SE(A2=MIN(SE(ANNO(A$2:A$12)=ANNO(A2);SE(MESE(A$2:A$12)=MESE(A2);A$2:A$12)));"ok";"");"")
rimane la necessità di una colonna d'appoggio
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: [Excel 2013] Filtro date

Postdi damage » 04/08/15 16:37

Innanzitutto grazie per la risposta

Ho provato entrambe le formule
La prima sembra funzionare, l'unico problema è che mette l'ok su l'ultimo giorno di ogni mese, mentre a me servirebbe che lo mettesse sul primo giorno di ogni mese
La seconda formula invece mi mette l'ok solamente sulla prima data (riga 2) e sul primo giorno del mese successivo, poi più nulla
damage
Utente Junior
 
Post: 14
Iscritto il: 05/02/15 12:02

Re: [Excel 2013] Filtro date

Postdi Sbarba » 04/08/15 17:04

Mi permetto di dare un piccolo aiuto, anche se la domanda non era rivolta a me.

Modificando la prima formula da
=SE(MESE(A3)=MESE(A2);"";"ok")
a
=SE(MESE(A3)=MESE(A4);"";"ok") , mettendola nella riga 4

"ok" viene restituito vicino al primo giorno del mese e non all'ultimo
Sbarba
Utente Junior
 
Post: 36
Iscritto il: 07/10/14 15:56

Re: [Excel 2013] Filtro date

Postdi damage » 04/08/15 17:14

Perfetto Sbarba, funziona ! :)

Grazie mille ad entrambi per l'aiuto
damage
Utente Junior
 
Post: 14
Iscritto il: 05/02/15 12:02

Re: [Excel 2013] Filtro date

Postdi wallace&gromit » 05/08/15 07:44

:mmmh: devo dedurre che le tue date sono inserite dalla più recente alla più antica.
Però il difetto della seconda formula è solo che devi adattare il range (io ho fatto una prova fino alla riga 12).
Se non hai conflitti con altri dati inseriti nelle stesse colonne puoi provare anche con:
Codice: Seleziona tutto
=SE(A2<>"";SE(A2=MIN(SE(ANNO(A:A)=ANNO(A2);SE(MESE(A:A)=MESE(A2);A:A)));"ok";"");"")
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: [Excel 2013] Filtro date

Postdi damage » 05/08/15 13:56

wallace&gromit ha scritto::mmmh: devo dedurre che le tue date sono inserite dalla più recente alla più antica.
Però il difetto della seconda formula è solo che devi adattare il range (io ho fatto una prova fino alla riga 12).
Se non hai conflitti con altri dati inseriti nelle stesse colonne puoi provare anche con:
Codice: Seleziona tutto
=SE(A2<>"";SE(A2=MIN(SE(ANNO(A:A)=ANNO(A2);SE(MESE(A:A)=MESE(A2);A:A)));"ok";"");"")


Scusami non sono molto pratico, ora ho capito
Ho ordinato dalla data più recente alla meno recente e ho adattato il range.
Confermo che funziona tutto correttamente :)
Grazie!
damage
Utente Junior
 
Post: 14
Iscritto il: 05/02/15 12:02

Re: [Excel 2013] Filtro date

Postdi wallace&gromit » 05/08/15 14:10

con la seconda formula l'ordine delle date non è più rilevante.
Lì era solo un problema di range.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: [Excel 2013] Filtro date

Postdi damage » 21/02/16 18:38

Ciao a tutti,
riapro questo vecchio topic.
In precedenza avevo la necessità di "filtrare" il primo giorno di ogni mese, ora invece voglio filtrare il giorno 15 di ogni mese
Il problema è che mancano le date dei giorni festivi, perciò se in un mese non c'è il giorno 15 dovrà farmi vedere il giorno 16 (e se non c'è nemmeno il 16 dovrà prendere il 17 o addirittura il 18 se fosse necessario).
Ho la possibilità di aggiungere colonne di appoggio se serve
Secondo voi è fattibile ?
Grazie mille
damage
Utente Junior
 
Post: 14
Iscritto il: 05/02/15 12:02

Re: [Excel 2013] Filtro date

Postdi Anthony47 » 22/02/16 00:03

Se le date sono in colonna A in ordine crescente allora puoi mettere in B2 la formula
Codice: Seleziona tutto
=SE(E(GIORNO(A2)>=15;SOMMA($B$1:B1)=0);1;0)
da copiare poi verso il basso.
Se le date sono invece decrescenti, prova con
Codice: Seleziona tutto
=SE(E(GIORNO(A2)>=15;GIORNO(A3)<15);1;0)

In abedue i casi dovrai filtrare per valore 1.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel 2013] Filtro date

Postdi damage » 22/02/16 10:11

Le date sono in ordine crescente, quindi ho usato la prima formula
Ho provato ad applicarla e mi metteva il valore 1 sul giorno 15 solo del primo mese (sulla colonna A non ci sono le date di un solo mese ma di diversi anni, forse non avevo specificato)
Ho provato a sostituire questa parte della formula con la cella B1 bloccata
SOMMA($B$1:B1)=0
in
SOMMA(B1:B12)=0
sembra che questo range fortunatamente funzioni su tutti i mesi

Ti ringrazio
Ciao
damage
Utente Junior
 
Post: 14
Iscritto il: 05/02/15 12:02

Re: [Excel 2013] Filtro date

Postdi wallace&gromit » 22/02/16 14:03

Se con i tuoi dati hai risolto con la formula di Anthony, va bene così.
Se invece avessi bisogno di una formula più completa, che non dipende dall'ordinamento del tuo elenco, ti propongo l'estensione della formula precedente (sempre matriciale):
Codice: Seleziona tutto
=SE(A1<>"";SE(A1=MIN(SE(ANNO(A:A)=ANNO(A1);SE(MESE(A:A)=MESE(A1);SE(GIORNO(A:A)>14;A:A))));"ok";"");"")
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: [Excel 2013] Filtro date

Postdi damage » 22/02/16 18:35

Potrebbe tornarmi utile

Grazie!
damage
Utente Junior
 
Post: 14
Iscritto il: 05/02/15 12:02


Torna a Applicazioni Office Windows


Topic correlati a "[Excel 2013] Filtro date":


Chi c’è in linea

Visitano il forum: Marius44 e 5 ospiti