Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Media Excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Media Excel

Postdi elisa1987 » 14/07/15 14:14

Ragazzi ho un problema! ho creato un file che calcola le medie in base al singolo venditore. La funzione è MEDIA.SE($D$4:$D$614;BR4;$J$4:$J$614) ovvero il valore della colonna D (totale vendite) suddiviso in base ai venditori presenti nelle colonne J). Ora vorrei che la suddetta media (che funziona) escludesse dal computo i valori pari a "0". Ho pensato alla funzione MEDIA.SE(A2:A7; "<>0"). Come faccio a integrarla nella media precedente? Grazie,scusate,non sono ferratissima di Excel...
elisa1987
Newbie
 
Post: 5
Iscritto il: 11/07/15 07:09

Sponsor
 

Re: Media Excel

Postdi wallace&gromit » 14/07/15 14:38

Ciao Elisa,
prima di proporre formule voglio chiederti: sei sicura di volere fare quello che dici?
Mi spiego: in una tabella di valori per me (e anche per excel) 0 significa che è stata rilevata l'assenza dell'oggetto cercato ed è diverso da cella vuota o da un qualche segno che mi dice che non è stata fatta alcuna rilevazione. Quindi questo 0 va inserito nella media.

Se sei sicura che tutti i valori 0 nel tuo foglio in realtà dovrebbero essere celle vuote o altro proporrei piuttosto di fare una sostituzione con l'opzione "Trova e sostituisci" Trova: 0 e sostituisci con "-", cliccare su "sostituisci tutto".

A questo punto le medie non considereranno più quelle celle.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1419
Iscritto il: 16/01/12 14:21

Re: Media Excel

Postdi elisa1987 » 14/07/15 14:59

Il problema è che il file con un cerca.vert mi restituisce #N/D e non mi è possibile fare un trova/sostituisci di #N/D con "-". Soluzioni alternative?
elisa1987
Newbie
 
Post: 5
Iscritto il: 11/07/15 07:09

Re: Media Excel

Postdi alfrimpa » 14/07/15 15:11

Ciao Elisa

Se il problema sono i messaggi di errore li puoi evitare con SE.ERRORE()

=SE.ERRORE(TUAFORMULA;"")

In questo caso se TUAFORMULA restituisce un errore non verrà visualizzato nulla.

Se vuoi visualizzare qualcosa devi cambiare il secondo parametro di SE.ERRORE()
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Media Excel

Postdi CANAPONE » 15/07/15 06:26

Ciao,

non conosco la versione di Excel che hai a disposizione, forse può essere d'aiuto la funzione media.più.se

Codice: Seleziona tutto
=MEDIA.PIÙ.SE($D$4:$D$614;$D$4:$D$614;"<>0";$J$4:$J$614;$BR$4)



Ne approfitto: un caro saluto ad Alfredo da Firenze.
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "Media Excel":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti