Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formattazione condizionale Excel, semaforo consegne

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formattazione condizionale Excel, semaforo consegne

Postdi PelletKW » 12/07/15 13:26

Buongiorno a tutti,
in settimana mi sono imbattuto in un problema relativo alla formattazione condizionale di Excel:
Devo creare un file inerente a degli ordini ricevuti, quindi per ogni riga inserisco il numero d''ordine e nella colonna a fianco inserisco la data di consegna e nella casella adiacente inserisco la data di consegna effettuata.
Mi sarebbe utile che la casella della data di consegna mi si illumini di un colore (tipo giallo) ad una settimana prima della scadenza, che dal giorno della scadenza in poi, ovvero ad ordine scaduto, il colore cambi (ad esempio rosso), e come ciliegina sulla torta che quando in una terza casella sempre sulla stessa riga viene spuntato lo stato di "consegnata" la casella presenti un terzo colore (ad esempio verde).
Per riassumere e schematizzare la cosa più in pratico:
Casella A1: Numero d'ordine (1)
Casella A2: Data di consegna (27 luglio)
in funzione della data odierna la casella A2 resterà "incolore" fino al 19 luglio, dal 20 al 26 compresi diventerà gialla e dal 27 in poi resterà rossa.
Casella A3: Qui verrà inserita la data di consegna effettivamente eseguita che potrà essere in anticipo, in ritardo o potrà combaciare alla data in casella A2, all'inserimento di una data, qualunque essa sia, il sistema dovrebbe rilevare che la consegna (al di la della data) è stata effettuata e di conseguenza dovrebbe portare la casella A2 ad un terzo stato, ad esempio verde.

Ho trovato diverse discussioni sull'argomento formattazione condizionale e smanettando un pò sono riuscito ad ottenere qualche casella colorata, ma sono ben lontano dal risultato che vorrei ottenere :D
Sono nelle vostre mani!
PelletKW
Newbie
 
Post: 2
Iscritto il: 09/07/15 00:55

Sponsor
 

Re: Formattazione condizionale Excel, semaforo consegne

Postdi Flash30005 » 12/07/15 19:32

Ciao PelletKW » e benvenuto nel Forum

Crei la prima condizione in formattazione condizionale con questa formula
Codice: Seleziona tutto
=SE($A$2-OGGI()<=7;1;0)
e metti formato sfondo colore giallo
seconda condizione questa formula
Codice: Seleziona tutto
=SE(OGGI()-$A$2>=0;1;0)
con sfondo colore rosso
Terza condizione
Codice: Seleziona tutto
=SE($A$3<>"";1;0)
colore verde

in questa ultima metterai la spunta su "Interrompi se vera"

Come da immagine
Immagine
url immagine

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Formattazione condizionale Excel, semaforo consegne

Postdi PelletKW » 29/07/15 11:29

Ciao, grazie mille per la dritta.
Ora però mi trovo di fronte a un problema abbastanza stupido:
Per ogni colonna ho le indicazioni di scadenza degli ordini e nella colonna D ho la data di scadenza con la formula del "semaforo".
Come posso copiare la formula per le caselle sottostanti della stessa colonna ma ognuna facente riferimento alle caselle delle righe corrispondenti?
Grazie
PelletKW
Newbie
 
Post: 2
Iscritto il: 09/07/15 00:55

Re: Formattazione condizionale Excel, semaforo consegne

Postdi Anthony47 » 30/07/15 01:54

Devi liminare dalle formule il "$" precedente il numero riga.
Es: non =SE($A$2-OGGI()<=7;1;0)
ma
Codice: Seleziona tutto
=SE($A2-OGGI()<=7;1;0)


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Formattazione condizionale Excel, semaforo consegne":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti