Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL '10] Risultato di 3 variabili.. in una solla cella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL '10] Risultato di 3 variabili.. in una solla cella

Postdi contiend » 21/05/15 15:04

Buongiorno a tutto il forum,
sto cercando supporto per creare una formula che, controllando una tabella specifica, mi riporti il risultato in un unica cella, verificando però 3 possibili variabili.

La tabella è sita in A1:B5,
dove in A1:A5 ci sono 5 nomi.
dove in B1:B5 ci sono 5 numeri.

In D1 la posizione della formula.

Le variabili che possono capitare sono queste:
1 - Nella colonna A, manca un nome (cella vuota) : in questo caso in D1, per ogni nome mancante, dovrebbe darmi un +4
(NB: Se manca il nome in COL A, mancherà SEMPRE il numero in COL B)


2 - Nella colonna B, manca un numero (cella vuota) : in questa caso in D1, per ogni numero mancante, dovrebbe darmi un +2

3 - Nella colonna A manca un nome e nella colonna B manca un numero (sulla stessa riga) : in questa caso in D1, dovrebbe darmi solo un +4 (e non un +4 +2).


Possibile costruire una formula così? :eeh:

Grazie per l'attenzione
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Sponsor
 

Re: [EXCEL '10] Risultato di 3 variabili.. in una solla cell

Postdi ricky53 » 22/05/15 00:30

Ciao,
fai degli esempi con nomi e numeri in modo da farci capire come produci i risultati per le tre regole.

Anche se ho dei dubbi sulle regole (da come hai scritto le regole mi sembra che la "1" e la "3" siano uguali; la "2" è implicita nelle regole 1 e 3 ... insomma non mi tornano le regole)
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [EXCEL '10] Risultato di 3 variabili.. in una solla cell

Postdi wallace&gromit » 22/05/15 07:11

Ciao,
capisco la perplessità di Ricky sulla regola 3 (che ripete la 1), la regola 2 mi sembra univoca.
Non hai specificato cosa succede se i dati sono completi, assumo che D1 valga 0.
In pratica dovrebbe bastare questa formula:
Codice: Seleziona tutto
=SE(A1="";4;SE(B1="";2;0))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: [EXCEL '10] Risultato di 3 variabili.. in una solla cell

Postdi contiend » 22/05/15 08:27

ricky53 ha scritto:Ciao,
fai degli esempi con nomi e numeri in modo da farci capire come produci i risultati per le tre regole.

Anche se ho dei dubbi sulle regole (da come hai scritto le regole mi sembra che la "1" e la "3" siano uguali; la "2" è implicita nelle regole 1 e 3 ... insomma non mi tornano le regole)


Grazie delle risposte innanzitutto.
Riepilogo alcuni casi d'esempio.

:::::::::::::::::::::::::: CASO "ZERO"
Codice: Seleziona tutto
COL A    ----   COL B
Pippo    ----  8       
Miky    ----   6
Gianni    ---- 9 
Sici    ----   3
Ricky    ----  7


D1 = 0

:::::::::::::::::::::::::: CASO "1"
Codice: Seleziona tutto
COL A    ----   COL B
Pippo    ----  8       
          ----   
Gianni    ---- 9 
       ----   
Ricky    ----  7


D1 = 8 (+4 +4)

:::::::::::::::::::::::::: CASO "2"
Codice: Seleziona tutto
COL A    ----   COL B
Pippo    ----         
Miky    ----   6
Gianni    ----   
Sici    ----   3
Ricky    ----  7


D1 = 4 (+2 +2)

:::::::::::::::::::::::::: CASO "3"
In effetti è uguale al CASO 1 :D


wallace&gromit ha scritto:Ciao,
capisco la perplessità di Ricky sulla regola 3 (che ripete la 1), la regola 2 mi sembra univoca.
Non hai specificato cosa succede se i dati sono completi, assumo che D1 valga 0.
In pratica dovrebbe bastare questa formula:
Codice: Seleziona tutto
=SE(A1="";4;SE(B1="";2;0))


Ho provato la tua formula e sembra funzionare correttamente nella singola riga.
Se però seleziono tuta la colonna mi da errore:
Codice: Seleziona tutto
=SE(A1:A5="";4;SE(B1:B5="";2;0))


Come posso strutturarla?
Windows 10
OFFICE 2010
Avatar utente
contiend
Utente Senior
 
Post: 145
Iscritto il: 20/04/09 17:45

Re: [EXCEL '10] Risultato di 3 variabili.. in una solla cell

Postdi wallace&gromit » 22/05/15 10:30

pensavo ad una formula riga per riga dove dopo fai il totale.
Ma se vuoi una sola formula puoi usare questa:
Codice: Seleziona tutto
=CONTA.SE(B1:B5;"")*2+CONTA.SE(A1:A5;"")*2
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL '10] Risultato di 3 variabili.. in una solla cella":


Chi c’è in linea

Visitano il forum: Marius44 e 19 ospiti