Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

fare una macro o formula in excel per fare la media di numer

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

fare una macro o formula in excel per fare la media di numer

Postdi vale2882 » 13/05/15 11:40

Buongiorno a tutti!Ho questo piccolo problema e ho bisogno del vostro grnade aiuto.Ho diversi fogli in una cartella con due colonne su ognuno.Nella prima colonna ho diverse righe con numeri che partono da 21, 2345678, 22,3456732424 e così via. In colonna 2 ho delle quantità. Vorrei fare in colonna 1 la media dei numeri che hanno le prime due cifre uguali e sommare i relativi numeri presenti in colonna 2.
Esempio
Col.1 Col.2
21,34556 2
22,56433 4
22,45999 1
22,34111 3
Come risultato avere:
21,3456 2
media(22,56422,22,45999...) 8
Grazie mille a tutti!!!
vale2882
Utente Junior
 
Post: 98
Iscritto il: 29/07/14 18:41

Sponsor
 

Re: fare una macro o formula in excel per fare la media di n

Postdi wallace&gromit » 13/05/15 16:05

ciao,
assumo che "le prime due cifre" significhi sempre il numero intero senza decimali.
ho inserito da A2 a C5 i valori che hai scritto, in C2 e C3 ho scritto 21 e 22, in D2 ho inserito la formula matriciale:
Codice: Seleziona tutto
=MEDIA(SE(INT($A$2:$A$5)=C2;$A$2:$A$5))

e in E2 un'altra formula matriciale:
Codice: Seleziona tutto
=SOMMA(SE(INT($A$2:$A$5)=C2;$B$2:$B$5))

poi trascino in giù
mi sembra che funzionino, anche se il risultato della media dei 22,... a me dà 22,45514.

Conosci le formule matriciali? Una volta inserite nelle celle invece di premere solo enter devi premere la sequenza Ctrl + Maiusc + Enter e appaiono delle parentesi graffe
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: fare una macro o formula in excel per fare la media di n

Postdi vale2882 » 13/05/15 16:10

Ciao grazie mille per l'aiuto!!!Forse ho scritto male:Nella prima colonna ho numeri decimali tipo 21,234....23,456.Quindi non funzionerebbe come hai detto giusto?Grazie!!
vale2882
Utente Junior
 
Post: 98
Iscritto il: 29/07/14 18:41

Re: fare una macro o formula in excel per fare la media di n

Postdi wallace&gromit » 13/05/15 16:14

Proprio in questo caso funziona!
se invece ti interessano le prime due cifre di un numero sopra al 100 o sotto a 10 allora cambia.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "fare una macro o formula in excel per fare la media di numer":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti