Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula di ricerca a tre condizioni su due dimensioni

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula di ricerca a tre condizioni su due dimensioni

Postdi ldf » 22/04/15 14:11

Salute a tutti.

Mi sto scervellando per trovare la formula di cui allo file:

http://www.filedropper.com/formuladiric ... mensioni_1

In pratica ho:
Tassi
Età maggiore di… fino a… Non fumatore Fumatore
0 25 1,15 1,27 Età 37
26 30 1,32 1,45 Fumatore
31 35 1,46 1,61
36 40 1,53 1,68
altri...
61 64 Riservato Riservato

Quale formula individua il tasso 1,68, corrispondente a un trentasettenne fumatore, cioè >=36 e <=40?

Non è una priorità assoluta, se la formula accetta anche il testo "riservato", è più comodo, altrimenti mi arrangio in qualche modo.

Tentato vie tipo INDICE+CONFRONTA, SCARTO, SOMMA.PIU.SE da combinare con altre formule... ricerche in rete e sul Walkenbach anche tra formule matriciali. Insomma, sono convinto di perdermi in un bicchier d'acqua, ma ci ho messo un sacco di tempo, senza andare avanti.

Grazie 1.000 fin d'ora se qualcuno può aiutarmi.
ldf
Newbie
 
Post: 9
Iscritto il: 01/04/15 19:44

Sponsor
 

Re: Formula di ricerca a tre condizioni su due dimensioni

Postdi ricky53 » 22/04/15 16:37

Ciao,
prova con questa formula
Codice: Seleziona tutto
=CERCA.VERT(G3; $A$3:$D$11; SE(G2="Fumatore";  4; 3); 1)
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Formula di ricerca a tre condizioni su due dimensioni

Postdi ninai » 22/04/15 17:54

un saluto a voi
oltre all'ottima formula di Ricky , alcune delle molte alternative possibili:

=INDICE(C3:D11;CONFRONTA(G3;A3:A11);1+(G2="Fumatore"))

=SCARTO(C3;CONFRONTA(G3;A3:A11)-1;--(G2="fumatore"))

=INDICE(C3:D11;INT((G3-21)/5)+1;1+(G2="Fumatore"))

=INDIRETTO(INDIRIZZO(INT((G3-21)/5)+3;3+(G2="Fumatore")))

=CERCA.ORIZZ(1+(G2="fumatore");C3:D11;CONFRONTA(G3;A3:A11))
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Formula di ricerca a tre condizioni su due dimensioni

Postdi ricky53 » 22/04/15 21:04

Ciao,
Ninai ti ha dato ben 5 soluzioni. Ottimo ed un grande BRAVO a lui.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Formula di ricerca a tre condizioni su due dimensioni

Postdi ninai » 22/04/15 22:46

"Bravo" ma "spriscialoro", non ho ben verificato le mie proposte, qualcuna non è del tutto corretta.
La parte INT((G3-21)/5) , che vorrebbe identificare la riga, non funziona per valori <21 o >65. Pertanto, la terza proposta va annullata e la quarta va modificata in:
=INDIRETTO(INDIRIZZO(CONFRONTA(G3;A3:A11)+2;3+(G2="Fumatore")))

Mi scuso per la superficialità ma non sempre ho l'accortezza di verificare bene, grazie a Richy per la segnalazione
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Formula di ricerca a tre condizioni su due dimensioni

Postdi ldf » 23/04/15 13:07

Salute a tutti e un grazie grandissimo!

Avevo dimenticati di flaggare per ricevere la segnalazione di nuove risposte, sono venuto a curiosare e ne ho un profluvio.

Adesso mi metto a provarle e scelgo la più simpatica :D .

Certo che se voi ne avete trovate tante in quattro e quattr'otto e io nessunaq in ore, vuol dire che non sono messo benissimo. Speriamo col tempo...

Grazie ancora a tutti
ldf
Newbie
 
Post: 9
Iscritto il: 01/04/15 19:44

Re: Formula di ricerca a tre condizioni su due dimensioni

Postdi ricky53 » 23/04/15 13:57

Ciao,
non mollare e col tempo e con il dovuto impegno il livello della tua conoscenza salirà.

Ti attendiamo per conoscere la tua scelta.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Formula di ricerca a tre condizioni su due dimensioni

Postdi ldf » 23/04/15 14:04

Alla fine ho scelto

=INDICE(C3:D11;CONFRONTA(G3;A3:A11);1+(G2="Fumatore"))

di ninai; l'unico motivo, del tutto insignificante, è che ho usato la combinazione INDICE CONFRONTA da altre parti nel foglio: una specie di estetica simmetrica un po' alla supercazzula di tognazziana memoria :-)

Un saluto cordialissimo a tutti
ldf
Newbie
 
Post: 9
Iscritto il: 01/04/15 19:44

Re: Formula di ricerca a tre condizioni su due dimensioni

Postdi ricky53 » 23/04/15 15:28

Ciao,
bene.
Alla prossima, buon proseguimento e buon apprendimento.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "Formula di ricerca a tre condizioni su due dimensioni":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti