Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel]Formula con SE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel]Formula con SE

Postdi claudia80 » 01/04/15 12:26

Salve a Tutti, sono nuova in questo forum posso già dirvi che siete grandi per quello che ho letto, vi seguo da un po di tempo, ma solo ora mi sono iscritta per porvi una domanda.
Sto usando excel e sto alle prime armi, ora ho bisogno di inserire una condizione in una cella, però non so come fare, provo a spiegarmi

soppuniamo che nella cella A1 ho un numero ipotiziamo 3 e nella cella B1 un altro numero ipotiziamo 2 nella cella C1 ci metto funzione somma ed è molto semplice ottenendo valore 5, ora pero nella cella H10 ho messo un badget tipo 100 e nella cella H11 inserisco una formula dove mi prende il valore della cella H10 e lo somma alla cella C1, anche qui molto semplice, però ho bisogno di una condizione più o meno del tipo che SE nella cella D1 io scrivo si lui mi aggiunge alla cella H11 la somma in questi casi farebbe 105, se io gli dico No lui mi scala alla cella H11 la somma e in questi casi mi da 95, SE invece la lascio vuota la cella H11 dovrà rimanere uguale e quindi 100.

Sicuramente sono stata molto contorta e spero che qualcuno riesca a capirmi

Grazie a tutti
claudia80
Utente Junior
 
Post: 23
Iscritto il: 01/04/15 11:52

Sponsor
 

Postdi alfrimpa » 01/04/15 13:50

Ciao Claudia e benvenuta nel forum.

Premesso che hai sbagliato sezione; avresti dovuto postare in "Applicazioni Office Windows" in E1 metti questa formula:

Codice: Seleziona tutto
=SE(D1="";"";SE(D1="si";C1+H10;SE(D1="no";H10)))


che vuol dire:

se D1 è vuota non restituisce nulla
se D1 è uguale a "si" fa la somma tra C1 e H10
se D1 è uguale a "no" restituisce H10

Spero di aver interpretato bene il tuo quesito.

Alfredo
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Postdi claudia80 » 01/04/15 14:57

Ciao Alf e grazie per la risposta, la formula in parte funziona, e quindi nella cella E1 mi compare 5 se scrivo Si, 0 se scrivo No e va benissimo, ma poi se non scrivo nulla mi da FALSO e qui ci vorrei cella vuota.

Puoi spostare il post se qui non è la sezione giusta?
claudia80
Utente Junior
 
Post: 23
Iscritto il: 01/04/15 11:52

Postdi alfrimpa » 01/04/15 15:03

No Claudia la formula fa proprio questo ( e te l'ho anche scritto :) )

Infatti la parte iniziale della formula

=SE(D1="";"";.... vuol dire che se D1 = a vuoto restituisci vuoto (le doppie virgolette stanno per vuoto)

La formula (prima di proportela) l'ho testata e funzionava correttamente.

Non sono un Moderatore quindi non posso spostare la discussione; magari la prossima che apri falla in "Applicazioni Office Windows"

Alfredo
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: [Excel]Formula con SE

Postdi claudia80 » 01/04/15 16:54

Alfredo, grazie per le tue risposte, solo che forse mi sono spiegata male io,

Budget 100 in H10 (Questo valore deve aggiornarsi ogni volta dove sottraggo sempre A1, in questi casi 97, ma se Scrivo SI lui poi mi deve aggiungere 5 sarebbe 102)

A1 = 3
B1 = 2
C1 = Somma A1 + B1


se D1 è uguale a "si" fa la somma tra C1 e H10 (in questi casi però non la fa, dovrebbe dare 102)
se D1 è uguale a "no" (qui H10 rimanere 97)

e così via per tutte le righe, che man mano H10 si aggiorna ed avrò un progressivo gestonale
claudia80
Utente Junior
 
Post: 23
Iscritto il: 01/04/15 11:52

Re: [Excel]Formula con SE

Postdi Flash30005 » 01/04/15 19:07

Ciao Claudia e benvenuta nel Forum anche da parte mia

Prova così
Codice: Seleziona tutto
=SE(D1="";H$10;SE(D1="si";C1+H$10;SE(D1="no";H$10-C1)))


Se, invece, vuoi il conto scalare devi togliere il simbolo "$" nella formula
Codice: Seleziona tutto
=SE(D1="";H10;SE(D1="si";C1+H10;SE(D1="no";H10-C1)))


Fai sapere
ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [Excel]Formula con SE

Postdi claudia80 » 04/04/15 08:22

Grazie Flash, ho fatto come mi dicevi ed ho risolto, sei stato gentilissimo !!!
claudia80
Utente Junior
 
Post: 23
Iscritto il: 01/04/15 11:52


Torna a Applicazioni Office Windows


Topic correlati a "[Excel]Formula con SE":


Chi c’è in linea

Visitano il forum: Nessuno e 25 ospiti