Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Confrontare dati con cerca.vert

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Confrontare dati con cerca.vert

Postdi Geppo2011 » 31/03/15 13:28

Salve
avrei bisogno d' aiuto con una formula.
In un foglio di excel denominato "Magazzino" ho inserito nella colonna AQ un 'elenco di prodotti,circa 100, e nelle colonne adiacenti una seri di dati e formule relativi ai prodotti.Ho nominato questa serie di celle "Limitazioni" Tra questi dati, nella colonna BB ho inserito come dato la quantità max di prodotto consentita. In un altro foglio, denominato "Registro" nella colonna B devo inserire il nome del prodotto e nella colonna D la dose utilizzata.
Nella colonna H ho creato questa formula

=SE(CERCA.VERT(B20;Limitazioni;12;FALSO)<D20;"Errore Dose";"")

con questa formula riesco a confrontare la dose inserita in col. D con la dose max consentita. Se è minore non mi appare nessun messaggio di errore, se invece il dato inserito supera la dose max nella cella della col H appare il messaggio "Errore Dose".
Quando però nella col.B del foglio registro non è presente nessun dato in col. H appare il messaggio #N/D Ho provato a modificare la formula aggiungendo la funzione VAL.NON.DISP ma non funziona. Ho fatto vari tentativi pensando ad un errore di sintassi ma niente da fare.

Potete aiutarmi?

Grazie
Geppo2011
Utente Junior
 
Post: 29
Iscritto il: 01/09/11 23:08

Sponsor
 

Re: Confrontare dati con cerca.vert

Postdi wallace&gromit » 31/03/15 13:46

ciao,
sei finito nel settore sbagliato: c'è una sezione apposita per i programmi office, magari un amministratore può spostare il messaggio.
Comunque puoi risolvere semplicemente aggiungendo un SE:
Codice: Seleziona tutto
=SE(B20="";"";SE(CERCA.VERT(B20;Limitazioni;12;FALSO)<D20;"Errore Dose";""))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Confrontare dati con cerca.vert

Postdi hydra » 31/03/15 13:46

Sposto
Avatar utente
hydra
Moderatore
 
Post: 7002
Iscritto il: 19/07/04 08:06
Località: Vallis Duplavis

Re: Confrontare dati con cerca.vert

Postdi Geppo2011 » 31/03/15 22:40

Ho provato la formula postata e ora funziona tutto.
Chiedo scusa per aver sbagliato sezione nel porre il problema, starò più attento in futuro.

Grazie infinite per l' aiuto.

Saluti Geppo2011
Geppo2011
Utente Junior
 
Post: 29
Iscritto il: 01/09/11 23:08


Torna a Applicazioni Office Windows


Topic correlati a "Confrontare dati con cerca.vert":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti