Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cercare testo abbreviato

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cercare testo abbreviato

Postdi dome10 » 12/03/15 15:38

Salve ragazzi,ho un problema,ho due fogli nel primo ho una tabella con nomi e numeri (colonna H i nomi, colonna I numeri), nel secondo foglio ho un altra tabella (Colonna AC nomi , colonna AD vuota), devo cercare i dati con i nomi uguali è portarli nel secondo foglio.Alora ho fatto questa formula: "=SE($AC6="";"";SE.ERRORE(CERCA.VERT($AC6;Foglio1!$H:$L;2;FALSO);""))"; fa il suo dovere ma se nei nomi del foglio 2 ci sono nomi con punto es"Vitesse Arnh." e nel primo foglio " Vitesse Arnhem " non riconosce cosi no mi da il valore.Spero di essere stato chiaro.Grazie
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04

Sponsor
 

Re: Cercare testo abbreviato

Postdi peppo55 » 12/03/15 16:07

Ciao dome10,

prova a mettere due asterischi nella formula cerca verticale

CERCA.VERT(*$AC6*;
peppo

Excel 2010
peppo55
Utente Senior
 
Post: 154
Iscritto il: 30/09/12 13:51

Re: Cercare testo abbreviato

Postdi dome10 » 12/03/15 16:15

Gia provato mi dava errore.Grazie peppo55
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04

Re: Cercare testo abbreviato

Postdi colcoz » 12/03/15 16:55

non vorrei dire una cavolata, ma se metti "vero" al posto di "falso" nella formula del cerca.vert dovrebbe ricercare il valore approssimato e non quello completamente uguale.
colcoz
Utente Junior
 
Post: 27
Iscritto il: 06/02/15 15:23

Re: Cercare testo abbreviato

Postdi dome10 » 12/03/15 17:02

No colcoz , se metto "vero" mi da a tutte le celle vuote.Grazie
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04

Re: Cercare testo abbreviato

Postdi colcoz » 12/03/15 17:14

questo è il cerca.vert corretto:

CERCA.VERT("*" & $AC6 & "*";Foglio1!$H:$L;2;FALSO)
colcoz
Utente Junior
 
Post: 27
Iscritto il: 06/02/15 15:23

Re: Cercare testo abbreviato

Postdi dome10 » 12/03/15 17:48

colcoz ho fatto con la formula CERCA.VERT("*" & $AC6 & "*";Foglio1!$H:$L;2;FALSO) ma il problema persiste. (nel foglio2 cella AL6 è vuota)
ti allego due immagini
foglio1:
Immagine
url immagine
foglio2
Immagine
host immagini
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04

Re: Cercare testo abbreviato

Postdi colcoz » 12/03/15 17:57

l'errore te lo riporta per via del "." alla fine del valore da cercare. dovresti ricercarlo senza il punto finale in modo che il valore risulti una troncatura di quello completo. ora provo a vedere se trovo una formula per toglierti il punto finale.
colcoz
Utente Junior
 
Post: 27
Iscritto il: 06/02/15 15:23

Re: Cercare testo abbreviato

Postdi colcoz » 12/03/15 18:05

usa questa di formula:
=SE.ERRORE(CERCA.VERT("*" & $AC6 & "*";Foglio1!$H:$L;2;FALSO);CERCA.VERT("*" & STRINGA.ESTRAI($AC6;1;LUNGHEZZA($AC6)-1) & "*";Foglio1!$H:$L;2;FALSO))

praticamente ti estrae il carattere approssimativo senza il punto finale.
colcoz
Utente Junior
 
Post: 27
Iscritto il: 06/02/15 15:23

Re: Cercare testo abbreviato

Postdi dome10 » 12/03/15 22:08

Ciao colcoz,ho usa la tua formula:
=SE.ERRORE(CERCA.VERT("*" & $AC6 & "*";Foglio1!$H:$L;2;FALSO);CERCA.VERT("*" & STRINGA.ESTRAI($AC6;1;LUNGHEZZA($AC6)-1) & "*";Foglio1!$H:$L;2;FALSO))
ti allego immagine
il risultato è ok,(in verde) ma ora riscontro due problemi, il primo è che mi mette due zero hai dati in percentuali(rosso),ed il secondo non trovando il nome nel foglio1 mi da errore #nd(rosso)
Immagine
url immagine
Grazie
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04

Re: Cercare testo abbreviato

Postdi Anthony47 » 12/03/15 22:38

Ti suggerisco di pubblicare un file con dei dati reali, altrimenti secondo me si lavora alla cieca.
Potresti allegare il file su cui si presentano gli errori che hai appena evidenziato.
Per le istruzioni guarda qui: viewtopic.php?f=26&t=103893&p=605487#p605487

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cercare testo abbreviato

Postdi dome10 » 12/03/15 23:09

ok ,Anthony47 , ecco il file.
http://www.filedropper.com/prova_71
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04

Re: Cercare testo abbreviato

Postdi Anthony47 » 13/03/15 00:00

Da quello che vedo, quelle colonne sono formattate "percentuale", per cui il 30 restituito dalla formula e' "visualizzato" come 3000%. Formatta come "Generale" e i valori verranno visualizzati correttamente.

Quanto al #N/D si tratta della normale risposta di Cerca.Vert a una ricerca negativa; se preferisci vedere qualche cosa di diverso allora usa Se.Errore:
Codice: Seleziona tutto
=Se.Errore(LaFormula;QuelCheVuoiVedereInCasoDiErrore)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cercare testo abbreviato

Postdi colcoz » 13/03/15 09:58

buongiorno Dome,
questo è un accrocchione di formule che dovrebbe risolvere gli altri due problemi.

dimmi se ti va bene.

=SE.ERRORE(SE($AD6="";"";SE.ERRORE(CERCA.VERT("*" & $AD6 & "*";Foglio1!$H:$L;2;FALSO);SE.ERRORE(CERCA.VERT("*" & STRINGA.ESTRAI($AD6;1;LUNGHEZZA($AD6)-1) & "*";Foglio1!$H:$L;2;FALSO);)))/100;"")

ciao
colcoz
Utente Junior
 
Post: 27
Iscritto il: 06/02/15 15:23

Re: Cercare testo abbreviato

Postdi dome10 » 13/03/15 14:16

Grazie Anthony47 e colcoz, per i vostri aiuti, colcoz la formula postata e ok.Ora mi manca solo di creare un' altro foglio creare un archivio.Grazie di tutto
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04

Re: Cercare testo abbreviato

Postdi Anthony47 » 13/03/15 14:23

Mi permetto di osservare che quel 3000%, segnalato come anomalia della formula, e' la visualizzazione errata del valore corretto estratto dalla formula (30); quindi non bisogna cambiare la formula ma la formattazione di cella.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cercare testo abbreviato

Postdi dome10 » 13/03/15 14:46

Anthony47 ha scritto:Mi permetto di osservare che quel 3000%, segnalato come anomalia della formula, e' la visualizzazione errata del valore corretto estratto dalla formula (30); quindi non bisogna cambiare la formula ma la formattazione di cella.

Ciao a tutti.

Si Anthony47, ho cambiato formattazione alla cella ed dalla formula di colcoz ho eliminato "/100" finale.
' =SE.ERRORE(SE($AC7="";"";SE.ERRORE(CERCA.VERT("*" & $AC7 & "*";Foglio1!$H:$L;2;FALSO);SE.ERRORE(CERCA.VERT("*" & STRINGA.ESTRAI($AC7;1;LUNGHEZZA($AC7)-1) & "*";Foglio1!$H:$L;2;FALSO);)));"")' ed ora è ok.Grazie
dome10
Utente Junior
 
Post: 16
Iscritto il: 05/03/15 15:04

Re: Cercare testo abbreviato

Postdi Flash30005 » 16/03/15 03:14

Quando inserite formule o codice Vba in un post
utilizzate il Tag Code che si trova nella testata del messaggio che state editando
in maniera da avere questa finestra
Codice: Seleziona tutto
 =SE.ERRORE(SE($AC7="";"";SE.ERRORE(CERCA.VERT("*" & $AC7 & "*";Foglio1!$H:$L;2;FALSO);SE.ERRORE(CERCA.VERT("*" & STRINGA.ESTRAI($AC7;1;LUNGHEZZA($AC7)-1) & "*";Foglio1!$H:$L;2;FALSO);)));"")


altrimenti si rischia di avere pensare di digitare un 8 con a fianco una parentesi "8)" e invece nel post apparirà questa emoticon 8)

Inoltre sarebbe opportuno effettuare sempre l'anteprima del messaggio prima dell'invio, l'anteprima vi permetterà di vedere se il post è correttamente scritto prima dell'invio

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-


Torna a Applicazioni Office Windows


Topic correlati a "Cercare testo abbreviato":


Chi c’è in linea

Visitano il forum: Marius44, raimea e 16 ospiti