Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel 2013] Inserimento Formula Vba Excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel 2013] Inserimento Formula Vba Excel

Postdi saxas » 22/02/15 10:27

Salve a tutti,
vorre realizzare una macro che mi inserisca una formula da vba

la formula è la seguente
Codice: Seleziona tutto
=SOMMA.PIÙ.SE(Tipo!J3:J104;Tipo!B3:B104;A6:A22;Tipo!C3:C104;B6:B22;Tipo!D3:D104;C6:C22)


inserendola con la seguente macro

in pratica, nella variabile "Tipo" che si trova nella colonna 2 ho il nome del foglio da cui prelevare i dati, e a cui fare riferimento
Codice: Seleziona tutto
Sub InserisciFormula()
Sheets("Riepilogo").Select
EndRiga = Cells(Rows.count, 1).End(xlUp).Row
    For XX = 6 To EndRiga
        Tipo = Cells(XX, 2).Value
        RigPar = Worksheets(Tipo).Cells(Rows.count, 1).End(xlUp).Row
        Cells(XX, 4).FormulaLocal = "=SOMMA.PIÙ.SE( & Tipo & !J3: J & RigPar & ; & Tipo & !B3: B & RigPar &  A6: A & EndRiga & ; & Tipo & !C3: C & RigPar & ; B6: B & EndRiga &  ; & Tipo & !D3: D & RigPar & ; C6: C & EndRiga &  )"
    Next XX
End Sub


ma ovviamente mi da errore di run time
come posso modificare la formula per poterla far funzionare
ringrazio per l'aiuto
Win10 - Office 2016 Ita
saxas
Utente Junior
 
Post: 48
Iscritto il: 14/11/13 16:58

Sponsor
 

Re: [Excel 2013] Inserimento Formula Vba Excel

Postdi Anthony47 » 22/02/15 13:05

Devi solo mettere i separatori di stringa dove servono e aggiungere un paio di ";". Quindi probabilmente
Codice: Seleziona tutto
        Cells(XX, 4).FormulaLocal = "=SOMMA.PIÙ.SE(" & Tipo & "!J3:J" & RigPar & ";" & Tipo & "!B3:B" & RigPar & ";A6:A" & EndRiga & ";" & Tipo & "!C3:C" & RigPar & ";B6:B" & EndRiga & ";" & Tipo & "!D3:D" & RigPar & ";C6:C" & EndRiga & ")"


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel 2013] Inserimento Formula Vba Excel

Postdi saxas » 22/02/15 15:50

Grazie funziona perfettamente
Win10 - Office 2016 Ita
saxas
Utente Junior
 
Post: 48
Iscritto il: 14/11/13 16:58


Torna a Applicazioni Office Windows


Topic correlati a "[Excel 2013] Inserimento Formula Vba Excel":


Chi c’è in linea

Visitano il forum: Nessuno e 15 ospiti